- Resync with upstream sources (#857236).
This commit is contained in:
parent
575bb8c6d7
commit
3cb79f751c
2
.gitignore
vendored
2
.gitignore
vendored
@ -42,3 +42,5 @@ glibc-2.14-394-g8f3b1ff
|
|||||||
/glibc-2.16.90-d22e28b0.tar.gz
|
/glibc-2.16.90-d22e28b0.tar.gz
|
||||||
/glibc-2.16.90-a0bbdad3-fedora.tar.gz
|
/glibc-2.16.90-a0bbdad3-fedora.tar.gz
|
||||||
/glibc-2.16.90-a0bbdad3.tar.gz
|
/glibc-2.16.90-a0bbdad3.tar.gz
|
||||||
|
/glibc-2.16.90-97bc38d7-fedora.tar.gz
|
||||||
|
/glibc-2.16.90-97bc38d7.tar.gz
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
diff -Nrup a/stdio-common/Makefile b/stdio-common/Makefile
|
diff -Nrup a/stdio-common/Makefile b/stdio-common/Makefile
|
||||||
--- a/stdio-common/Makefile 2012-06-30 13:12:34.000000000 -0600
|
--- a/stdio-common/Makefile 2012-09-14 14:31:29.000000000 -0600
|
||||||
+++ b/stdio-common/Makefile 2012-07-25 23:24:40.562730023 -0600
|
+++ b/stdio-common/Makefile 2012-09-14 14:41:50.837749196 -0600
|
||||||
@@ -57,7 +57,7 @@ tests := tstscanf test_rdwr test-popen t
|
@@ -57,7 +57,7 @@ tests := tstscanf test_rdwr test-popen t
|
||||||
bug19 bug19a tst-popen2 scanf13 scanf14 scanf15 bug20 bug21 bug22 \
|
bug19 bug19a tst-popen2 scanf13 scanf14 scanf15 bug20 bug21 bug22 \
|
||||||
scanf16 scanf17 tst-setvbuf1 tst-grouping bug23 bug24 \
|
scanf16 scanf17 tst-setvbuf1 tst-grouping bug23 bug24 \
|
||||||
bug-vfprintf-nargs tst-long-dbl-fphex tst-fphex-wide tst-sprintf3 \
|
bug-vfprintf-nargs tst-long-dbl-fphex tst-fphex-wide tst-sprintf3 \
|
||||||
- bug25
|
- bug25 tst-printf-round
|
||||||
+ bug25 bug23-2 bug23-3
|
+ bug25 tst-printf-round bug23-2 bug23-3
|
||||||
|
|
||||||
test-srcs = tst-unbputc tst-printf
|
test-srcs = tst-unbputc tst-printf
|
||||||
|
|
||||||
diff -Nrup a/stdio-common/bug23-2.c b/stdio-common/bug23-2.c
|
diff -Nrup a/stdio-common/bug23-2.c b/stdio-common/bug23-2.c
|
||||||
--- a/stdio-common/bug23-2.c 1969-12-31 17:00:00.000000000 -0700
|
--- a/stdio-common/bug23-2.c 1969-12-31 17:00:00.000000000 -0700
|
||||||
+++ b/stdio-common/bug23-2.c 2012-07-25 23:23:52.732948658 -0600
|
+++ b/stdio-common/bug23-2.c 2012-09-14 14:41:27.832840375 -0600
|
||||||
@@ -0,0 +1,70 @@
|
@@ -0,0 +1,70 @@
|
||||||
+#include <stdio.h>
|
+#include <stdio.h>
|
||||||
+#include <string.h>
|
+#include <string.h>
|
||||||
@ -86,7 +86,7 @@ diff -Nrup a/stdio-common/bug23-2.c b/stdio-common/bug23-2.c
|
|||||||
+#include "../test-skeleton.c"
|
+#include "../test-skeleton.c"
|
||||||
diff -Nrup a/stdio-common/bug23-3.c b/stdio-common/bug23-3.c
|
diff -Nrup a/stdio-common/bug23-3.c b/stdio-common/bug23-3.c
|
||||||
--- a/stdio-common/bug23-3.c 1969-12-31 17:00:00.000000000 -0700
|
--- a/stdio-common/bug23-3.c 1969-12-31 17:00:00.000000000 -0700
|
||||||
+++ b/stdio-common/bug23-3.c 2012-07-25 23:23:52.752948566 -0600
|
+++ b/stdio-common/bug23-3.c 2012-09-14 14:41:27.884840169 -0600
|
||||||
@@ -0,0 +1,45076 @@
|
@@ -0,0 +1,45076 @@
|
||||||
+#include <stdio.h>
|
+#include <stdio.h>
|
||||||
+#include <string.h>
|
+#include <string.h>
|
||||||
@ -45165,8 +45165,8 @@ diff -Nrup a/stdio-common/bug23-3.c b/stdio-common/bug23-3.c
|
|||||||
+#include "../test-skeleton.c"
|
+#include "../test-skeleton.c"
|
||||||
+
|
+
|
||||||
diff -Nrup a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
|
diff -Nrup a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
|
||||||
--- a/stdio-common/vfprintf.c 2012-07-25 23:23:15.865117380 -0600
|
--- a/stdio-common/vfprintf.c 2012-09-14 14:31:29.000000000 -0600
|
||||||
+++ b/stdio-common/vfprintf.c 2012-07-25 23:27:19.072943588 -0600
|
+++ b/stdio-common/vfprintf.c 2012-09-14 14:41:27.891840141 -0600
|
||||||
@@ -243,6 +243,12 @@ vfprintf (FILE *s, const CHAR_T *format,
|
@@ -243,6 +243,12 @@ vfprintf (FILE *s, const CHAR_T *format,
|
||||||
/* For the argument descriptions, which may be allocated on the heap. */
|
/* For the argument descriptions, which may be allocated on the heap. */
|
||||||
void *args_malloced = NULL;
|
void *args_malloced = NULL;
|
||||||
@ -45180,7 +45180,7 @@ diff -Nrup a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
|
|||||||
/* This table maps a character into a number representing a
|
/* This table maps a character into a number representing a
|
||||||
class. In each step there is a destination label for each
|
class. In each step there is a destination label for each
|
||||||
class. */
|
class. */
|
||||||
@@ -1652,8 +1658,8 @@ do_positional:
|
@@ -1685,8 +1691,8 @@ do_positional:
|
||||||
size_t nspecs = 0;
|
size_t nspecs = 0;
|
||||||
/* A more or less arbitrary start value. */
|
/* A more or less arbitrary start value. */
|
||||||
size_t nspecs_size = 32 * sizeof (struct printf_spec);
|
size_t nspecs_size = 32 * sizeof (struct printf_spec);
|
||||||
@ -45190,7 +45190,7 @@ diff -Nrup a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
|
|||||||
/* The number of arguments the format string requests. This will
|
/* The number of arguments the format string requests. This will
|
||||||
determine the size of the array needed to store the argument
|
determine the size of the array needed to store the argument
|
||||||
attributes. */
|
attributes. */
|
||||||
@@ -1694,10 +1700,25 @@ do_positional:
|
@@ -1727,10 +1733,25 @@ do_positional:
|
||||||
{
|
{
|
||||||
/* Extend the array of format specifiers. */
|
/* Extend the array of format specifiers. */
|
||||||
struct printf_spec *old = specs;
|
struct printf_spec *old = specs;
|
||||||
@ -45218,7 +45218,7 @@ diff -Nrup a/stdio-common/vfprintf.c b/stdio-common/vfprintf.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Parse the format specifier. */
|
/* Parse the format specifier. */
|
||||||
@@ -2012,6 +2033,8 @@ do_positional:
|
@@ -2045,6 +2066,8 @@ do_positional:
|
||||||
}
|
}
|
||||||
|
|
||||||
all_done:
|
all_done:
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.16.90-a0bbdad3
|
%define glibcsrcdir glibc-2.16.90-97bc38d7
|
||||||
%define glibcversion 2.16.90
|
%define glibcversion 2.16.90
|
||||||
### glibc.spec.in follows:
|
### glibc.spec.in follows:
|
||||||
%define run_glibc_tests 1
|
%define run_glibc_tests 1
|
||||||
@ -27,7 +27,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 10%{?dist}
|
Release: 11%{?dist}
|
||||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||||
# Things that are linked directly into dynamically linked programs
|
# Things that are linked directly into dynamically linked programs
|
||||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||||
@ -1349,6 +1349,9 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 14 2012 Jeff Law <law@redhat.com> - 2.16.90-11
|
||||||
|
- Resync with upstream sources (#857236).
|
||||||
|
|
||||||
* Sat Sep 8 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.16.90-10
|
* Sat Sep 8 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 2.16.90-10
|
||||||
- Enable ports to fix FTBFS on ARM
|
- Enable ports to fix FTBFS on ARM
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
68dc97f2a6ee4c4f0514061a6d56f1e0 glibc-2.16.90-a0bbdad3-fedora.tar.gz
|
2a6afa44c3e6ea7871c7889b8eb1ef93 glibc-2.16.90-97bc38d7-fedora.tar.gz
|
||||||
f168314e1eb0d8819a483bbbc516d904 glibc-2.16.90-a0bbdad3.tar.gz
|
48e371df9064491afef4f3fd8df54d6e glibc-2.16.90-97bc38d7.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user