Auto-sync with upstream branch master

Upstream commit bad7a0c81f501fbbcc79af9eaa4b8254441c4a1f

- copy_file_range: New function to copy file data
- nptl: Consolidate pthread_{timed,try}join{_np}
- nptl: Implement pthread_self in libc.so (swbz#22635)
- math: Provide a C++ version of iseqsig (swbz#22377)
- elf: remove redundant __libc_enable_secure check from fillin_rpath
- math: Avoid signed shift overflow in pow (swbz#21309)
- x86: Add feature_1 to tcbhead_t (swbz#22563)
- x86: Update cancel_jmp_buf to match __jmp_buf_tag (swbz#22563)
- ld.so: Examine GLRO to detect inactive loader (swbz#20204)
- nscd: Fix nscd readlink argument aliasing (swbz#22446)
- elf: do not substitute dst in $LD_LIBRARY_PATH twice (swbz#22627)
- ldconfig: set LC_COLLATE to C (swbz#22505)
- math: New generic sincosf
- powerpc: st{r,p}cpy optimization for aligned strings
- CVE-2017-1000409: Count in expanded path in _dl_init_path (#1524867)
- CVE-2017-1000408: Compute correct array size in _dl_init_paths (#1524867)
- x86-64: Remove sysdeps/x86_64/fpu/s_cosf.S
- aarch64: Improve strcmp unaligned performance
This commit is contained in:
Florian Weimer 2017-12-22 16:13:39 +01:00
parent a5a7506242
commit 39b4cfbcf1
3 changed files with 38 additions and 13 deletions

View File

@ -13,24 +13,27 @@
# The general idea for the design is in the leading comment
# in the source code.
#
Index: glibc-2.24-163-ge299076/nptl/Makefile
===================================================================
--- glibc-2.24-163-ge299076.orig/nptl/Makefile
+++ glibc-2.24-163-ge299076/nptl/Makefile
@@ -30,7 +30,8 @@ install-lib-ldscripts := libpthread.so
diff --git a/nptl/Makefile b/nptl/Makefile
index 59295e413a2fa8bf..a62c939a01c200a5 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -31,7 +31,9 @@ install-lib-ldscripts := libpthread.so
routines = alloca_cutoff forward libc-lowlevellock libc-cancellation \
libc-cleanup libc_pthread_init libc_multiple_threads \
- register-atfork unregister-atfork
+ register-atfork unregister-atfork libc_pthread_atfork
- register-atfork unregister-atfork pthread_self
+ register-atfork unregister-atfork pthread_self \
+ libc_pthread_atfork
+static-only-routines += libc_pthread_atfork
shared-only-routines = forward
# We need to provide certain routines for compatibility with existing
Index: glibc-2.24-163-ge299076/nptl/libc_pthread_atfork.c
===================================================================
diff --git a/nptl/libc_pthread_atfork.c b/nptl/libc_pthread_atfork.c
new file mode 100644
index 0000000000000000..667049aa38f6b390
--- /dev/null
+++ glibc-2.24-163-ge299076/nptl/libc_pthread_atfork.c
+++ b/nptl/libc_pthread_atfork.c
@@ -0,0 +1,54 @@
+/* Copyright (C) 2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.26.9000-969-g243b63337c
%define glibcsrcdir glibc-2.26.9000-1033-gbad7a0c81f
%define glibcversion 2.26.9000
%define glibcrelease 33%{?dist}
%define glibcrelease 34%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
@ -2034,6 +2034,28 @@ fi
%endif
%changelog
* Fri Dec 22 2017 Florian Weimer <fweimer@redhat.com> - 2.26.9000-34
- Auto-sync with upstream branch master,
commit bad7a0c81f501fbbcc79af9eaa4b8254441c4a1f:
- copy_file_range: New function to copy file data
- nptl: Consolidate pthread_{timed,try}join{_np}
- nptl: Implement pthread_self in libc.so (swbz#22635)
- math: Provide a C++ version of iseqsig (swbz#22377)
- elf: remove redundant __libc_enable_secure check from fillin_rpath
- math: Avoid signed shift overflow in pow (swbz#21309)
- x86: Add feature_1 to tcbhead_t (swbz#22563)
- x86: Update cancel_jmp_buf to match __jmp_buf_tag (swbz#22563)
- ld.so: Examine GLRO to detect inactive loader (swbz#20204)
- nscd: Fix nscd readlink argument aliasing (swbz#22446)
- elf: do not substitute dst in $LD_LIBRARY_PATH twice (swbz#22627)
- ldconfig: set LC_COLLATE to C (swbz#22505)
- math: New generic sincosf
- powerpc: st{r,p}cpy optimization for aligned strings
- CVE-2017-1000409: Count in expanded path in _dl_init_path (#1524867)
- CVE-2017-1000408: Compute correct array size in _dl_init_paths (#1524867)
- x86-64: Remove sysdeps/x86_64/fpu/s_cosf.S
- aarch64: Improve strcmp unaligned performance
* Wed Dec 13 2017 Florian Weimer <fweimer@redhat.com> - 2.26.9000-33
- Remove power6 platform directory (#1522675)

View File

@ -1 +1 @@
SHA512 (glibc-2.26.9000-969-g243b63337c.tar.gz) = 216b99a3b6ca0bb4c78a9ce659cd825a7b2ccda6a46c4249872f0c2b6443408b1742caf91b636471fd886cd59987dd377f5c82cdb31ad73221bf41a0a64a5253
SHA512 (glibc-2.26.9000-1033-gbad7a0c81f.tar.gz) = b9a51940a3d16b9d80369b978c36d7228302fb57c4da0fd59ad7beb9f3389b5843d06778b0fc8b40304e5adbabcab3e63fbd163d11f79b4a79e89517bc5bdbb5