Auto-sync with upstream master.

Upstream commit: e299076fefd9649f78f853865d4745043e50813c
This commit is contained in:
Carlos O'Donell 2016-09-20 23:28:04 -04:00
parent 77d2ac8e00
commit 36702a1359
4 changed files with 27 additions and 26 deletions

View File

@ -13,26 +13,24 @@
# The general idea for the design is in the leading comment # The general idea for the design is in the leading comment
# in the source code. # in the source code.
# #
diff --git a/nptl/sysdeps/unix/sysv/linux/Makefile b/nptl/sysdeps/unix/sysv/linux/Makefile Index: glibc-2.24-163-ge299076/nptl/Makefile
index 6078e2d..36fd50b 100644 ===================================================================
--- a/nptl/Makefile --- glibc-2.24-163-ge299076.orig/nptl/Makefile
+++ b/nptl/Makefile +++ glibc-2.24-163-ge299076/nptl/Makefile
@@ -18,7 +18,9 @@ @@ -30,7 +30,8 @@ install-lib-ldscripts := libpthread.so
routines = alloca_cutoff forward libc-lowlevellock libc-cancellation \ routines = alloca_cutoff forward libc-lowlevellock libc-cancellation \
libc-cleanup libc_pthread_init libc_multiple_threads \ libc-cleanup libc_pthread_init libc_multiple_threads \
- register-atfork unregister-atfork - register-atfork unregister-atfork
+ register-atfork unregister-atfork libc_pthread_atfork + register-atfork unregister-atfork libc_pthread_atfork
+
+static-only-routines += libc_pthread_atfork +static-only-routines += libc_pthread_atfork
shared-only-routines = forward shared-only-routines = forward
libpthread-routines = nptl-init vars events version pt-interp \ # We need to provide certain routines for compatibility with existing
diff --git a/nptl/libc_pthread_atfork.c b/nptl/libc_pthread_atfork.c Index: glibc-2.24-163-ge299076/nptl/libc_pthread_atfork.c
new file mode 100644 ===================================================================
index 0000000..667049a
--- /dev/null --- /dev/null
+++ b/nptl/libc_pthread_atfork.c +++ glibc-2.24-163-ge299076/nptl/libc_pthread_atfork.c
@@ -0,0 +1,54 @@ @@ -0,0 +1,54 @@
+/* Copyright (C) 2013 Free Software Foundation, Inc. +/* Copyright (C) 2013 Free Software Foundation, Inc.
+ This file is part of the GNU C Library. + This file is part of the GNU C Library.

View File

@ -24,30 +24,30 @@ Date: Thu Mar 31 11:26:55 2016 +0200
* elf/Makefile (tests): Add tst-dlsym-error. * elf/Makefile (tests): Add tst-dlsym-error.
(tst-dlsym-error): Link against libdl. (tst-dlsym-error): Link against libdl.
Index: b/elf/Makefile Index: glibc-2.24-163-ge299076/elf/Makefile
=================================================================== ===================================================================
--- a/elf/Makefile --- glibc-2.24-163-ge299076.orig/elf/Makefile
+++ b/elf/Makefile +++ glibc-2.24-163-ge299076/elf/Makefile
@@ -149,7 +149,7 @@ tests += loadtest restest1 preloadtest l @@ -149,7 +149,7 @@ tests += loadtest restest1 preloadtest l
tst-nodelete) \ tst-nodelete) \
tst-initorder tst-initorder2 tst-relsort1 tst-null-argv \ tst-initorder tst-initorder2 tst-relsort1 tst-null-argv \
tst-ptrguard1 tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \ tst-ptrguard1 tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \
- tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error - tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error tst-noload
+ tst-nodelete2 tst-audit11 tst-audit12 + tst-nodelete2 tst-audit11 tst-audit12 tst-noload
# reldep9 # reldep9
ifeq ($(build-hardcoded-path-in-tests),yes) ifeq ($(build-hardcoded-path-in-tests),yes)
tests += tst-dlopen-aout tests += tst-dlopen-aout
@@ -1258,5 +1258,3 @@ $(objpfx)tst-prelink-cmp.out: tst-prelin @@ -1266,5 +1266,3 @@ $(objpfx)tst-prelink-cmp.out: tst-prelin
$(objpfx)tst-ldconfig-X.out : tst-ldconfig-X.sh $(objpfx)ldconfig $(objpfx)tst-ldconfig-X.out : tst-ldconfig-X.sh $(objpfx)ldconfig
$(SHELL) $< '$(common-objpfx)' '$(test-wrapper)' '$(test-wrapper-env)' > $@; \ $(SHELL) $< '$(common-objpfx)' '$(test-wrapper)' '$(test-wrapper-env)' > $@; \
$(evaluate-test) $(evaluate-test)
- -
-$(objpfx)tst-dlsym-error: $(libdl) -$(objpfx)tst-dlsym-error: $(libdl)
Index: b/elf/dl-lookup.c Index: glibc-2.24-163-ge299076/elf/dl-lookup.c
=================================================================== ===================================================================
--- a/elf/dl-lookup.c --- glibc-2.24-163-ge299076.orig/elf/dl-lookup.c
+++ b/elf/dl-lookup.c +++ glibc-2.24-163-ge299076/elf/dl-lookup.c
@@ -858,6 +858,7 @@ _dl_lookup_symbol_x (const char *undef_n @@ -862,6 +862,7 @@ _dl_lookup_symbol_x (const char *undef_n
if (__glibc_unlikely (current_value.s == NULL)) if (__glibc_unlikely (current_value.s == NULL))
{ {
if ((*ref == NULL || ELFW(ST_BIND) ((*ref)->st_info) != STB_WEAK) if ((*ref == NULL || ELFW(ST_BIND) ((*ref)->st_info) != STB_WEAK)
@ -55,9 +55,9 @@ Index: b/elf/dl-lookup.c
&& !(GLRO(dl_debug_mask) & DL_DEBUG_UNUSED)) && !(GLRO(dl_debug_mask) & DL_DEBUG_UNUSED))
{ {
/* We could find no value for a strong reference. */ /* We could find no value for a strong reference. */
Index: b/elf/tst-dlsym-error.c Index: glibc-2.24-163-ge299076/elf/tst-dlsym-error.c
=================================================================== ===================================================================
--- a/elf/tst-dlsym-error.c --- glibc-2.24-163-ge299076.orig/elf/tst-dlsym-error.c
+++ /dev/null +++ /dev/null
@@ -1,114 +0,0 @@ @@ -1,114 +0,0 @@
-/* Test error reporting for dlsym, dlvsym failures. -/* Test error reporting for dlsym, dlvsym failures.

View File

@ -1,6 +1,6 @@
%define glibcsrcdir glibc-2.24-106-g4d72808 %define glibcsrcdir glibc-2.24-163-ge299076
%define glibcversion 2.24.90 %define glibcversion 2.24.90
%define glibcrelease 6%{?dist} %define glibcrelease 7%{?dist}
# Pre-release tarballs are pulled in from git using a command that is # Pre-release tarballs are pulled in from git using a command that is
# effectively: # effectively:
# #
@ -2266,6 +2266,9 @@ rm -f *.filelist*
%endif %endif
%changelog %changelog
* Tue Sep 20 2016 Carlos O'Donell <carlos@systemhalted.org> - 2.24.90-7
- Auto-sync with upstream master.
* Thu Sep 01 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-6 * Thu Sep 01 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-6
- Auto-sync with upstream master, - Auto-sync with upstream master,
commit 4d728087ef8cc826b05bd21d0c74d4eca9b1a27d, fixing: commit 4d728087ef8cc826b05bd21d0c74d4eca9b1a27d, fixing:

View File

@ -1 +1 @@
287d4343060baf701c8283cc158bf238 glibc-2.24-106-g4d72808.tar.gz f28e91a29f8c5f26a0a592be9b1cd592 glibc-2.24-163-ge299076.tar.gz