Resync with upstream master
This commit is contained in:
parent
db59a6354f
commit
35b7508499
@ -1,24 +0,0 @@
|
|||||||
diff -pruN glibc-2.18/nscd/aicache.c glibc-2.18.new/nscd/aicache.c
|
|
||||||
--- glibc-2.18/nscd/aicache.c 2013-08-11 04:22:55.000000000 +0530
|
|
||||||
+++ glibc-2.18.new/nscd/aicache.c 2013-08-26 11:10:25.843470413 +0530
|
|
||||||
@@ -25,6 +25,7 @@
|
|
||||||
#include <time.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <sys/mman.h>
|
|
||||||
+#include <resolv/res_hconf.h>
|
|
||||||
|
|
||||||
#include "dbg_log.h"
|
|
||||||
#include "nscd.h"
|
|
||||||
@@ -100,8 +101,11 @@ addhstaiX (struct database_dyn *db, int
|
|
||||||
no_more = __nss_database_lookup ("hosts", NULL,
|
|
||||||
"dns [!UNAVAIL=return] files", &nip);
|
|
||||||
|
|
||||||
+ /* Initialize configurations. */
|
|
||||||
+ if (__builtin_expect (!_res_hconf.initialized, 0))
|
|
||||||
+ _res_hconf_init ();
|
|
||||||
if (__res_maybe_init (&_res, 0) == -1)
|
|
||||||
- no_more = 1;
|
|
||||||
+ no_more = 1;
|
|
||||||
|
|
||||||
/* If we are looking for both IPv4 and IPv6 address we don't want
|
|
||||||
the lookup functions to automatically promote IPv4 addresses to
|
|
@ -1,78 +0,0 @@
|
|||||||
|
|
||||||
2012-03-07 Jeff Law <law@redhat.com>
|
|
||||||
|
|
||||||
* elf/dl-reloc.c (_dl_relocate_object): Move code to allocate
|
|
||||||
l_reloc_result prior to calling ELF_DYNAMIC_RELOCATE.
|
|
||||||
|
|
||||||
diff -rup a/elf/dl-reloc.c b/elf/dl-reloc.c
|
|
||||||
--- a/elf/dl-reloc.c 2012-01-01 05:16:32.000000000 -0700
|
|
||||||
+++ b/elf/dl-reloc.c 2012-03-06 15:41:56.486242640 -0700
|
|
||||||
@@ -238,32 +238,9 @@ _dl_relocate_object (struct link_map *l,
|
|
||||||
/* String table object symbols. */
|
|
||||||
const char *strtab = (const void *) D_PTR (l, l_info[DT_STRTAB]);
|
|
||||||
|
|
||||||
- /* This macro is used as a callback from the ELF_DYNAMIC_RELOCATE code. */
|
|
||||||
-#define RESOLVE_MAP(ref, version, r_type) \
|
|
||||||
- (ELFW(ST_BIND) ((*ref)->st_info) != STB_LOCAL \
|
|
||||||
- ? ((__builtin_expect ((*ref) == l->l_lookup_cache.sym, 0) \
|
|
||||||
- && elf_machine_type_class (r_type) == l->l_lookup_cache.type_class) \
|
|
||||||
- ? (bump_num_cache_relocations (), \
|
|
||||||
- (*ref) = l->l_lookup_cache.ret, \
|
|
||||||
- l->l_lookup_cache.value) \
|
|
||||||
- : ({ lookup_t _lr; \
|
|
||||||
- int _tc = elf_machine_type_class (r_type); \
|
|
||||||
- l->l_lookup_cache.type_class = _tc; \
|
|
||||||
- l->l_lookup_cache.sym = (*ref); \
|
|
||||||
- const struct r_found_version *v = NULL; \
|
|
||||||
- if ((version) != NULL && (version)->hash != 0) \
|
|
||||||
- v = (version); \
|
|
||||||
- _lr = _dl_lookup_symbol_x (strtab + (*ref)->st_name, l, (ref), \
|
|
||||||
- scope, v, _tc, \
|
|
||||||
- DL_LOOKUP_ADD_DEPENDENCY, NULL); \
|
|
||||||
- l->l_lookup_cache.ret = (*ref); \
|
|
||||||
- l->l_lookup_cache.value = _lr; })) \
|
|
||||||
- : l)
|
|
||||||
-
|
|
||||||
-#include "dynamic-link.h"
|
|
||||||
-
|
|
||||||
- ELF_DYNAMIC_RELOCATE (l, lazy, consider_profiling, skip_ifunc);
|
|
||||||
-
|
|
||||||
+ /* ELF_DYNAMIC_RELOCATE may need to examine l_reloc_result
|
|
||||||
+ when handling MACHINE_IRELATIVE relocs. So we must
|
|
||||||
+ allocate l_reloc_result prior to calling ELF_DYNAMIC_RELOCATE. */
|
|
||||||
#ifndef PROF
|
|
||||||
if (__builtin_expect (consider_profiling, 0))
|
|
||||||
{
|
|
||||||
@@ -290,6 +267,32 @@ _dl_relocate_object (struct link_map *l,
|
|
||||||
}
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
+
|
|
||||||
+ /* This macro is used as a callback from the ELF_DYNAMIC_RELOCATE code. */
|
|
||||||
+#define RESOLVE_MAP(ref, version, r_type) \
|
|
||||||
+ (ELFW(ST_BIND) ((*ref)->st_info) != STB_LOCAL \
|
|
||||||
+ ? ((__builtin_expect ((*ref) == l->l_lookup_cache.sym, 0) \
|
|
||||||
+ && elf_machine_type_class (r_type) == l->l_lookup_cache.type_class) \
|
|
||||||
+ ? (bump_num_cache_relocations (), \
|
|
||||||
+ (*ref) = l->l_lookup_cache.ret, \
|
|
||||||
+ l->l_lookup_cache.value) \
|
|
||||||
+ : ({ lookup_t _lr; \
|
|
||||||
+ int _tc = elf_machine_type_class (r_type); \
|
|
||||||
+ l->l_lookup_cache.type_class = _tc; \
|
|
||||||
+ l->l_lookup_cache.sym = (*ref); \
|
|
||||||
+ const struct r_found_version *v = NULL; \
|
|
||||||
+ if ((version) != NULL && (version)->hash != 0) \
|
|
||||||
+ v = (version); \
|
|
||||||
+ _lr = _dl_lookup_symbol_x (strtab + (*ref)->st_name, l, (ref), \
|
|
||||||
+ scope, v, _tc, \
|
|
||||||
+ DL_LOOKUP_ADD_DEPENDENCY, NULL); \
|
|
||||||
+ l->l_lookup_cache.ret = (*ref); \
|
|
||||||
+ l->l_lookup_cache.value = _lr; })) \
|
|
||||||
+ : l)
|
|
||||||
+
|
|
||||||
+#include "dynamic-link.h"
|
|
||||||
+
|
|
||||||
+ ELF_DYNAMIC_RELOCATE (l, lazy, consider_profiling, skip_ifunc);
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Mark the object so we know this work has been done. */
|
|
@ -1,23 +0,0 @@
|
|||||||
#
|
|
||||||
# Posted upstream:
|
|
||||||
# http://sourceware.org/ml/libc-ports/2013-08/msg00053.html
|
|
||||||
#
|
|
||||||
# 2013-08-28 Kyle McMartin <kyle@redhat.com>
|
|
||||||
# Carlos O'Donell <carlos@redhat.com>
|
|
||||||
#
|
|
||||||
# * sysdeps/arm/dl-machine [!RTLD_BOOTSTRAP] (elf_machine_rel):
|
|
||||||
# Pass GLRO(dl_hwcap) to the IFUNC resolver.
|
|
||||||
#
|
|
||||||
diff --git a/ports/sysdeps/arm/dl-machine.h b/ports/sysdeps/arm/dl-machine.h
|
|
||||||
index d251527..85dba67 100644
|
|
||||||
--- a/ports/sysdeps/arm/dl-machine.h
|
|
||||||
+++ b/ports/sysdeps/arm/dl-machine.h
|
|
||||||
@@ -503,7 +503,7 @@ elf_machine_rel (struct link_map *map, const Elf32_Rel *reloc,
|
|
||||||
break;
|
|
||||||
case R_ARM_IRELATIVE:
|
|
||||||
value = map->l_addr + *reloc_addr;
|
|
||||||
- value = ((Elf32_Addr (*) (void)) value) ();
|
|
||||||
+ value = ((Elf32_Addr (*) (int)) value) (GLRO(dl_hwcap));
|
|
||||||
*reloc_addr = value;
|
|
||||||
break;
|
|
||||||
#endif
|
|
@ -1,302 +0,0 @@
|
|||||||
commit 91ce40854d0b7f865cf5024ef95a8026b76096f3
|
|
||||||
Author: Florian Weimer <fweimer@redhat.com>
|
|
||||||
Date: Fri Aug 16 09:38:52 2013 +0200
|
|
||||||
|
|
||||||
CVE-2013-4237, BZ #14699: Buffer overflow in readdir_r
|
|
||||||
|
|
||||||
* sysdeps/posix/dirstream.h (struct __dirstream): Add errcode
|
|
||||||
member.
|
|
||||||
* sysdeps/posix/opendir.c (__alloc_dir): Initialize errcode
|
|
||||||
member.
|
|
||||||
* sysdeps/posix/rewinddir.c (rewinddir): Reset errcode member.
|
|
||||||
* sysdeps/posix/readdir_r.c (__READDIR_R): Enforce NAME_MAX limit.
|
|
||||||
Return delayed error code. Remove GETDENTS_64BIT_ALIGNED
|
|
||||||
conditional.
|
|
||||||
* sysdeps/unix/sysv/linux/wordsize-64/readdir_r.c: Do not define
|
|
||||||
GETDENTS_64BIT_ALIGNED.
|
|
||||||
* sysdeps/unix/sysv/linux/i386/readdir64_r.c: Likewise.
|
|
||||||
* manual/filesys.texi (Reading/Closing Directory): Document
|
|
||||||
ENAMETOOLONG return value of readdir_r. Recommend readdir more
|
|
||||||
strongly.
|
|
||||||
* manual/conf.texi (Limits for Files): Add portability note to
|
|
||||||
NAME_MAX, PATH_MAX.
|
|
||||||
(Pathconf): Add portability note for _PC_NAME_MAX, _PC_PATH_MAX.
|
|
||||||
|
|
||||||
diff --git a/manual/conf.texi b/manual/conf.texi
|
|
||||||
index 7eb8b36..c720063 100644
|
|
||||||
--- a/manual/conf.texi
|
|
||||||
+++ b/manual/conf.texi
|
|
||||||
@@ -1149,6 +1149,9 @@ typed ahead as input. @xref{I/O Queues}.
|
|
||||||
@deftypevr Macro int NAME_MAX
|
|
||||||
The uniform system limit (if any) for the length of a file name component, not
|
|
||||||
including the terminating null character.
|
|
||||||
+
|
|
||||||
+@strong{Portability Note:} On some systems, @theglibc{} defines
|
|
||||||
+@code{NAME_MAX}, but does not actually enforce this limit.
|
|
||||||
@end deftypevr
|
|
||||||
|
|
||||||
@comment limits.h
|
|
||||||
@@ -1157,6 +1160,9 @@ including the terminating null character.
|
|
||||||
The uniform system limit (if any) for the length of an entire file name (that
|
|
||||||
is, the argument given to system calls such as @code{open}), including the
|
|
||||||
terminating null character.
|
|
||||||
+
|
|
||||||
+@strong{Portability Note:} @Theglibc{} does not enforce this limit
|
|
||||||
+even if @code{PATH_MAX} is defined.
|
|
||||||
@end deftypevr
|
|
||||||
|
|
||||||
@cindex limits, pipe buffer size
|
|
||||||
@@ -1476,6 +1482,9 @@ Inquire about the value of @code{POSIX_REC_MIN_XFER_SIZE}.
|
|
||||||
Inquire about the value of @code{POSIX_REC_XFER_ALIGN}.
|
|
||||||
@end table
|
|
||||||
|
|
||||||
+@strong{Portability Note:} On some systems, @theglibc{} does not
|
|
||||||
+enforce @code{_PC_NAME_MAX} or @code{_PC_PATH_MAX} limits.
|
|
||||||
+
|
|
||||||
@node Utility Limits
|
|
||||||
@section Utility Program Capacity Limits
|
|
||||||
|
|
||||||
diff --git a/manual/filesys.texi b/manual/filesys.texi
|
|
||||||
index 1df9cf2..814c210 100644
|
|
||||||
--- a/manual/filesys.texi
|
|
||||||
+++ b/manual/filesys.texi
|
|
||||||
@@ -444,9 +444,9 @@ symbols are declared in the header file @file{dirent.h}.
|
|
||||||
@comment POSIX.1
|
|
||||||
@deftypefun {struct dirent *} readdir (DIR *@var{dirstream})
|
|
||||||
This function reads the next entry from the directory. It normally
|
|
||||||
-returns a pointer to a structure containing information about the file.
|
|
||||||
-This structure is statically allocated and can be rewritten by a
|
|
||||||
-subsequent call.
|
|
||||||
+returns a pointer to a structure containing information about the
|
|
||||||
+file. This structure is associated with the @var{dirstream} handle
|
|
||||||
+and can be rewritten by a subsequent call.
|
|
||||||
|
|
||||||
@strong{Portability Note:} On some systems @code{readdir} may not
|
|
||||||
return entries for @file{.} and @file{..}, even though these are always
|
|
||||||
@@ -461,19 +461,61 @@ conditions are defined for this function:
|
|
||||||
The @var{dirstream} argument is not valid.
|
|
||||||
@end table
|
|
||||||
|
|
||||||
-@code{readdir} is not thread safe. Multiple threads using
|
|
||||||
-@code{readdir} on the same @var{dirstream} may overwrite the return
|
|
||||||
-value. Use @code{readdir_r} when this is critical.
|
|
||||||
+To distinguish between an end-of-directory condition or an error, you
|
|
||||||
+must set @code{errno} to zero before calling @code{readdir}. To avoid
|
|
||||||
+entering an infinite loop, you should stop reading from the directory
|
|
||||||
+after the first error.
|
|
||||||
+
|
|
||||||
+In POSIX.1-2008, @code{readdir} is not thread-safe. In @theglibc{}
|
|
||||||
+implementation, it is safe to call @code{readdir} concurrently on
|
|
||||||
+different @var{dirstream}s, but multiple threads accessing the same
|
|
||||||
+@var{dirstream} result in undefined behavior. @code{readdir_r} is a
|
|
||||||
+fully thread-safe alternative, but suffers from poor portability (see
|
|
||||||
+below). It is recommended that you use @code{readdir}, with external
|
|
||||||
+locking if multiple threads access the same @var{dirstream}.
|
|
||||||
@end deftypefun
|
|
||||||
|
|
||||||
@comment dirent.h
|
|
||||||
@comment GNU
|
|
||||||
@deftypefun int readdir_r (DIR *@var{dirstream}, struct dirent *@var{entry}, struct dirent **@var{result})
|
|
||||||
-This function is the reentrant version of @code{readdir}. Like
|
|
||||||
-@code{readdir} it returns the next entry from the directory. But to
|
|
||||||
-prevent conflicts between simultaneously running threads the result is
|
|
||||||
-not stored in statically allocated memory. Instead the argument
|
|
||||||
-@var{entry} points to a place to store the result.
|
|
||||||
+This function is a version of @code{readdir} which performs internal
|
|
||||||
+locking. Like @code{readdir} it returns the next entry from the
|
|
||||||
+directory. To prevent conflicts between simultaneously running
|
|
||||||
+threads the result is stored inside the @var{entry} object.
|
|
||||||
+
|
|
||||||
+@strong{Portability Note:} It is recommended to use @code{readdir}
|
|
||||||
+instead of @code{readdir_r} for the following reasons:
|
|
||||||
+
|
|
||||||
+@itemize @bullet
|
|
||||||
+@item
|
|
||||||
+On systems which do not define @code{NAME_MAX}, it may not be possible
|
|
||||||
+to use @code{readdir_r} safely because the caller does not specify the
|
|
||||||
+length of the buffer for the directory entry.
|
|
||||||
+
|
|
||||||
+@item
|
|
||||||
+On some systems, @code{readdir_r} cannot read directory entries with
|
|
||||||
+very long names. If such a name is encountered, @theglibc{}
|
|
||||||
+implementation of @code{readdir_r} returns with an error code of
|
|
||||||
+@code{ENAMETOOLONG} after the final directory entry has been read. On
|
|
||||||
+other systems, @code{readdir_r} may return successfully, but the
|
|
||||||
+@code{d_name} member may not be NUL-terminated or may be truncated.
|
|
||||||
+
|
|
||||||
+@item
|
|
||||||
+POSIX-1.2008 does not guarantee that @code{readdir} is thread-safe,
|
|
||||||
+even when access to the same @var{dirstream} is serialized. But in
|
|
||||||
+current implementations (including @theglibc{}), it is safe to call
|
|
||||||
+@code{readdir} concurrently on different @var{dirstream}s, so there is
|
|
||||||
+no need to use @code{readdir_r} in most multi-threaded programs. In
|
|
||||||
+the rare case that multiple threads need to read from the same
|
|
||||||
+@var{dirstream}, it is still better to use @code{readdir} and external
|
|
||||||
+synchronization.
|
|
||||||
+
|
|
||||||
+@item
|
|
||||||
+It is expected that future versions of POSIX will obsolete
|
|
||||||
+@code{readdir_r} and mandate the level of thread safety for
|
|
||||||
+@code{readdir} which is provided by @theglibc{} and other
|
|
||||||
+implementations today.
|
|
||||||
+@end itemize
|
|
||||||
|
|
||||||
Normally @code{readdir_r} returns zero and sets @code{*@var{result}}
|
|
||||||
to @var{entry}. If there are no more entries in the directory or an
|
|
||||||
@@ -481,15 +523,6 @@ error is detected, @code{readdir_r} sets @code{*@var{result}} to a
|
|
||||||
null pointer and returns a nonzero error code, also stored in
|
|
||||||
@code{errno}, as described for @code{readdir}.
|
|
||||||
|
|
||||||
-@strong{Portability Note:} On some systems @code{readdir_r} may not
|
|
||||||
-return a NUL terminated string for the file name, even when there is no
|
|
||||||
-@code{d_reclen} field in @code{struct dirent} and the file
|
|
||||||
-name is the maximum allowed size. Modern systems all have the
|
|
||||||
-@code{d_reclen} field, and on old systems multi-threading is not
|
|
||||||
-critical. In any case there is no such problem with the @code{readdir}
|
|
||||||
-function, so that even on systems without the @code{d_reclen} member one
|
|
||||||
-could use multiple threads by using external locking.
|
|
||||||
-
|
|
||||||
It is also important to look at the definition of the @code{struct
|
|
||||||
dirent} type. Simply passing a pointer to an object of this type for
|
|
||||||
the second parameter of @code{readdir_r} might not be enough. Some
|
|
||||||
diff --git a/sysdeps/posix/dirstream.h b/sysdeps/posix/dirstream.h
|
|
||||||
index a7a074d..8e8570d 100644
|
|
||||||
--- a/sysdeps/posix/dirstream.h
|
|
||||||
+++ b/sysdeps/posix/dirstream.h
|
|
||||||
@@ -39,6 +39,8 @@ struct __dirstream
|
|
||||||
|
|
||||||
off_t filepos; /* Position of next entry to read. */
|
|
||||||
|
|
||||||
+ int errcode; /* Delayed error code. */
|
|
||||||
+
|
|
||||||
/* Directory block. */
|
|
||||||
char data[0] __attribute__ ((aligned (__alignof__ (void*))));
|
|
||||||
};
|
|
||||||
diff --git a/sysdeps/posix/opendir.c b/sysdeps/posix/opendir.c
|
|
||||||
index ddfc3a7..fc05b0f 100644
|
|
||||||
--- a/sysdeps/posix/opendir.c
|
|
||||||
+++ b/sysdeps/posix/opendir.c
|
|
||||||
@@ -231,6 +231,7 @@ __alloc_dir (int fd, bool close_fd, int flags, const struct stat64 *statp)
|
|
||||||
dirp->size = 0;
|
|
||||||
dirp->offset = 0;
|
|
||||||
dirp->filepos = 0;
|
|
||||||
+ dirp->errcode = 0;
|
|
||||||
|
|
||||||
return dirp;
|
|
||||||
}
|
|
||||||
diff --git a/sysdeps/posix/readdir_r.c b/sysdeps/posix/readdir_r.c
|
|
||||||
index b5a8e2e..8ed5c3f 100644
|
|
||||||
--- a/sysdeps/posix/readdir_r.c
|
|
||||||
+++ b/sysdeps/posix/readdir_r.c
|
|
||||||
@@ -40,6 +40,7 @@ __READDIR_R (DIR *dirp, DIRENT_TYPE *entry, DIRENT_TYPE **result)
|
|
||||||
DIRENT_TYPE *dp;
|
|
||||||
size_t reclen;
|
|
||||||
const int saved_errno = errno;
|
|
||||||
+ int ret;
|
|
||||||
|
|
||||||
__libc_lock_lock (dirp->lock);
|
|
||||||
|
|
||||||
@@ -70,10 +71,10 @@ __READDIR_R (DIR *dirp, DIRENT_TYPE *entry, DIRENT_TYPE **result)
|
|
||||||
bytes = 0;
|
|
||||||
__set_errno (saved_errno);
|
|
||||||
}
|
|
||||||
+ if (bytes < 0)
|
|
||||||
+ dirp->errcode = errno;
|
|
||||||
|
|
||||||
dp = NULL;
|
|
||||||
- /* Reclen != 0 signals that an error occurred. */
|
|
||||||
- reclen = bytes != 0;
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
dirp->size = (size_t) bytes;
|
|
||||||
@@ -106,29 +107,46 @@ __READDIR_R (DIR *dirp, DIRENT_TYPE *entry, DIRENT_TYPE **result)
|
|
||||||
dirp->filepos += reclen;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
- /* Skip deleted files. */
|
|
||||||
+#ifdef NAME_MAX
|
|
||||||
+ if (reclen > offsetof (DIRENT_TYPE, d_name) + NAME_MAX + 1)
|
|
||||||
+ {
|
|
||||||
+ /* The record is very long. It could still fit into the
|
|
||||||
+ caller-supplied buffer if we can skip padding at the
|
|
||||||
+ end. */
|
|
||||||
+ size_t namelen = _D_EXACT_NAMLEN (dp);
|
|
||||||
+ if (namelen <= NAME_MAX)
|
|
||||||
+ reclen = offsetof (DIRENT_TYPE, d_name) + namelen + 1;
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ /* The name is too long. Ignore this file. */
|
|
||||||
+ dirp->errcode = ENAMETOOLONG;
|
|
||||||
+ dp->d_ino = 0;
|
|
||||||
+ continue;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+ /* Skip deleted and ignored files. */
|
|
||||||
}
|
|
||||||
while (dp->d_ino == 0);
|
|
||||||
|
|
||||||
if (dp != NULL)
|
|
||||||
{
|
|
||||||
-#ifdef GETDENTS_64BIT_ALIGNED
|
|
||||||
- /* The d_reclen value might include padding which is not part of
|
|
||||||
- the DIRENT_TYPE data structure. */
|
|
||||||
- reclen = MIN (reclen,
|
|
||||||
- offsetof (DIRENT_TYPE, d_name) + sizeof (dp->d_name));
|
|
||||||
-#endif
|
|
||||||
*result = memcpy (entry, dp, reclen);
|
|
||||||
-#ifdef GETDENTS_64BIT_ALIGNED
|
|
||||||
+#ifdef _DIRENT_HAVE_D_RECLEN
|
|
||||||
entry->d_reclen = reclen;
|
|
||||||
#endif
|
|
||||||
+ ret = 0;
|
|
||||||
}
|
|
||||||
else
|
|
||||||
- *result = NULL;
|
|
||||||
+ {
|
|
||||||
+ *result = NULL;
|
|
||||||
+ ret = dirp->errcode;
|
|
||||||
+ }
|
|
||||||
|
|
||||||
__libc_lock_unlock (dirp->lock);
|
|
||||||
|
|
||||||
- return dp != NULL ? 0 : reclen ? errno : 0;
|
|
||||||
+ return ret;
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef __READDIR_R_ALIAS
|
|
||||||
diff --git a/sysdeps/posix/rewinddir.c b/sysdeps/posix/rewinddir.c
|
|
||||||
index 2935a8e..d4991ad 100644
|
|
||||||
--- a/sysdeps/posix/rewinddir.c
|
|
||||||
+++ b/sysdeps/posix/rewinddir.c
|
|
||||||
@@ -33,6 +33,7 @@ rewinddir (dirp)
|
|
||||||
dirp->filepos = 0;
|
|
||||||
dirp->offset = 0;
|
|
||||||
dirp->size = 0;
|
|
||||||
+ dirp->errcode = 0;
|
|
||||||
#ifndef NOT_IN_libc
|
|
||||||
__libc_lock_unlock (dirp->lock);
|
|
||||||
#endif
|
|
||||||
diff --git a/sysdeps/unix/sysv/linux/i386/readdir64_r.c b/sysdeps/unix/sysv/linux/i386/readdir64_r.c
|
|
||||||
index 8ebbcfd..a7d114e 100644
|
|
||||||
--- a/sysdeps/unix/sysv/linux/i386/readdir64_r.c
|
|
||||||
+++ b/sysdeps/unix/sysv/linux/i386/readdir64_r.c
|
|
||||||
@@ -18,7 +18,6 @@
|
|
||||||
#define __READDIR_R __readdir64_r
|
|
||||||
#define __GETDENTS __getdents64
|
|
||||||
#define DIRENT_TYPE struct dirent64
|
|
||||||
-#define GETDENTS_64BIT_ALIGNED 1
|
|
||||||
|
|
||||||
#include <sysdeps/posix/readdir_r.c>
|
|
||||||
|
|
||||||
diff --git a/sysdeps/unix/sysv/linux/wordsize-64/readdir_r.c b/sysdeps/unix/sysv/linux/wordsize-64/readdir_r.c
|
|
||||||
index 5ed8e95..290f2c8 100644
|
|
||||||
--- a/sysdeps/unix/sysv/linux/wordsize-64/readdir_r.c
|
|
||||||
+++ b/sysdeps/unix/sysv/linux/wordsize-64/readdir_r.c
|
|
||||||
@@ -1,5 +1,4 @@
|
|
||||||
#define readdir64_r __no_readdir64_r_decl
|
|
||||||
-#define GETDENTS_64BIT_ALIGNED 1
|
|
||||||
#include <sysdeps/posix/readdir_r.c>
|
|
||||||
#undef readdir64_r
|
|
||||||
weak_alias (__readdir_r, readdir64_r)
|
|
File diff suppressed because it is too large
Load Diff
26
glibc.spec
26
glibc.spec
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.18
|
%define glibcsrcdir glibc-2.18-79-gbb8ea71
|
||||||
%define glibcversion 2.18
|
%define glibcversion 2.18.90
|
||||||
%define glibcrelease 6%{?dist}
|
%define glibcrelease 1%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
#
|
#
|
||||||
@ -9,7 +9,7 @@
|
|||||||
# gzip -9 $(git describe --match 'glibc-*').tar
|
# gzip -9 $(git describe --match 'glibc-*').tar
|
||||||
#
|
#
|
||||||
# glibc_release_url is only defined when we have a release tarball.
|
# glibc_release_url is only defined when we have a release tarball.
|
||||||
%define glibc_release_url http://ftp.gnu.org/gnu/glibc/
|
# % define glibc_release_url http://ftp.gnu.org/gnu/glibc/
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# If run_glibc_tests is zero then tests are not run for the build.
|
# If run_glibc_tests is zero then tests are not run for the build.
|
||||||
# You must always set run_glibc_tests to one for production builds.
|
# You must always set run_glibc_tests to one for production builds.
|
||||||
@ -183,7 +183,6 @@ Patch0042: %{name}-rh970865.patch
|
|||||||
#
|
#
|
||||||
# Patches from upstream
|
# Patches from upstream
|
||||||
#
|
#
|
||||||
Patch1001: %{name}-rh995841.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Patches submitted, but not yet approved upstream.
|
# Patches submitted, but not yet approved upstream.
|
||||||
@ -200,9 +199,6 @@ Patch2013: %{name}-rh741105.patch
|
|||||||
# Upstream BZ 9954
|
# Upstream BZ 9954
|
||||||
Patch2021: %{name}-rh739743.patch
|
Patch2021: %{name}-rh739743.patch
|
||||||
|
|
||||||
# Upstream BZ 13818
|
|
||||||
Patch2022: %{name}-rh800224.patch
|
|
||||||
|
|
||||||
# Upstream BZ 14247
|
# Upstream BZ 14247
|
||||||
Patch2023: %{name}-rh827510.patch
|
Patch2023: %{name}-rh827510.patch
|
||||||
|
|
||||||
@ -215,12 +211,6 @@ Patch2027: %{name}-rh819430.patch
|
|||||||
#Upstream BZ 14547
|
#Upstream BZ 14547
|
||||||
Patch2028: %{name}-strcoll-cve.patch
|
Patch2028: %{name}-strcoll-cve.patch
|
||||||
|
|
||||||
# Initialize res_hconf in nscd
|
|
||||||
Patch2029: %{name}-rh1000924.patch
|
|
||||||
|
|
||||||
# Pass dl_hwcap to IFUNC resolver on 32-bit ARM.
|
|
||||||
Patch2030: %{name}-rh985342.patch
|
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# End of glibc patches.
|
# End of glibc patches.
|
||||||
##############################################################################
|
##############################################################################
|
||||||
@ -521,7 +511,6 @@ package or when debugging this package.
|
|||||||
%patch0019 -p1
|
%patch0019 -p1
|
||||||
%patch0020 -p1
|
%patch0020 -p1
|
||||||
%patch2021 -p1
|
%patch2021 -p1
|
||||||
%patch2022 -p1
|
|
||||||
%patch2023 -p1
|
%patch2023 -p1
|
||||||
%patch0024 -p1
|
%patch0024 -p1
|
||||||
%patch0025 -p1
|
%patch0025 -p1
|
||||||
@ -537,12 +526,9 @@ package or when debugging this package.
|
|||||||
%patch0035 -p1
|
%patch0035 -p1
|
||||||
%patch0037 -p1
|
%patch0037 -p1
|
||||||
%patch2028 -p1
|
%patch2028 -p1
|
||||||
%patch1001 -p1
|
|
||||||
%patch0040 -p1
|
%patch0040 -p1
|
||||||
%patch0041 -p1
|
%patch0041 -p1
|
||||||
%patch0042 -p1
|
%patch0042 -p1
|
||||||
%patch2029 -p1
|
|
||||||
%patch2030 -p1
|
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
# %%prep - Additional prep required...
|
# %%prep - Additional prep required...
|
||||||
@ -1628,6 +1614,10 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 5 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.18.90-1
|
||||||
|
- Resync with upstream master.
|
||||||
|
- Drop patch for #800224.
|
||||||
|
|
||||||
* Thu Aug 29 2013 Carlos O'Donell <carlos@redhat.com> - 2.18-6
|
* Thu Aug 29 2013 Carlos O'Donell <carlos@redhat.com> - 2.18-6
|
||||||
- Fix Power build (#997531).
|
- Fix Power build (#997531).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user