Drop glibc-arm-hardfloat-3.patch and associated hack
This commit is contained in:
parent
5ca19238f5
commit
27727bd4a9
@ -1,20 +0,0 @@
|
|||||||
diff -Nrup a/elf/dl-load.c b/elf/dl-load.c
|
|
||||||
--- a/elf/dl-load.c 2012-06-06 13:07:41.727524312 -0600
|
|
||||||
+++ b/elf/dl-load.c 2012-06-06 13:11:19.308681002 -0600
|
|
||||||
@@ -2093,10 +2093,14 @@ _dl_map_object (struct link_map *loader,
|
|
||||||
soname = ((const char *) D_PTR (l, l_info[DT_STRTAB])
|
|
||||||
+ l->l_info[DT_SONAME]->d_un.d_val);
|
|
||||||
if (strcmp (name, soname) != 0)
|
|
||||||
- continue;
|
|
||||||
+#ifdef __arm__
|
|
||||||
+ if (strcmp (name, "ld-linux.so.3")
|
|
||||||
+ || strcmp (soname, "ld-linux-armhf.so.3"))
|
|
||||||
+#endif
|
|
||||||
+ continue;
|
|
||||||
|
|
||||||
/* We have a match on a new name -- cache it. */
|
|
||||||
- add_name_to_object (l, soname);
|
|
||||||
+ add_name_to_object (l, name);
|
|
||||||
l->l_soname_added = 1;
|
|
||||||
}
|
|
||||||
|
|
29
glibc.spec
29
glibc.spec
@ -185,10 +185,6 @@ Patch0004: glibc-fedora-ppc-unwind.patch
|
|||||||
# tree so that they're identical for multilib builds
|
# tree so that they're identical for multilib builds
|
||||||
Patch0005: glibc-rh825061.patch
|
Patch0005: glibc-rh825061.patch
|
||||||
|
|
||||||
# Horrible hack, never to be upstreamed. Can go away once the world
|
|
||||||
# has been rebuilt to use the new ld.so path.
|
|
||||||
Patch0006: glibc-arm-hardfloat-3.patch
|
|
||||||
|
|
||||||
# Needs to be sent upstream
|
# Needs to be sent upstream
|
||||||
Patch0009: glibc-fedora-include-bits-ldbl.patch
|
Patch0009: glibc-fedora-include-bits-ldbl.patch
|
||||||
|
|
||||||
@ -282,14 +278,6 @@ Provides: ldconfig
|
|||||||
|
|
||||||
# The dynamic linker supports DT_GNU_HASH
|
# The dynamic linker supports DT_GNU_HASH
|
||||||
Provides: rtld(GNU_HASH)
|
Provides: rtld(GNU_HASH)
|
||||||
|
|
||||||
# This is a short term need until everything is rebuilt in the ARM world
|
|
||||||
# to use the new dynamic linker path
|
|
||||||
%ifarch armv7hl armv7hnl
|
|
||||||
Provides: ld-linux.so.3
|
|
||||||
Provides: ld-linux.so.3(GLIBC_2.4)
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Requires: glibc-common = %{version}-%{release}
|
Requires: glibc-common = %{version}-%{release}
|
||||||
|
|
||||||
%if %{without bootstrap}
|
%if %{without bootstrap}
|
||||||
@ -759,7 +747,6 @@ microbenchmark tests on the system.
|
|||||||
%patch0001 -p1
|
%patch0001 -p1
|
||||||
%patch0004 -p1
|
%patch0004 -p1
|
||||||
%patch0005 -p1
|
%patch0005 -p1
|
||||||
%patch0006 -p1
|
|
||||||
%patch2007 -p1
|
%patch2007 -p1
|
||||||
%patch0009 -p1
|
%patch0009 -p1
|
||||||
%patch0012 -p1
|
%patch0012 -p1
|
||||||
@ -1553,17 +1540,12 @@ rm -rf $RPM_BUILD_ROOT%{_prefix}/share/zoneinfo
|
|||||||
touch -r %{SOURCE2} $RPM_BUILD_ROOT/etc/ld.so.conf
|
touch -r %{SOURCE2} $RPM_BUILD_ROOT/etc/ld.so.conf
|
||||||
touch -r sunrpc/etc.rpc $RPM_BUILD_ROOT/etc/rpc
|
touch -r sunrpc/etc.rpc $RPM_BUILD_ROOT/etc/rpc
|
||||||
|
|
||||||
# We allow undefined symbols in shared libraries because the libraries
|
|
||||||
# referenced at link time here, particularly ld.so, may be different than
|
|
||||||
# the one used at runtime. This is really only needed during the ARM
|
|
||||||
# transition from ld-linux.so.3 to ld-linux-armhf.so.3.
|
|
||||||
pushd build-%{target}
|
pushd build-%{target}
|
||||||
$GCC -Os -g -static -o build-locale-archive %{SOURCE1} \
|
$GCC -Os -g -static -o build-locale-archive %{SOURCE1} \
|
||||||
../build-%{target}/locale/locarchive.o \
|
../build-%{target}/locale/locarchive.o \
|
||||||
../build-%{target}/locale/md5.o \
|
../build-%{target}/locale/md5.o \
|
||||||
-I. -DDATADIR=\"%{_datadir}\" -DPREFIX=\"%{_prefix}\" \
|
-I. -DDATADIR=\"%{_datadir}\" -DPREFIX=\"%{_prefix}\" \
|
||||||
-L../build-%{target} \
|
-L../build-%{target} \
|
||||||
-Wl,--allow-shlib-undefined \
|
|
||||||
-B../build-%{target}/csu/ -lc -lc_nonshared
|
-B../build-%{target}/csu/ -lc -lc_nonshared
|
||||||
install -m 700 build-locale-archive $RPM_BUILD_ROOT%{_prefix}/sbin/build-locale-archive
|
install -m 700 build-locale-archive $RPM_BUILD_ROOT%{_prefix}/sbin/build-locale-archive
|
||||||
popd
|
popd
|
||||||
@ -1577,16 +1559,10 @@ cp posix/gai.conf documentation/
|
|||||||
|
|
||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
# Compatibility symlink
|
# Compatibility symlink
|
||||||
mkdir -p $RPM_BUILD_ROOT/lib
|
mkdir -p $RPM_BUILD_ROOT/libb
|
||||||
ln -sf /%{_lib}/ld64.so.1 $RPM_BUILD_ROOT/lib/ld64.so.1
|
ln -sf /%{_lib}/ld64.so.1 $RPM_BUILD_ROOT/lib/ld64.so.1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Leave a compatibility symlink for the dynamic loader on armhfp targets,
|
|
||||||
# at least until the world gets rebuilt
|
|
||||||
%ifarch armv7hl armv7hnl
|
|
||||||
ln -sf /lib/ld-linux-armhf.so.3 $RPM_BUILD_ROOT/lib/ld-linux.so.3
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%if %{with benchtests}
|
%if %{with benchtests}
|
||||||
# Build benchmark binaries. Ignore the output of the benchmark runs.
|
# Build benchmark binaries. Ignore the output of the benchmark runs.
|
||||||
pushd build-%{target}
|
pushd build-%{target}
|
||||||
@ -2030,9 +2006,6 @@ rm -f *.filelist*
|
|||||||
%ifarch s390x
|
%ifarch s390x
|
||||||
/lib/ld64.so.1
|
/lib/ld64.so.1
|
||||||
%endif
|
%endif
|
||||||
%ifarch armv7hl armv7hnl
|
|
||||||
/lib/ld-linux.so.3
|
|
||||||
%endif
|
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
|
%verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/ld.so.conf
|
%verify(not md5 size mtime) %config(noreplace) /etc/ld.so.conf
|
||||||
%verify(not md5 size mtime) %config(noreplace) /etc/rpc
|
%verify(not md5 size mtime) %config(noreplace) /etc/rpc
|
||||||
|
Loading…
Reference in New Issue
Block a user