Sync with roland/nptl upstream branch
Patches on this branch include nptl as a part of glibc instead of being an addon.
This commit is contained in:
parent
191c4db426
commit
1ea305b6fa
@ -21,9 +21,9 @@ GLIBC_PRIVATE.
|
|||||||
--- a/nptl/Version
|
--- a/nptl/Version
|
||||||
+++ b/nptl/Versions
|
+++ b/nptl/Versions
|
||||||
@@ -30,6 +30,7 @@ libc {
|
@@ -30,6 +30,7 @@ libc {
|
||||||
# Internal libc interface to libpthread
|
__libc_pthread_init;
|
||||||
__libc_dl_error_tsd;
|
__libc_current_sigrtmin_private; __libc_current_sigrtmax_private;
|
||||||
__libc_vfork;
|
__libc_allocate_rtsig_private;
|
||||||
+ __getrlimit;
|
+ __getrlimit;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -15,24 +15,24 @@
|
|||||||
#
|
#
|
||||||
diff --git a/nptl/sysdeps/unix/sysv/linux/Makefile b/nptl/sysdeps/unix/sysv/linux/Makefile
|
diff --git a/nptl/sysdeps/unix/sysv/linux/Makefile b/nptl/sysdeps/unix/sysv/linux/Makefile
|
||||||
index 6078e2d..36fd50b 100644
|
index 6078e2d..36fd50b 100644
|
||||||
--- a/nptl/sysdeps/unix/sysv/linux/Makefile
|
--- a/nptl/Makefile
|
||||||
+++ b/nptl/sysdeps/unix/sysv/linux/Makefile
|
+++ b/nptl/Makefile
|
||||||
@@ -18,7 +18,9 @@
|
@@ -18,7 +18,9 @@
|
||||||
|
|
||||||
ifeq ($(subdir),nptl)
|
routines = alloca_cutoff forward libc-lowlevellock libc-cancellation \
|
||||||
sysdep_routines += register-atfork unregister-atfork libc_pthread_init \
|
libc-cleanup libc_pthread_init libc_multiple_threads \
|
||||||
- libc_multiple_threads
|
- register-atfork unregister-atfork
|
||||||
+ libc_multiple_threads libc_pthread_atfork
|
+ register-atfork unregister-atfork libc_pthread_atfork
|
||||||
+
|
+
|
||||||
+static-only-routines += libc_pthread_atfork
|
+static-only-routines += libc_pthread_atfork
|
||||||
|
shared-only-routines = forward
|
||||||
|
|
||||||
libpthread-sysdep_routines += pt-fork pthread_mutex_cond_lock
|
libpthread-routines = nptl-init vars events version \
|
||||||
|
diff --git a/nptl/libc_pthread_atfork.c b/nptl/libc_pthread_atfork.c
|
||||||
diff --git a/nptl/sysdeps/unix/sysv/linux/libc_pthread_atfork.c b/nptl/sysdeps/unix/sysv/linux/libc_pthread_atfork.c
|
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..667049a
|
index 0000000..667049a
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/nptl/sysdeps/unix/sysv/linux/libc_pthread_atfork.c
|
+++ b/nptl/libc_pthread_atfork.c
|
||||||
@@ -0,0 +1,54 @@
|
@@ -0,0 +1,54 @@
|
||||||
+/* Copyright (C) 2013 Free Software Foundation, Inc.
|
+/* Copyright (C) 2013 Free Software Foundation, Inc.
|
||||||
+ This file is part of the GNU C Library.
|
+ This file is part of the GNU C Library.
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.19-743-g256aa66
|
%define glibcsrcdir glibc-2.19-739-gd6505ce
|
||||||
%define glibcversion 2.19.90
|
%define glibcversion 2.19.90
|
||||||
%define glibcrelease 24%{?dist}
|
%define glibcrelease 25%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
#
|
#
|
||||||
@ -1641,6 +1641,9 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 03 2014 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.19.90-25
|
||||||
|
- Sync with upstream roland/nptl branch.
|
||||||
|
|
||||||
* Wed Jul 02 2014 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.19.90-24
|
* Wed Jul 02 2014 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.19.90-24
|
||||||
- Sync with upstream master.
|
- Sync with upstream master.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user