Auto-sync with upstream branch master
Upstream commit: 1305edd42c44fee6f8660734d2dfa4911ec755d6 - elf: Move post-relocation code of _dl_start into _dl_start_final - misc: Fix rare fortify crash on wchar funcs. [BZ 29030] - elf: Remove unused enum allowmask - scripts/glibcelf.py: Mark as UNSUPPORTED on Python 3.5 and earlier - x86: Optimize {str|wcs}rchr-evex - x86: Optimize {str|wcs}rchr-avx2 - x86: Optimize {str|wcs}rchr-sse2 - benchtests: Improve bench-strrchr - x86-64: Fix SSE2 memcmp and SSSE3 memmove for x32 - Default to --with-default-link=no (bug 25812) - scripts: Add glibcelf.py module - Add locale for syr_SY - elf: Move elf_dynamic_do_Rel RTLD_BOOTSTRAP branches outside - m68k: Handle fewer relocations for RTLD_BOOTSTRAP (#BZ29071) - nptl: Fix pthread_cancel cancelhandling atomic operations - x86: Fix missing __wmemcmp def for disable-multiarch build - elf: Remove __libc_init_secure
This commit is contained in:
parent
b72082ecfb
commit
1be721e225
@ -12,10 +12,11 @@ additional locales.
|
||||
* Tue Mar 26 2002 Jakub Jelinek <jakub@redhat.com> 2.2.5-28
|
||||
- add a couple of .ISO-8859-15 locales (#61908)
|
||||
|
||||
diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
--- a/localedata/SUPPORTED 2012-11-25 12:59:31.000000000 -0700
|
||||
+++ b/localedata/SUPPORTED 2012-11-26 12:58:43.298223018 -0700
|
||||
@@ -89,6 +89,7 @@ cy_GB.UTF-8/UTF-8 \
|
||||
diff --git a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
index c8b63cc2fe2b4547..32088fdef06a14a3 100644
|
||||
--- a/localedata/SUPPORTED
|
||||
+++ b/localedata/SUPPORTED
|
||||
@@ -103,6 +103,7 @@ cy_GB.UTF-8/UTF-8 \
|
||||
cy_GB/ISO-8859-14 \
|
||||
da_DK.UTF-8/UTF-8 \
|
||||
da_DK/ISO-8859-1 \
|
||||
@ -23,7 +24,7 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
de_AT.UTF-8/UTF-8 \
|
||||
de_AT/ISO-8859-1 \
|
||||
de_AT@euro/ISO-8859-15 \
|
||||
@@ -121,6 +122,7 @@ en_DK.UTF-8/UTF-8 \
|
||||
@@ -140,6 +141,7 @@ en_DK.UTF-8/UTF-8 \
|
||||
en_DK/ISO-8859-1 \
|
||||
en_GB.UTF-8/UTF-8 \
|
||||
en_GB/ISO-8859-1 \
|
||||
@ -31,7 +32,7 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
en_HK.UTF-8/UTF-8 \
|
||||
en_HK/ISO-8859-1 \
|
||||
en_IE.UTF-8/UTF-8 \
|
||||
@@ -136,6 +138,7 @@ en_SG.UTF-8/UTF-8 \
|
||||
@@ -157,6 +159,7 @@ en_SG.UTF-8/UTF-8 \
|
||||
en_SG/ISO-8859-1 \
|
||||
en_US.UTF-8/UTF-8 \
|
||||
en_US/ISO-8859-1 \
|
||||
@ -39,11 +40,11 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
en_ZA.UTF-8/UTF-8 \
|
||||
en_ZA/ISO-8859-1 \
|
||||
en_ZM/UTF-8 \
|
||||
@@ -385,6 +388,7 @@ sv_FI/ISO-8859-1 \
|
||||
@@ -425,6 +428,7 @@ sv_FI/ISO-8859-1 \
|
||||
sv_FI@euro/ISO-8859-15 \
|
||||
sv_SE.UTF-8/UTF-8 \
|
||||
sv_SE/ISO-8859-1 \
|
||||
+sv_SE.ISO-8859-15/ISO-8859-15 \
|
||||
sw_KE/UTF-8 \
|
||||
sw_TZ/UTF-8 \
|
||||
szl_PL/UTF-8 \
|
||||
syr/UTF-8 \
|
||||
|
36
glibc.spec
36
glibc.spec
@ -1,4 +1,4 @@
|
||||
%global glibcsrcdir glibc-2.35.9000-392-g78fb888273
|
||||
%global glibcsrcdir glibc-2.35.9000-409-g1305edd42c
|
||||
%global glibcversion 2.35.9000
|
||||
# Pre-release tarballs are pulled in from git using a command that is
|
||||
# effectively:
|
||||
@ -152,7 +152,7 @@ end}
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
|
||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||
# libraries.
|
||||
@ -513,6 +513,10 @@ The sources for all locales provided in the language packs.
|
||||
If you are building custom locales you will most likely use
|
||||
these sources as the basis for your new locale.
|
||||
|
||||
# We define a global regular expression to capture all of the locale
|
||||
# sources. We use it later when constructing the various packages.
|
||||
%global locale_rx eo syr *_*
|
||||
|
||||
%{lua:
|
||||
-- To make lua-mode happy: '
|
||||
|
||||
@ -773,6 +777,7 @@ local locales = {
|
||||
{ code="st", name="Southern Sotho", regions={ "ZA" } },
|
||||
{ code="sv", name="Swedish", regions={ "FI", "SE" } },
|
||||
{ code="sw", name="Swahili", regions={ "KE", "TZ" } },
|
||||
{ code="syr", name="Syriac", regions={} },
|
||||
{ code="szl", name="Silesian", regions={ "PL" } },
|
||||
{ code="ta", name="Tamil", regions={ "IN", "LK" } },
|
||||
{ code="tcy", name="Tulu", regions={ "IN" } },
|
||||
@ -1335,7 +1340,7 @@ $olddir/build-%{target}/elf/ld.so \
|
||||
$olddir/build-%{target}/locale/localedef \
|
||||
--alias-file=$olddir/intl/locale.alias \
|
||||
--prefix %{glibc_sysroot} --add-to-archive \
|
||||
eo *_*
|
||||
%locale_rx
|
||||
# Historically, glibc-all-langpacks deleted the file on updates (sic),
|
||||
# so we need to restore it in the posttrans scriptlet (like the old
|
||||
# glibc-all-langpacks versions)
|
||||
@ -1349,13 +1354,13 @@ ln locale-archive locale-archive.real
|
||||
# LC_MEASUREMENT and LC_PAPER also have several duplicates but we don't
|
||||
# bother with these because they are only ~30 bytes each.
|
||||
pushd %{glibc_sysroot}/usr/lib/locale
|
||||
for f in $(find eo *_* -samefile C.utf8/LC_CTYPE); do
|
||||
for f in $(find %locale_rx -samefile C.utf8/LC_CTYPE); do
|
||||
rm $f && ln -s '../C.utf8/LC_CTYPE' $f
|
||||
done
|
||||
popd
|
||||
|
||||
# Create the file lists for the language specific sub-packages:
|
||||
for i in eo *_*
|
||||
for i in %locale_rx
|
||||
do
|
||||
lang=${i%%_*}
|
||||
if [ ! -e langpack-${lang}.filelist ]; then
|
||||
@ -2170,6 +2175,27 @@ update_gconv_modules_cache ()
|
||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||
|
||||
%changelog
|
||||
* Mon Apr 25 2022 Carlos O'Donell <carlos@redhat.com> - 2.35.9000-15
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 1305edd42c44fee6f8660734d2dfa4911ec755d6:
|
||||
- elf: Move post-relocation code of _dl_start into _dl_start_final
|
||||
- misc: Fix rare fortify crash on wchar funcs. [BZ 29030]
|
||||
- elf: Remove unused enum allowmask
|
||||
- scripts/glibcelf.py: Mark as UNSUPPORTED on Python 3.5 and earlier
|
||||
- x86: Optimize {str|wcs}rchr-evex
|
||||
- x86: Optimize {str|wcs}rchr-avx2
|
||||
- x86: Optimize {str|wcs}rchr-sse2
|
||||
- benchtests: Improve bench-strrchr
|
||||
- x86-64: Fix SSE2 memcmp and SSSE3 memmove for x32
|
||||
- Default to --with-default-link=no (bug 25812)
|
||||
- scripts: Add glibcelf.py module
|
||||
- Add locale for syr_SY
|
||||
- elf: Move elf_dynamic_do_Rel RTLD_BOOTSTRAP branches outside
|
||||
- m68k: Handle fewer relocations for RTLD_BOOTSTRAP (#BZ29071)
|
||||
- nptl: Fix pthread_cancel cancelhandling atomic operations
|
||||
- x86: Fix missing __wmemcmp def for disable-multiarch build
|
||||
- elf: Remove __libc_init_secure
|
||||
|
||||
* Tue Apr 19 2022 DJ Delorie <dj@redhat.com> - 2.35.9000-14
|
||||
- Auto-sync with upstream branch master,
|
||||
commit 78fb88827362fbd2cc8aa32892ae5b015106e25c.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glibc-2.35.9000-392-g78fb888273.tar.xz) = 27d3aa2e5bfb0ee46ab22d8b867c922c6b4c07a78955a887574caa4b737cddbc60d57f7197999617c2fad4f5525310d44bc1f8c03266f737ef11ff7c65eb4485
|
||||
SHA512 (glibc-2.35.9000-409-g1305edd42c.tar.xz) = a2a35d1822d5a3352a60a1f494bbf18dec07a7edb7f326b046be91035d7a15d520b125144f28eeea8e0974d78a9332358c09e3554885149456f0d71e61193a7b
|
||||
|
Loading…
Reference in New Issue
Block a user