- Fix a wrong constant in powerpc hypot implementation (#750811)
#13534 in python bug database #13472 in glibc bug database
This commit is contained in:
parent
44d6e5be05
commit
1a1532d525
29
glibc-rh750811.patch
Normal file
29
glibc-rh750811.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
commit 850fb039cec802072f70ed9763927881bbbf639c
|
||||||
|
Author: Andreas Schwab <schwab@linux-m68k.org>
|
||||||
|
Date: Tue Dec 6 11:10:06 2011 +0100
|
||||||
|
|
||||||
|
Fix a wrong constant in powerpc hypot implementation
|
||||||
|
|
||||||
|
--- a/ChangeLog 2011-12-05 20:28:47.000000000 -0700
|
||||||
|
+++ b/ChangeLog 2011-12-07 13:14:29.619858242 -0700
|
||||||
|
@@ -1,3 +1,7 @@
|
||||||
|
+2011-12-06 Andreas Schwab <schwab@linux-m68k.org>
|
||||||
|
+
|
||||||
|
+ * sysdeps/powerpc/fpu/e_hypot.c (twoM600): Correct value.
|
||||||
|
+
|
||||||
|
2011-12-02 Andreas Schwab <schwab@redhat.com>
|
||||||
|
|
||||||
|
* misc/bits/select2.h (__FD_ELT): Mark as extension. Add
|
||||||
|
diff --git a/sysdeps/powerpc/fpu/e_hypot.c b/sysdeps/powerpc/fpu/e_hypot.c
|
||||||
|
index a8d67d8..3731c58 100644
|
||||||
|
--- a/sysdeps/powerpc/fpu/e_hypot.c
|
||||||
|
+++ b/sysdeps/powerpc/fpu/e_hypot.c
|
||||||
|
@@ -26,7 +26,7 @@ static const double two500 = 3.2733906078961419e+150;
|
||||||
|
static const double two600 = 4.149515568880993e+180;
|
||||||
|
static const double two1022 = 4.49423283715579e+307;
|
||||||
|
static const double twoM500 = 3.054936363499605e-151;
|
||||||
|
-static const double twoM600 = 4.616489308892868e-128;
|
||||||
|
+static const double twoM600 = 2.4099198651028841e-181;
|
||||||
|
static const double pdnum = 2.225073858507201e-308;
|
||||||
|
|
||||||
|
/* __ieee754_hypot(x,y)
|
10
glibc.spec
10
glibc.spec
@ -50,6 +50,8 @@ Patch6: %{name}-rh750858.patch
|
|||||||
Patch7: %{name}-rh757887.patch
|
Patch7: %{name}-rh757887.patch
|
||||||
Patch8: %{name}-fdelt.patch
|
Patch8: %{name}-fdelt.patch
|
||||||
Patch9: %{name}-rh708455.patch
|
Patch9: %{name}-rh708455.patch
|
||||||
|
Patch10: %{name}-rh750811.patch
|
||||||
|
Patch11: %{name}-rh758252.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Obsoletes: glibc-profile < 2.4
|
Obsoletes: glibc-profile < 2.4
|
||||||
Obsoletes: nss_db
|
Obsoletes: nss_db
|
||||||
@ -276,6 +278,8 @@ rm -rf %{glibcportsdir}
|
|||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
|
%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
|
||||||
# A lot of programs still misuse memcpy when they have to use
|
# A lot of programs still misuse memcpy when they have to use
|
||||||
# memmove. The memcpy implementation below is not tolerant at
|
# memmove. The memcpy implementation below is not tolerant at
|
||||||
@ -1128,6 +1132,12 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 7 2011 Jeff Law <law@redhat.com> - 2.14.90-23
|
||||||
|
- Fix a wrong constant in powerpc hypot implementation (#750811)
|
||||||
|
#13534 in python bug database
|
||||||
|
#13472 in glibc bug database
|
||||||
|
- Truncate time values in Linux futimes when falling back to utime
|
||||||
|
|
||||||
* Mon Dec 5 2011 Jeff Law <law@redhat.com> - 2.14.90-22
|
* Mon Dec 5 2011 Jeff Law <law@redhat.com> - 2.14.90-22
|
||||||
- Mark fortified __FD_ELT as extension
|
- Mark fortified __FD_ELT as extension
|
||||||
- Fix typo in manual (#708455)
|
- Fix typo in manual (#708455)
|
||||||
|
Loading…
Reference in New Issue
Block a user