Sync with upstream master
This commit is contained in:
parent
4d96e3246c
commit
14915008a3
@ -1,55 +0,0 @@
|
|||||||
2009-04-26 Aurelien Jarno <aurelien@aurel32.net>
|
|
||||||
|
|
||||||
* sysdeps/posix/getaddrinfo.c (rfc3484_sort): don't assign native
|
|
||||||
result if the result has no associated interface.
|
|
||||||
|
|
||||||
---
|
|
||||||
sysdeps/posix/getaddrinfo.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
--- a/sysdeps/posix/getaddrinfo.c
|
|
||||||
+++ b/sysdeps/posix/getaddrinfo.c
|
|
||||||
@@ -1456,13 +1456,13 @@
|
|
||||||
|
|
||||||
/* Fill in the results in all the records. */
|
|
||||||
for (int i = 0; i < src->nresults; ++i)
|
|
||||||
- if (src->results[i].index == a1_index)
|
|
||||||
+ if (a1_index != -1 && src->results[i].index == a1_index)
|
|
||||||
{
|
|
||||||
assert (src->results[i].native == -1
|
|
||||||
|| src->results[i].native == a1_native);
|
|
||||||
src->results[i].native = a1_native;
|
|
||||||
}
|
|
||||||
- else if (src->results[i].index == a2_index)
|
|
||||||
+ else if (a2_index != -1 && src->results[i].index == a2_index)
|
|
||||||
{
|
|
||||||
assert (src->results[i].native == -1
|
|
||||||
|| src->results[i].native == a2_native);
|
|
||||||
|
|
||||||
2009-03-15 Aurelien Jarno <aurelien@aurel32.net>
|
|
||||||
|
|
||||||
* sysdeps/posix/getaddrinfo.c (getaddrinfo): correctly detect
|
|
||||||
interface for all 127.X.Y.Z addresses.
|
|
||||||
|
|
||||||
---
|
|
||||||
sysdeps/posix/getaddrinfo.c | 9 ++++++++-
|
|
||||||
1 file changed, 8 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/sysdeps/posix/getaddrinfo.c
|
|
||||||
+++ b/sysdeps/posix/getaddrinfo.c
|
|
||||||
@@ -2265,7 +2265,14 @@
|
|
||||||
tmp.addr[0] = 0;
|
|
||||||
tmp.addr[1] = 0;
|
|
||||||
tmp.addr[2] = htonl (0xffff);
|
|
||||||
- tmp.addr[3] = sinp->sin_addr.s_addr;
|
|
||||||
+ /* Special case for lo interface, the source address
|
|
||||||
+ being possibly different than the interface
|
|
||||||
+ address. */
|
|
||||||
+ if ((ntohl(sinp->sin_addr.s_addr) & 0xff000000)
|
|
||||||
+ == 0x7f000000)
|
|
||||||
+ tmp.addr[3] = htonl(0x7f000001);
|
|
||||||
+ else
|
|
||||||
+ tmp.addr[3] = sinp->sin_addr.s_addr;
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
11
glibc.spec
11
glibc.spec
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.18-322-gd1f23d4
|
%define glibcsrcdir glibc-2.18-332-gb125d3e
|
||||||
%define glibcversion 2.18.90
|
%define glibcversion 2.18.90
|
||||||
%define glibcrelease 12%{?dist}
|
%define glibcrelease 13%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
#
|
#
|
||||||
@ -202,9 +202,6 @@ Patch2011: %{name}-rh757881.patch
|
|||||||
|
|
||||||
Patch2013: %{name}-rh741105.patch
|
Patch2013: %{name}-rh741105.patch
|
||||||
|
|
||||||
# Upstream BZ 9954
|
|
||||||
Patch2021: %{name}-rh739743.patch
|
|
||||||
|
|
||||||
# Upstream BZ 14247
|
# Upstream BZ 14247
|
||||||
Patch2023: %{name}-rh827510.patch
|
Patch2023: %{name}-rh827510.patch
|
||||||
|
|
||||||
@ -518,7 +515,6 @@ package or when debugging this package.
|
|||||||
%patch0016 -p1
|
%patch0016 -p1
|
||||||
%patch0019 -p1
|
%patch0019 -p1
|
||||||
%patch0020 -p1
|
%patch0020 -p1
|
||||||
%patch2021 -p1
|
|
||||||
%patch2023 -p1
|
%patch2023 -p1
|
||||||
%patch0024 -p1
|
%patch0024 -p1
|
||||||
%patch0025 -p1
|
%patch0025 -p1
|
||||||
@ -1624,6 +1620,9 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 28 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.18.90-13
|
||||||
|
- Sync with upstream master.
|
||||||
|
|
||||||
* Mon Oct 21 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.18.90-12
|
* Mon Oct 21 2013 Siddhesh Poyarekar <siddhesh@redhat.com> - 2.18.90-12
|
||||||
- Allow fill_archive to be called with NULL fname.
|
- Allow fill_archive to be called with NULL fname.
|
||||||
- Sync with upstream master.
|
- Sync with upstream master.
|
||||||
|
Loading…
Reference in New Issue
Block a user