Auto-sync with upstream master
Upstream commit: ff88ee7edfaa439e23c42fccaf3a36cd5f041894
This commit is contained in:
parent
0adb9076a4
commit
0b05408588
@ -320,7 +320,7 @@ Index: b/include/alloca.h
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- a/include/alloca.h
|
--- a/include/alloca.h
|
||||||
+++ b/include/alloca.h
|
+++ b/include/alloca.h
|
||||||
@@ -20,57 +20,17 @@ libc_hidden_proto (__libc_alloca_cutoff)
|
@@ -23,57 +23,17 @@ libc_hidden_proto (__libc_alloca_cutoff)
|
||||||
|
|
||||||
#include <allocalim.h>
|
#include <allocalim.h>
|
||||||
|
|
||||||
@ -377,7 +377,7 @@ Index: b/include/alloca.h
|
|||||||
- extend_alloca (buf, len, s__); })
|
- extend_alloca (buf, len, s__); })
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#endif
|
# endif /* !_ISOMAC */
|
||||||
Index: b/nis/nss_compat/compat-initgroups.c
|
Index: b/nis/nss_compat/compat-initgroups.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- a/nis/nss_compat/compat-initgroups.c
|
--- a/nis/nss_compat/compat-initgroups.c
|
||||||
@ -558,7 +558,7 @@ Index: b/nscd/aicache.c
|
|||||||
|
|
||||||
#include "dbg_log.h"
|
#include "dbg_log.h"
|
||||||
#include "nscd.h"
|
#include "nscd.h"
|
||||||
@@ -113,10 +114,13 @@ addhstaiX (struct database_dyn *db, int
|
@@ -112,10 +113,13 @@ addhstaiX (struct database_dyn *db, int
|
||||||
int old_res_options = _res.options;
|
int old_res_options = _res.options;
|
||||||
_res.options &= ~RES_USE_INET6;
|
_res.options &= ~RES_USE_INET6;
|
||||||
|
|
||||||
@ -576,7 +576,7 @@ Index: b/nscd/aicache.c
|
|||||||
int32_t ttl = INT32_MAX;
|
int32_t ttl = INT32_MAX;
|
||||||
ssize_t total = 0;
|
ssize_t total = 0;
|
||||||
char *key_copy = NULL;
|
char *key_copy = NULL;
|
||||||
@@ -129,6 +133,7 @@ addhstaiX (struct database_dyn *db, int
|
@@ -128,6 +132,7 @@ addhstaiX (struct database_dyn *db, int
|
||||||
int status[2] = { NSS_STATUS_UNAVAIL, NSS_STATUS_UNAVAIL };
|
int status[2] = { NSS_STATUS_UNAVAIL, NSS_STATUS_UNAVAIL };
|
||||||
int naddrs = 0;
|
int naddrs = 0;
|
||||||
size_t addrslen = 0;
|
size_t addrslen = 0;
|
||||||
@ -584,7 +584,7 @@ Index: b/nscd/aicache.c
|
|||||||
char *canon = NULL;
|
char *canon = NULL;
|
||||||
size_t canonlen;
|
size_t canonlen;
|
||||||
|
|
||||||
@@ -143,12 +148,17 @@ addhstaiX (struct database_dyn *db, int
|
@@ -142,12 +147,17 @@ addhstaiX (struct database_dyn *db, int
|
||||||
at = &atmem;
|
at = &atmem;
|
||||||
rc6 = 0;
|
rc6 = 0;
|
||||||
herrno = 0;
|
herrno = 0;
|
||||||
@ -604,7 +604,7 @@ Index: b/nscd/aicache.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (rc6 != 0 && herrno == NETDB_INTERNAL)
|
if (rc6 != 0 && herrno == NETDB_INTERNAL)
|
||||||
@@ -226,41 +236,38 @@ addhstaiX (struct database_dyn *db, int
|
@@ -225,41 +235,38 @@ addhstaiX (struct database_dyn *db, int
|
||||||
while (1)
|
while (1)
|
||||||
{
|
{
|
||||||
rc6 = 0;
|
rc6 = 0;
|
||||||
@ -662,7 +662,7 @@ Index: b/nscd/aicache.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (rc4 != 0 && herrno == NETDB_INTERNAL)
|
if (rc4 != 0 && herrno == NETDB_INTERNAL)
|
||||||
@@ -286,13 +293,11 @@ addhstaiX (struct database_dyn *db, int
|
@@ -285,13 +292,11 @@ addhstaiX (struct database_dyn *db, int
|
||||||
cfct = __nss_lookup_function (nip, "getcanonname_r");
|
cfct = __nss_lookup_function (nip, "getcanonname_r");
|
||||||
if (cfct != NULL)
|
if (cfct != NULL)
|
||||||
{
|
{
|
||||||
@ -678,7 +678,7 @@ Index: b/nscd/aicache.c
|
|||||||
== NSS_STATUS_SUCCESS)
|
== NSS_STATUS_SUCCESS)
|
||||||
canon = s;
|
canon = s;
|
||||||
else
|
else
|
||||||
@@ -321,18 +326,20 @@ addhstaiX (struct database_dyn *db, int
|
@@ -320,18 +325,20 @@ addhstaiX (struct database_dyn *db, int
|
||||||
addrfamily = AF_INET6;
|
addrfamily = AF_INET6;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -704,7 +704,7 @@ Index: b/nscd/aicache.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
if (rc == 0)
|
if (rc == 0)
|
||||||
@@ -560,6 +567,10 @@ next_nip:
|
@@ -559,6 +566,10 @@ next_nip:
|
||||||
dh->usable = false;
|
dh->usable = false;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
11
glibc.spec
11
glibc.spec
@ -1,6 +1,6 @@
|
|||||||
%define glibcsrcdir glibc-2.24-180-g17af5da
|
%define glibcsrcdir glibc-2.24-210-gff88ee7
|
||||||
%define glibcversion 2.24.90
|
%define glibcversion 2.24.90
|
||||||
%define glibcrelease 8%{?dist}
|
%define glibcrelease 9%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
#
|
#
|
||||||
@ -2275,6 +2275,13 @@ rm -f *.filelist*
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 04 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-9
|
||||||
|
- Auto-sync with upstream master,
|
||||||
|
commit ff88ee7edfaa439e23c42fccaf3a36cd5f041894, fixing:
|
||||||
|
- LONG_WIDTH is incorrectly set to the 64 on 32-bit platforms (#1381582)
|
||||||
|
- libio: Multiple fixes for open_{w}memstream (swbz#18241, swbz#20181)
|
||||||
|
- Simplify and test _dl_addr_inside_object (swbz#20292)
|
||||||
|
|
||||||
* Thu Sep 22 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-8
|
* Thu Sep 22 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-8
|
||||||
- Add support for MIPS (#1377795)
|
- Add support for MIPS (#1377795)
|
||||||
- Drop glibc-rh1315476-1.patch (sln pre-processor cleanup), it was
|
- Drop glibc-rh1315476-1.patch (sln pre-processor cleanup), it was
|
||||||
|
Loading…
Reference in New Issue
Block a user