Auto-sync with upstream master
Upstream commit: 17af5da98cd2c9ec958421ae2108f877e0945451
This commit is contained in:
parent
66afdc6140
commit
0adb9076a4
@ -1,54 +0,0 @@
|
|||||||
commit a4551b7f6ce08317220a8cd79cd3d02a03648752
|
|
||||||
Author: Florian Weimer <fweimer@redhat.com>
|
|
||||||
Date: Wed Jul 13 11:50:04 2016 +0200
|
|
||||||
|
|
||||||
sln: Preprocessor cleanups
|
|
||||||
|
|
||||||
diff --git a/elf/sln.c b/elf/sln.c
|
|
||||||
index f52cb9f..fa4ccec 100644
|
|
||||||
--- a/elf/sln.c
|
|
||||||
+++ b/elf/sln.c
|
|
||||||
@@ -16,10 +16,6 @@
|
|
||||||
License along with the GNU C Library; if not, see
|
|
||||||
<http://www.gnu.org/licenses/>. */
|
|
||||||
|
|
||||||
-#ifdef HAVE_CONFIG_H
|
|
||||||
-# include "config.h"
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
#include <error.h>
|
|
||||||
#include <errno.h>
|
|
||||||
#include <libintl.h>
|
|
||||||
@@ -37,10 +33,6 @@
|
|
||||||
|
|
||||||
#define PACKAGE _libc_intl_domainname
|
|
||||||
|
|
||||||
-#if !defined S_ISDIR && defined S_IFDIR
|
|
||||||
-#define S_ISDIR(m) (((m) & S_IFMT) == S_IFDIR)
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
static int makesymlink (const char *src, const char *dest);
|
|
||||||
static int makesymlinks (const char *file);
|
|
||||||
static void usage (void);
|
|
||||||
@@ -89,9 +81,6 @@ usage (void)
|
|
||||||
static int
|
|
||||||
makesymlinks (const char *file)
|
|
||||||
{
|
|
||||||
-#ifndef PATH_MAX
|
|
||||||
-#define PATH_MAX 4095
|
|
||||||
-#endif
|
|
||||||
char *buffer = NULL;
|
|
||||||
size_t bufferlen = 0;
|
|
||||||
int ret;
|
|
||||||
@@ -190,11 +179,7 @@ makesymlink (const char *src, const char *dest)
|
|
||||||
return -1;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#ifdef S_ISLNK
|
|
||||||
if (symlink (src, dest) == 0)
|
|
||||||
-#else
|
|
||||||
- if (link (src, dest) == 0)
|
|
||||||
-#endif
|
|
||||||
{
|
|
||||||
/* Destination must exist by now. */
|
|
||||||
if (access (dest, F_OK))
|
|
13
glibc.spec
13
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.24-163-ge299076
|
%define glibcsrcdir glibc-2.24-180-g17af5da
|
||||||
%define glibcversion 2.24.90
|
%define glibcversion 2.24.90
|
||||||
%define glibcrelease 8%{?dist}
|
%define glibcrelease 8%{?dist}
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
@ -304,7 +304,6 @@ Patch2038: glibc-rh1335011.patch
|
|||||||
Patch2110: glibc-rh1351108-update-to-unicode-9.0.0.patch
|
Patch2110: glibc-rh1351108-update-to-unicode-9.0.0.patch
|
||||||
|
|
||||||
# sln implemented by ldconfig, to conserve disk space.
|
# sln implemented by ldconfig, to conserve disk space.
|
||||||
Patch2111: glibc-rh1315476-1.patch
|
|
||||||
Patch2112: glibc-rh1315476-2.patch
|
Patch2112: glibc-rh1315476-2.patch
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
@ -881,7 +880,6 @@ microbenchmark tests on the system.
|
|||||||
%patch2037 -p1
|
%patch2037 -p1
|
||||||
%patch2038 -p1
|
%patch2038 -p1
|
||||||
%patch2110 -p1
|
%patch2110 -p1
|
||||||
%patch2111 -p1
|
|
||||||
%patch2112 -p1
|
%patch2112 -p1
|
||||||
|
|
||||||
##############################################################################
|
##############################################################################
|
||||||
@ -2279,6 +2277,15 @@ rm -f *.filelist*
|
|||||||
%changelog
|
%changelog
|
||||||
* Thu Sep 22 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-8
|
* Thu Sep 22 2016 Florian Weimer <fweimer@redhat.com> - 2.24.90-8
|
||||||
- Add support for MIPS (#1377795)
|
- Add support for MIPS (#1377795)
|
||||||
|
- Drop glibc-rh1315476-1.patch (sln pre-processor cleanup), it was
|
||||||
|
applied upstream.
|
||||||
|
- Auto-sync with upstream master,
|
||||||
|
commit 17af5da98cd2c9ec958421ae2108f877e0945451, fixing the following bugs:
|
||||||
|
- Fix non-LE TLS in static programs (swbz#19826)
|
||||||
|
- resolv: Remove unsupported hook functions from the API (swbz#20016)
|
||||||
|
- Remove RR type classification macros (swbz#20592)
|
||||||
|
- Remove obsolete DNSSEC support (swbz#20591)
|
||||||
|
- manual: Clarify the documentation of strverscmp (swbz#20524)
|
||||||
|
|
||||||
* Tue Sep 20 2016 Carlos O'Donell <carlos@systemhalted.org> - 2.24.90-7
|
* Tue Sep 20 2016 Carlos O'Donell <carlos@systemhalted.org> - 2.24.90-7
|
||||||
- Auto-sync with upstream master.
|
- Auto-sync with upstream master.
|
||||||
|
Loading…
Reference in New Issue
Block a user