Update system call list to Linux 4.12 (#1484729)
This commit is contained in:
parent
2f246edc9d
commit
0ab5fbb2e4
@ -2,10 +2,10 @@ The explicit system call list for system call management was not
|
|||||||
accepted upstream.
|
accepted upstream.
|
||||||
diff --git a/sysdeps/unix/sysv/linux/syscall-names.list b/sysdeps/unix/sysv/linux/syscall-names.list
|
diff --git a/sysdeps/unix/sysv/linux/syscall-names.list b/sysdeps/unix/sysv/linux/syscall-names.list
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 00000000..459b2226
|
index 00000000..80c4f101
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/sysdeps/unix/sysv/linux/syscall-names.list
|
+++ b/sysdeps/unix/sysv/linux/syscall-names.list
|
||||||
@@ -0,0 +1,595 @@
|
@@ -0,0 +1,596 @@
|
||||||
+# List of all known Linux system calls.
|
+# List of all known Linux system calls.
|
||||||
+# Copyright (C) 2017 Free Software Foundation, Inc.
|
+# Copyright (C) 2017 Free Software Foundation, Inc.
|
||||||
+# This file is part of the GNU C Library.
|
+# This file is part of the GNU C Library.
|
||||||
@ -30,8 +30,8 @@ index 00000000..459b2226
|
|||||||
+# names are only used if the installed kernel headers also provide
|
+# names are only used if the installed kernel headers also provide
|
||||||
+# them.
|
+# them.
|
||||||
+
|
+
|
||||||
+# The list of system calls is current as of Linux 4.11.
|
+# The list of system calls is current as of Linux 4.12.
|
||||||
+kernel 4.11
|
+kernel 4.12
|
||||||
+
|
+
|
||||||
+FAST_atomic_update
|
+FAST_atomic_update
|
||||||
+FAST_cmpxchg
|
+FAST_cmpxchg
|
||||||
@ -443,6 +443,7 @@ index 00000000..459b2226
|
|||||||
+rt_sigtimedwait
|
+rt_sigtimedwait
|
||||||
+rt_tgsigqueueinfo
|
+rt_tgsigqueueinfo
|
||||||
+rtas
|
+rtas
|
||||||
|
+s390_guarded_storage
|
||||||
+s390_pci_mmio_read
|
+s390_pci_mmio_read
|
||||||
+s390_pci_mmio_write
|
+s390_pci_mmio_write
|
||||||
+s390_runtime_instr
|
+s390_runtime_instr
|
||||||
|
@ -26,7 +26,7 @@ Author: Florian Weimer <fweimer@redhat.com>
|
|||||||
The explicit system call list for system call management was not
|
The explicit system call list for system call management was not
|
||||||
accepted upstream.
|
accepted upstream.
|
||||||
diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
|
diff --git a/sysdeps/unix/sysv/linux/Makefile b/sysdeps/unix/sysv/linux/Makefile
|
||||||
index 9d6a2de8..bb7a3c78 100644
|
index 9d6a2de8..4e4a22b5 100644
|
||||||
--- a/sysdeps/unix/sysv/linux/Makefile
|
--- a/sysdeps/unix/sysv/linux/Makefile
|
||||||
+++ b/sysdeps/unix/sysv/linux/Makefile
|
+++ b/sysdeps/unix/sysv/linux/Makefile
|
||||||
@@ -52,75 +52,46 @@ sysdep_headers += sys/mount.h sys/acct.h sys/sysctl.h \
|
@@ -52,75 +52,46 @@ sysdep_headers += sys/mount.h sys/acct.h sys/sysctl.h \
|
||||||
@ -134,11 +134,11 @@ index 9d6a2de8..bb7a3c78 100644
|
|||||||
+ $(AWK) '/^#define SYS_/ { print substr($$2, 5) }' $< > $@-tmp
|
+ $(AWK) '/^#define SYS_/ { print substr($$2, 5) }' $< > $@-tmp
|
||||||
+ $(move-if-change) $@-tmp $@
|
+ $(move-if-change) $@-tmp $@
|
||||||
+
|
+
|
||||||
+tests: $(objpfx)tst-syscall-list.out
|
+tests-special += $(objpfx)tst-syscall-list.out
|
||||||
+$(objpfx)tst-syscall-list.out: \
|
+$(objpfx)tst-syscall-list.out: \
|
||||||
+ ../sysdeps/unix/sysv/linux/tst-syscall-list.sh \
|
+ ../sysdeps/unix/sysv/linux/tst-syscall-list.sh \
|
||||||
+ $(objpfx)tst-syscall-list-nr.list $(objpfx)tst-syscall-list-sys.list
|
+ $(objpfx)tst-syscall-list-nr.list $(objpfx)tst-syscall-list-sys.list
|
||||||
+ $(BASH) $^ > $@
|
+ $(BASH) $^ > $@; $(evaluate-test)
|
||||||
+
|
+
|
||||||
+endif # $(subdir) == misc
|
+endif # $(subdir) == misc
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user