- Resync with upstream sources
- Drop local patch for getconf. - Repack patchlist.
This commit is contained in:
parent
9625d850cd
commit
0a6b9006e7
2
.gitignore
vendored
2
.gitignore
vendored
@ -69,3 +69,5 @@ glibc-2.14-394-g8f3b1ff
|
||||
/glibc-2.16.90-01f34a3b.tar.gz
|
||||
/glibc-2.16.90-d14fbb17-fedora.tar.gz
|
||||
/glibc-2.16.90-d14fbb17.tar.gz
|
||||
/glibc-2.16.90-3e2e43e2-fedora.tar.gz
|
||||
/glibc-2.16.90-3e2e43e2.tar.gz
|
||||
|
@ -1,74 +0,0 @@
|
||||
2004-11-26 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* posix/Makefile (generated: Add getconf.speclist.
|
||||
($(inst_libexecdir)/getconf): Use getconf.speclist instead of
|
||||
getconf output.
|
||||
($(objpfx)getconf.speclist): New rule.
|
||||
* posix/getconf.speclist.h: New file.
|
||||
|
||||
diff -Nrup a/posix/Makefile b/posix/Makefile
|
||||
--- a/posix/Makefile 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/posix/Makefile 2012-06-07 12:15:21.820318664 -0600
|
||||
@@ -305,15 +305,8 @@ $(inst_libexecdir)/getconf: $(inst_bindi
|
||||
mv -f $@/$$spec.new $@/$$spec; \
|
||||
done < $(objpfx)getconf.speclist
|
||||
|
||||
-$(objpfx)getconf.speclist: $(objpfx)getconf
|
||||
-ifeq (no,$(cross-compiling))
|
||||
- LC_ALL=C GETCONF_DIR=/dev/null \
|
||||
- $(run-program-prefix) $< _POSIX_V7_WIDTH_RESTRICTED_ENVS > $@.new
|
||||
- LC_ALL=C GETCONF_DIR=/dev/null \
|
||||
- $(run-program-prefix) $< _POSIX_V6_WIDTH_RESTRICTED_ENVS >> $@.new
|
||||
- LC_ALL=C GETCONF_DIR=/dev/null \
|
||||
- $(run-program-prefix) $< _XBS5_WIDTH_RESTRICTED_ENVS >> $@.new
|
||||
-else
|
||||
- > $@.new
|
||||
-endif
|
||||
+$(objpfx)getconf.speclist: getconf.speclist.h
|
||||
+ $(CC) -E $(CFLAGS) $(CPPFLAGS) $< \
|
||||
+ | sed -n -e '/START_OF_STRINGS/,$${/\(POSIX_V[67]\|XBS5\)_/{s/^[^"]*"//;s/".*$$//;p}}' \
|
||||
+ > $@.new
|
||||
mv -f $@.new $@
|
||||
diff -Nrup a/posix/getconf.speclist.h b/posix/getconf.speclist.h
|
||||
--- a/posix/getconf.speclist.h 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/posix/getconf.speclist.h 2012-06-07 12:15:21.820318664 -0600
|
||||
@@ -0,0 +1,39 @@
|
||||
+#include <unistd.h>
|
||||
+const char *START_OF_STRINGS =
|
||||
+#if _POSIX_V7_ILP32_OFF32 == 1
|
||||
+"POSIX_V7_ILP32_OFF32"
|
||||
+#endif
|
||||
+#if _POSIX_V7_ILP32_OFFBIG == 1
|
||||
+"POSIX_V7_ILP32_OFFBIG"
|
||||
+#endif
|
||||
+#if _POSIX_V7_LP64_OFF64 == 1
|
||||
+"POSIX_V7_LP64_OFF64"
|
||||
+#endif
|
||||
+#if _POSIX_V7_LPBIG_OFFBIG == 1
|
||||
+"POSIX_V7_LPBIG_OFFBIG"
|
||||
+#endif
|
||||
+#if _POSIX_V6_ILP32_OFF32 == 1
|
||||
+"POSIX_V6_ILP32_OFF32"
|
||||
+#endif
|
||||
+#if _POSIX_V6_ILP32_OFFBIG == 1
|
||||
+"POSIX_V6_ILP32_OFFBIG"
|
||||
+#endif
|
||||
+#if _POSIX_V6_LP64_OFF64 == 1
|
||||
+"POSIX_V6_LP64_OFF64"
|
||||
+#endif
|
||||
+#if _POSIX_V6_LPBIG_OFFBIG == 1
|
||||
+"POSIX_V6_LPBIG_OFFBIG"
|
||||
+#endif
|
||||
+#if _XBS5_ILP32_OFF32 == 1
|
||||
+"XBS5_ILP32_OFF32"
|
||||
+#endif
|
||||
+#if _XBS5_ILP32_OFFBIG == 1
|
||||
+"XBS5_ILP32_OFFBIG"
|
||||
+#endif
|
||||
+#if _XBS5_LP64_OFF64 == 1
|
||||
+"XBS5_LP64_OFF64"
|
||||
+#endif
|
||||
+#if _XBS5_LPBIG_OFFBIG == 1
|
||||
+"XBS5_LPBIG_OFFBIG"
|
||||
+#endif
|
||||
+"";
|
@ -2,9 +2,9 @@
|
||||
- add a couple of .ISO-8859-15 locales (#61908)
|
||||
|
||||
diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
--- a/localedata/SUPPORTED 2012-06-05 07:42:49.000000000 -0600
|
||||
+++ b/localedata/SUPPORTED 2012-06-07 12:15:21.805318719 -0600
|
||||
@@ -88,6 +88,7 @@ cy_GB.UTF-8/UTF-8 \
|
||||
--- a/localedata/SUPPORTED 2012-11-25 12:59:31.000000000 -0700
|
||||
+++ b/localedata/SUPPORTED 2012-11-26 12:58:43.298223018 -0700
|
||||
@@ -89,6 +89,7 @@ cy_GB.UTF-8/UTF-8 \
|
||||
cy_GB/ISO-8859-14 \
|
||||
da_DK.UTF-8/UTF-8 \
|
||||
da_DK/ISO-8859-1 \
|
||||
@ -12,7 +12,7 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
de_AT.UTF-8/UTF-8 \
|
||||
de_AT/ISO-8859-1 \
|
||||
de_AT@euro/ISO-8859-15 \
|
||||
@@ -119,6 +120,7 @@ en_DK.UTF-8/UTF-8 \
|
||||
@@ -121,6 +122,7 @@ en_DK.UTF-8/UTF-8 \
|
||||
en_DK/ISO-8859-1 \
|
||||
en_GB.UTF-8/UTF-8 \
|
||||
en_GB/ISO-8859-1 \
|
||||
@ -20,7 +20,7 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
en_HK.UTF-8/UTF-8 \
|
||||
en_HK/ISO-8859-1 \
|
||||
en_IE.UTF-8/UTF-8 \
|
||||
@@ -134,6 +136,7 @@ en_SG.UTF-8/UTF-8 \
|
||||
@@ -136,6 +138,7 @@ en_SG.UTF-8/UTF-8 \
|
||||
en_SG/ISO-8859-1 \
|
||||
en_US.UTF-8/UTF-8 \
|
||||
en_US/ISO-8859-1 \
|
||||
@ -28,11 +28,11 @@ diff -Nrup a/localedata/SUPPORTED b/localedata/SUPPORTED
|
||||
en_ZA.UTF-8/UTF-8 \
|
||||
en_ZA/ISO-8859-1 \
|
||||
en_ZM/UTF-8 \
|
||||
@@ -378,6 +381,7 @@ sv_FI/ISO-8859-1 \
|
||||
@@ -385,6 +388,7 @@ sv_FI/ISO-8859-1 \
|
||||
sv_FI@euro/ISO-8859-15 \
|
||||
sv_SE.UTF-8/UTF-8 \
|
||||
sv_SE/ISO-8859-1 \
|
||||
+sv_SE.ISO-8859-15/ISO-8859-15 \
|
||||
sw_KE/UTF-8 \
|
||||
sw_TZ/UTF-8 \
|
||||
ta_IN/UTF-8 \
|
||||
szl_PL/UTF-8 \
|
||||
|
13
glibc.spec
13
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.16.90-d14fbb17
|
||||
%define glibcsrcdir glibc-2.16.90-3e2e43e2
|
||||
%define glibcversion 2.16.90
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 1
|
||||
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 29%{?dist}
|
||||
Release: 30%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -112,7 +112,7 @@ Patch0034: %{name}-fedora-elf-init-hidden_undef.patch
|
||||
Patch0035: %{name}-fedora-elf-rh737223.patch
|
||||
Patch0036: %{name}-fedora-gai-canonical.patch
|
||||
Patch0037: %{name}-fedora-test-debug-gnuc-hack.patch
|
||||
Patch0038: %{name}-fedora-getconf.patch
|
||||
Patch0038: %{name}-fedora-localedef.patch
|
||||
Patch0039: %{name}-fedora-getrlimit-PLT.patch
|
||||
Patch0040: %{name}-fedora-i386-tls-direct-seg-refs.patch
|
||||
Patch0041: %{name}-fedora-pt_chown.patch
|
||||
@ -123,7 +123,6 @@ Patch0045: %{name}-fedora-locale-euro.patch
|
||||
Patch0046: %{name}-fedora-localedata-locales-fixes.patch
|
||||
Patch0047: %{name}-fedora-streams-rh436349.patch
|
||||
Patch0048: %{name}-fedora-localedata-rh61908.patch
|
||||
Patch0049: %{name}-fedora-localedef.patch
|
||||
|
||||
#
|
||||
# Patches from upstream
|
||||
@ -438,7 +437,6 @@ package or when debugging this package.
|
||||
%patch0046 -p1
|
||||
%patch0047 -p1
|
||||
%patch0048 -p1
|
||||
%patch0049 -p1
|
||||
|
||||
# On powerpc32, hp timing is only available in power4/power6
|
||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||
@ -1233,6 +1231,11 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Nov 26 2012 Jeff Law <law@redhat.com> - 2.16.90-30
|
||||
- Resync with upstream sources
|
||||
- Drop local patch for getconf.
|
||||
- Repack patchlist.
|
||||
|
||||
* Fri Nov 16 2012 Jeff Law <law@redhat.com> - 2.16.90-29
|
||||
- Rsync with upstream sources
|
||||
- Drop local patches for 803286, 791161, 790292, 790298
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
6d70e1594c0c90c7029f685595040447 glibc-2.16.90-d14fbb17-fedora.tar.gz
|
||||
bc56a554f5c469260acbcd9f2b358351 glibc-2.16.90-d14fbb17.tar.gz
|
||||
8c42a7148eee38c58e88f7185bcd1267 glibc-2.16.90-3e2e43e2-fedora.tar.gz
|
||||
be38c58906cbec13928dedad16d084d0 glibc-2.16.90-3e2e43e2.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user