Auto-sync with upstream branch master
Upstream commit: aa9a7f629632c9180de89632d4f2c1e6039f7781 - nptl: Export _pthread_cleanup_push, _pthread_cleanup_pop again - s390x: Align child stack while clone. [BZ #27968] - y2038: Add test coverage - libsupport: Add 64-bit time_t support for stat functions - libsupport: Add 64-bit time_t support for time functions - io: Add ftw64 with 64-bit time_t support - io: Add fts64 with 64-bit time_t support - posix: Add glob64 with 64-bit time_t support - y2038: Add support for 64-bit time on legacy ABIs - time: Add 64-bit time support for getdate - y2038: Add __USE_TIME_BITS64 support for socket-constants.h - y2038: Use a common definition for shmid_ds - y2038: Use a common definition for semid_ds - y2038: Use a common definition for msqid_ds - y2038: Use a common definition for stat - y2038: linux: Add __USE_TIME_BITS64 support for struct timex - y2038: Add __USE_TIME_BITS64 support for struct utimbuf - y2038: Add __USE_TIME_BITS64 support for struct timespec - y2038: Add __USE_TIME_BITS64 support for struct timeval - y2038: Add __USE_TIME_BITS64 support for time_t - linux: Add recvvmsg fallback for 64-bit time_t SO_TIMESTAMP{NS} - linux: Add fallback for 64-bit time_t SO_TIMESTAMP{NS} - linux: Add fallback for 64-bit time_t SO_{RCV,SND}TIMEO - linux: s390: Add libanl.abilist in s390 and s390x - linux: mips: Split libanl.abilist in n32 and n64 - linux: mips: Split librt.abilist in n32 and n64 - Reinstate gconv-modules as the default configuration file
This commit is contained in:
parent
027b24e17f
commit
07558826b7
@ -1,137 +0,0 @@
|
|||||||
Short description: Reinstate gconv-modules as the default configuration file
|
|
||||||
Author(s): Fedora glibc team <glibc@lists.fedoraproject.org>
|
|
||||||
Origin: PATCH
|
|
||||||
Upstream status: https://sourceware.org/pipermail/libc-alpha/2021-June/127497.html
|
|
||||||
|
|
||||||
Reinstate gconv-modules as the main file so that the configuration
|
|
||||||
files in gconv-modules.d/ become add-on configuration. With this, the
|
|
||||||
effective user visible change is that GCONV_PATH can now have
|
|
||||||
supplementary configuration in GCONV_PATH/gconv-modules.d/ in addition
|
|
||||||
to the main GCONV_PATH/gconv-modules file.
|
|
||||||
|
|
||||||
diff --git a/iconvdata/Makefile b/iconvdata/Makefile
|
|
||||||
index 3c6929fb59aadaa2..bb3f621b49608b04 100644
|
|
||||||
--- a/iconvdata/Makefile
|
|
||||||
+++ b/iconvdata/Makefile
|
|
||||||
@@ -137,13 +137,12 @@ charmaps = ../localedata/charmaps
|
|
||||||
extra-modules-left := $(modules)
|
|
||||||
include extra-module.mk
|
|
||||||
|
|
||||||
-gconv-modules = gconv-modules.conf gconv-modules-extra.conf
|
|
||||||
+gconv-modules = gconv-modules gconv-modules.d/gconv-modules-extra.conf
|
|
||||||
modpfx = $(objpfx)gconv-modules.d/
|
|
||||||
|
|
||||||
extra-objs += $(modules.so)
|
|
||||||
install-others = $(addprefix $(inst_gconvdir)/, $(modules.so)) \
|
|
||||||
- $(addprefix $(inst_gconvdir)/gconv-modules.d/, \
|
|
||||||
- $(gconv-modules))
|
|
||||||
+ $(addprefix $(inst_gconvdir)/, $(gconv-modules))
|
|
||||||
|
|
||||||
# We can build the conversion tables for numerous charsets automatically.
|
|
||||||
|
|
||||||
@@ -185,7 +184,7 @@ generated += $(generated-modules:=.h) $(generated-modules:=.stmp) \
|
|
||||||
iconv-test.out iconv-rules tst-loading.mtrace \
|
|
||||||
mtrace-tst-loading.out tst-tables.out iconv-test.xxx
|
|
||||||
ifdef objpfx
|
|
||||||
-generated += $(addprefix gconv-modules.d/,$(gconv-modules))
|
|
||||||
+generated += $(gconv-modules)
|
|
||||||
endif
|
|
||||||
|
|
||||||
# Rules to generate the headers.
|
|
||||||
@@ -253,8 +252,8 @@ headers: $(addprefix $(objpfx), $(generated-modules:=.h))
|
|
||||||
$(addprefix $(inst_gconvdir)/, $(modules.so)): \
|
|
||||||
$(inst_gconvdir)/%: $(objpfx)% $(+force)
|
|
||||||
$(do-install-program)
|
|
||||||
-$(addprefix $(inst_gconvdir)/gconv-modules.d/, $(gconv-modules)): \
|
|
||||||
- $(inst_gconvdir)/gconv-modules.d/%: $(modpfx)% $(+force)
|
|
||||||
+$(addprefix $(inst_gconvdir)/, $(gconv-modules)): \
|
|
||||||
+ $(inst_gconvdir)/%: $(objpfx)% $(+force)
|
|
||||||
$(do-install)
|
|
||||||
ifeq (no,$(cross-compiling))
|
|
||||||
# Update the $(prefix)/lib/gconv/gconv-modules.cache file. This is necessary
|
|
||||||
@@ -307,29 +306,29 @@ $(objpfx)mtrace-tst-loading.out: $(objpfx)tst-loading.out
|
|
||||||
$(common-objpfx)malloc/mtrace $(objpfx)tst-loading.mtrace > $@; \
|
|
||||||
$(evaluate-test)
|
|
||||||
|
|
||||||
-$(objpfx)bug-iconv1.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv1.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv2.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv2.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv3.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv3.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv5.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv5.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)tst-loading.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)tst-loading.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)tst-iconv4.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)tst-iconv4.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)tst-iconv7.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)tst-iconv7.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv10.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv10.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv12.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv12.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
-$(objpfx)bug-iconv14.out: $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+$(objpfx)bug-iconv14.out: $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
|
|
||||||
$(objpfx)iconv-test.out: run-iconv-test.sh \
|
|
||||||
- $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+ $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so)) \
|
|
||||||
$(common-objdir)/iconv/iconv_prog TESTS
|
|
||||||
iconv_modules="$(modules)" \
|
|
||||||
@@ -338,7 +337,7 @@ $(objpfx)iconv-test.out: run-iconv-test.sh \
|
|
||||||
$(evaluate-test)
|
|
||||||
|
|
||||||
$(objpfx)tst-tables.out: tst-tables.sh \
|
|
||||||
- $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+ $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so)) \
|
|
||||||
$(objpfx)tst-table-from $(objpfx)tst-table-to
|
|
||||||
$(SHELL) $< $(common-objpfx) $(common-objpfx)iconvdata/ \
|
|
||||||
@@ -357,7 +356,10 @@ $(modpfx):
|
|
||||||
$(modpfx)%: % $(modpfx)
|
|
||||||
cp $< $@
|
|
||||||
|
|
||||||
+$(objpfx)gconv-modules: gconv-modules
|
|
||||||
+ cp $^ $@
|
|
||||||
+
|
|
||||||
# Test requires BIG5HKSCS.
|
|
||||||
$(objpfx)tst-iconv-big5-hkscs-to-2ucs4.out: \
|
|
||||||
- $(addprefix $(modpfx), $(gconv-modules)) \
|
|
||||||
+ $(addprefix $(objpfx), $(gconv-modules)) \
|
|
||||||
$(addprefix $(objpfx),$(modules.so))
|
|
||||||
diff --git a/iconvdata/gconv-modules.conf b/iconvdata/gconv-modules
|
|
||||||
similarity index 100%
|
|
||||||
rename from iconvdata/gconv-modules.conf
|
|
||||||
rename to iconvdata/gconv-modules
|
|
||||||
diff --git a/localedata/Makefile b/localedata/Makefile
|
|
||||||
index ff4ec4acfa2bc523..bc5a60cf3b49701a 100644
|
|
||||||
--- a/localedata/Makefile
|
|
||||||
+++ b/localedata/Makefile
|
|
||||||
@@ -183,7 +183,7 @@ install-others := $(addprefix $(inst_i18ndir)/, \
|
|
||||||
$(locales))
|
|
||||||
endif
|
|
||||||
|
|
||||||
-tests: $(objdir)/iconvdata/gconv-modules.d/gconv-modules.conf
|
|
||||||
+tests: $(objdir)/iconvdata/gconv-modules
|
|
||||||
|
|
||||||
tests-static += tst-langinfo-newlocale-static tst-langinfo-setlocale-static
|
|
||||||
|
|
||||||
@@ -465,5 +465,5 @@ $(objpfx)mtrace-tst-leaks.out: $(objpfx)tst-leaks.out
|
|
||||||
bug-setlocale1-ENV-only = LOCPATH=$(objpfx) LC_CTYPE=de_DE.UTF-8
|
|
||||||
bug-setlocale1-static-ENV-only = $(bug-setlocale1-ENV-only)
|
|
||||||
|
|
||||||
-$(objdir)/iconvdata/gconv-modules.d/gconv-modules.conf:
|
|
||||||
+$(objdir)/iconvdata/gconv-modules:
|
|
||||||
$(MAKE) -C ../iconvdata subdir=iconvdata $@
|
|
37
glibc.spec
37
glibc.spec
@ -1,4 +1,4 @@
|
|||||||
%define glibcsrcdir glibc-2.33.9000-701-gebae2f5a6f
|
%define glibcsrcdir glibc-2.33.9000-728-gaa9a7f6296
|
||||||
%define glibcversion 2.33.9000
|
%define glibcversion 2.33.9000
|
||||||
# Pre-release tarballs are pulled in from git using a command that is
|
# Pre-release tarballs are pulled in from git using a command that is
|
||||||
# effectively:
|
# effectively:
|
||||||
@ -97,7 +97,7 @@
|
|||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: %{glibcversion}
|
Version: %{glibcversion}
|
||||||
Release: 16%{?dist}
|
Release: 17%{?dist}
|
||||||
|
|
||||||
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
# In general, GPLv2+ is used by programs, LGPLv2+ is used for
|
||||||
# libraries.
|
# libraries.
|
||||||
@ -169,7 +169,6 @@ Patch23: glibc-python3.patch
|
|||||||
Patch29: glibc-fedora-nsswitch.patch
|
Patch29: glibc-fedora-nsswitch.patch
|
||||||
Patch30: glibc-deprecated-selinux-makedb.patch
|
Patch30: glibc-deprecated-selinux-makedb.patch
|
||||||
Patch31: glibc-deprecated-selinux-nscd.patch
|
Patch31: glibc-deprecated-selinux-nscd.patch
|
||||||
Patch32: glibc-gconv-modules-revert.patch
|
|
||||||
Patch33: glibc-rh697421.patch
|
Patch33: glibc-rh697421.patch
|
||||||
Patch34: glibc-nosymlink-1.patch
|
Patch34: glibc-nosymlink-1.patch
|
||||||
Patch35: glibc-nosymlink-2.patch
|
Patch35: glibc-nosymlink-2.patch
|
||||||
@ -2186,6 +2185,38 @@ fi
|
|||||||
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 15 2021 Florian Weimer <fweimer@redhat.com> - 2.33.9000-17
|
||||||
|
- Dropped glibc-gconv-modules-revert.patch, applied upstream.
|
||||||
|
- Auto-sync with upstream branch master,
|
||||||
|
commit aa9a7f629632c9180de89632d4f2c1e6039f7781:
|
||||||
|
- nptl: Export _pthread_cleanup_push, _pthread_cleanup_pop again
|
||||||
|
- s390x: Align child stack while clone. [BZ #27968]
|
||||||
|
- y2038: Add test coverage
|
||||||
|
- libsupport: Add 64-bit time_t support for stat functions
|
||||||
|
- libsupport: Add 64-bit time_t support for time functions
|
||||||
|
- io: Add ftw64 with 64-bit time_t support
|
||||||
|
- io: Add fts64 with 64-bit time_t support
|
||||||
|
- posix: Add glob64 with 64-bit time_t support
|
||||||
|
- y2038: Add support for 64-bit time on legacy ABIs
|
||||||
|
- time: Add 64-bit time support for getdate
|
||||||
|
- y2038: Add __USE_TIME_BITS64 support for socket-constants.h
|
||||||
|
- y2038: Use a common definition for shmid_ds
|
||||||
|
- y2038: Use a common definition for semid_ds
|
||||||
|
- y2038: Use a common definition for msqid_ds
|
||||||
|
- y2038: Use a common definition for stat
|
||||||
|
- y2038: linux: Add __USE_TIME_BITS64 support for struct timex
|
||||||
|
- y2038: Add __USE_TIME_BITS64 support for struct utimbuf
|
||||||
|
- y2038: Add __USE_TIME_BITS64 support for struct timespec
|
||||||
|
- y2038: Add __USE_TIME_BITS64 support for struct timeval
|
||||||
|
- y2038: Add __USE_TIME_BITS64 support for time_t
|
||||||
|
- linux: Add recvvmsg fallback for 64-bit time_t SO_TIMESTAMP{NS}
|
||||||
|
- linux: Add fallback for 64-bit time_t SO_TIMESTAMP{NS}
|
||||||
|
- linux: Add fallback for 64-bit time_t SO_{RCV,SND}TIMEO
|
||||||
|
- linux: s390: Add libanl.abilist in s390 and s390x
|
||||||
|
- linux: mips: Split libanl.abilist in n32 and n64
|
||||||
|
- linux: mips: Split librt.abilist in n32 and n64
|
||||||
|
- Reinstate gconv-modules as the default configuration file
|
||||||
|
|
||||||
* Tue Jun 15 2021 Florian Weimer <fweimer@redhat.com> - 2.33.9000-16
|
* Tue Jun 15 2021 Florian Weimer <fweimer@redhat.com> - 2.33.9000-16
|
||||||
- Preserve some symbols in libc.so.6's symtab (#1965374)
|
- Preserve some symbols in libc.so.6's symtab (#1965374)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glibc-2.33.9000-701-gebae2f5a6f.tar.xz) = 1bf82ebfa0cce166a09d31a5b36e7ab456fc7c588f3a2454ce439c94d92fd54bce05ecf263cb6f555f8ce85b86a5718235cb72dbfdd05f85e898a7c8ff971b72
|
SHA512 (glibc-2.33.9000-728-gaa9a7f6296.tar.xz) = 99af420fe04976754515154aa9b60769624b431bdfeedcdcea62b1357fc6ef0f1f5f84bac203eb5af142d5eff0034fdc25e55b4fe644aec8b3d283f0e0e14bd8
|
||||||
|
Loading…
Reference in New Issue
Block a user