auto-import glibc-2.3.3-73 on branch devel from glibc-2.3.3-73.src.rpm

This commit is contained in:
Jakub Jelinek 2004-10-21 11:56:17 +00:00
parent 6bd344f17f
commit 03d052509c
2 changed files with 174 additions and 1 deletions

View File

@ -1300,6 +1300,39 @@
based on:
VERSION 2.7.0 Sun Mar 11 14:14:06 2001 Doug Lea (dl at gee)
--- glibc-20041021T0701/manual/errno.texi 20 Oct 2004 10:05:01 -0000 1.69
+++ glibc-20041021T0701-fedora/manual/errno.texi 21 Oct 2004 11:46:42 -0000 1.68.2.2
@@ -1229,30 +1229,6 @@ They are not yet documented.}
@comment errno ???/???
@end deftypevr
-@comment errno.h
-@comment Linux???: Required key not available
-@deftypevr Macro int ENOKEY
-@comment errno ???/???
-@end deftypevr
-
-@comment errno.h
-@comment Linux???: Key has expired
-@deftypevr Macro int EKEYEXPIRED
-@comment errno ???/???
-@end deftypevr
-
-@comment errno.h
-@comment Linux???: Key has been revoked
-@deftypevr Macro int EKEYREVOKED
-@comment errno ???/???
-@end deftypevr
-
-@comment errno.h
-@comment Linux???: Key was rejected by service
-@deftypevr Macro int EKEYREJECTED
-@comment errno ???/???
-@end deftypevr
-
@node Error Messages, , Error Codes, Error Reporting
@section Error Messages
--- glibc-20041021T0701/nptl/ChangeLog 18 Oct 2004 04:19:48 -0000 1.723
+++ glibc-20041021T0701-fedora/nptl/ChangeLog 18 Oct 2004 09:58:48 -0000 1.706.2.12
@@ -242,6 +242,11 @@
@ -1914,6 +1947,127 @@
#define CACHEMAGIC "ld.so-1.7.0"
/* libc5 and glibc 2.0/2.1 use the same format. For glibc 2.2 another
--- glibc-20041021T0701/sysdeps/gnu/Makefile 20 Oct 2004 10:04:57 -0000 1.19
+++ glibc-20041021T0701-fedora/sysdeps/gnu/Makefile 21 Oct 2004 11:46:42 -0000 1.18.2.2
@@ -49,14 +49,10 @@ endif
# Make it unwritable so noone will edit it by mistake.
-chmod a-w $@T
mv -f $@T $@
-$(objpfx)errlist-compat.h: $(objpfx)errlist-compat.c
- sed -n '1p;/ERR_MAX/p' $< > $@T
- -chmod a-w $@T
- mv -f $@T $@
-generated += errlist-compat.c errlist-compat.h
+generated += errlist-compat.c
# This will force the generation above to happy if need be.
-$(foreach o,.d $(object-suffixes),$(objpfx)errlist$o):$(objpfx)errlist-compat.h
+$(foreach o,.d $(object-suffixes),$(objpfx)errlist$o):$(objpfx)errlist-compat.c
endif
ifeq ($(subdir),login)
--- glibc-20041021T0701/sysdeps/gnu/errlist-compat.awk 20 Oct 2004 10:04:57 -0000 1.6
+++ glibc-20041021T0701-fedora/sysdeps/gnu/errlist-compat.awk 21 Oct 2004 11:46:42 -0000 1.5.2.2
@@ -59,7 +59,7 @@ END {
count = maxerr + 1;
- if (highest < count) {
+ if (highest != count) {
printf "*** errlist.c count %d vs Versions sys_errlist@%s count %d\n", \
count, highest_version, highest > "/dev/stderr";
exit 1;
@@ -79,12 +79,6 @@ END {
print "/* This file was generated by errlist-compat.awk; DO NOT EDIT! */\n";
print "#include <shlib-compat.h>\n";
- if (highest > count) {
- printf "*** errlist.c count %d inflated to %s count %d (old errno.h?)\n", \
- count, highest_version, highest > "/dev/stderr";
- printf "#define ERR_MAX %d\n\n", highest;
- }
-
for (old in compat) {
new = compat[old];
n = vcount[old];
--- glibc-20041021T0701/sysdeps/gnu/errlist.awk 20 Oct 2004 10:04:57 -0000 1.22
+++ glibc-20041021T0701-fedora/sysdeps/gnu/errlist.awk 21 Oct 2004 11:46:42 -0000 1.21.2.2
@@ -47,16 +47,7 @@ BEGIN {
print "#endif";
print "";
- print "#if !defined EMIT_ERR_MAX && !defined ERRLIST_NO_COMPAT";
- print "# include <errlist-compat.h>";
- print "#endif";
- print "#ifdef ERR_MAX";
- print "# define ERRLIST_SIZE ERR_MAX + 1";
- print "#else"
- print "# define ERRLIST_SIZE";
- print "#endif";
-
- print "const char *const _sys_errlist_internal[ERRLIST_SIZE] =";
+ print "const char *const _sys_errlist_internal[] =";
print " {";
print " [0] = N_(\"Success\"),"
}
--- glibc-20041021T0701/sysdeps/gnu/errlist.c 20 Oct 2004 10:05:01 -0000 1.30
+++ glibc-20041021T0701-fedora/sysdeps/gnu/errlist.c 21 Oct 2004 11:46:42 -0000 1.27.2.2
@@ -7,15 +7,7 @@
# define ERR_REMAP(n) n
#endif
-#if !defined EMIT_ERR_MAX && !defined ERRLIST_NO_COMPAT
-# include <errlist-compat.h>
-#endif
-#ifdef ERR_MAX
-# define ERRLIST_SIZE ERR_MAX + 1
-#else
-# define ERRLIST_SIZE
-#endif
-const char *const _sys_errlist_internal[ERRLIST_SIZE] =
+const char *const _sys_errlist_internal[] =
{
[0] = N_("Success"),
#ifdef EPERM
@@ -1408,38 +1400,6 @@ TRANS error; @pxref{Cancel AIO Operation
# define ERR_MAX EMEDIUMTYPE
# endif
#endif
-#ifdef ENOKEY
-/* */
- [ERR_REMAP (ENOKEY)] = N_("Required key not available"),
-# if ENOKEY > ERR_MAX
-# undef ERR_MAX
-# define ERR_MAX ENOKEY
-# endif
-#endif
-#ifdef EKEYEXPIRED
-/* */
- [ERR_REMAP (EKEYEXPIRED)] = N_("Key has expired"),
-# if EKEYEXPIRED > ERR_MAX
-# undef ERR_MAX
-# define ERR_MAX EKEYEXPIRED
-# endif
-#endif
-#ifdef EKEYREVOKED
-/* */
- [ERR_REMAP (EKEYREVOKED)] = N_("Key has been revoked"),
-# if EKEYREVOKED > ERR_MAX
-# undef ERR_MAX
-# define ERR_MAX EKEYREVOKED
-# endif
-#endif
-#ifdef EKEYREJECTED
-/* */
- [ERR_REMAP (EKEYREJECTED)] = N_("Key was rejected by service"),
-# if EKEYREJECTED > ERR_MAX
-# undef ERR_MAX
-# define ERR_MAX EKEYREJECTED
-# endif
-#endif
};
const int _sys_nerr_internal
--- glibc-20041021T0701/sysdeps/i386/bits/atomic.h 1 Jan 1970 00:00:00 -0000
+++ glibc-20041021T0701-fedora/sysdeps/i386/bits/atomic.h 5 Oct 2004 12:09:44 -0000 1.1.2.3
@@ -0,0 +1,410 @@
@ -2796,6 +2950,21 @@
if (result != -1)
return getpriority (PRIO_PROCESS, 0);
else
--- glibc-20041021T0701/sysdeps/unix/sysv/linux/Versions 20 Oct 2004 10:05:00 -0000 1.25
+++ glibc-20041021T0701-fedora/sysdeps/unix/sysv/linux/Versions 21 Oct 2004 11:46:43 -0000 1.23.2.3
@@ -114,12 +114,6 @@ libc {
}
GLIBC_2.3.4 {
sched_getaffinity; sched_setaffinity;
-
- # new syscalls
- setaltroot; add_key; request_key; keyctl;
-
- #errlist-compat 129
- _sys_errlist; sys_errlist; _sys_nerr; sys_nerr;
}
GLIBC_PRIVATE {
# functions used in other libraries
--- glibc-20041021T0701/sysdeps/unix/sysv/linux/paths.h 15 Nov 2000 23:06:47 -0000 1.11
+++ glibc-20041021T0701-fedora/sysdeps/unix/sysv/linux/paths.h 22 Sep 2004 21:21:08 -0000 1.11.4.1
@@ -61,7 +61,7 @@

View File

@ -1,6 +1,6 @@
%define glibcdate 20041021T0701
%define glibcversion 2.3.3
%define glibcrelease 72
%define glibcrelease 73
%define auxarches i586 i686 athlon sparcv9 alphaev6
%define prelinkarches noarch
%define nptlarches i386 i686 athlon x86_64 ia64 s390 s390x sparcv9 ppc ppc64
@ -1258,6 +1258,10 @@ rm -f *.filelist*
%endif
%changelog
* Thu Oct 21 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-73
- remove setaltroot and key{_add,_request,ctl} also from Versions
- back out _sys_errlist changes
* Thu Oct 21 2004 Jakub Jelinek <jakub@redhat.com> 2.3.3-72
- back out setaltroot and key{_add,_request,ctl} addition
- fix severe x86-64 symbol versioning regressions that breaks