- Resync with master (#882137).
- Remove local patch for strict-aliasing warnings that is no longer needed. - Remove local patch for 730856 that is no longer needed. - Repack patchlist.
This commit is contained in:
parent
f5dc60f992
commit
03545a8efd
2
.gitignore
vendored
2
.gitignore
vendored
@ -75,3 +75,5 @@ glibc-2.14-394-g8f3b1ff
|
||||
/glibc-2.16.90-14bc93a9.tar.gz
|
||||
/glibc-2.16.90-2af1b328-fedora.tar.gz
|
||||
/glibc-2.16.90-2af1b328.tar.gz
|
||||
/glibc-2.16.90-1a538b9f-fedora.tar.gz
|
||||
/glibc-2.16.90-1a538b9f.tar.gz
|
||||
|
@ -1,39 +0,0 @@
|
||||
[ Several unnecessary hunks from this patch have been removed. ]
|
||||
From 96aefb90e843648812d1832789f4a88ea5350605 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schwab <schwab@redhat.com>
|
||||
Date: Tue, 25 May 2010 15:09:20 +0200
|
||||
Subject: [PATCH] Avoid strict-aliasing issues
|
||||
|
||||
---
|
||||
elf/Makefile | 1 +
|
||||
inet/Makefile | 2 ++
|
||||
nis/Makefile | 2 ++
|
||||
nss/Makefile | 1 +
|
||||
resolv/Makefile | 1 +
|
||||
sunrpc/Makefile | 4 ++++
|
||||
sysdeps/powerpc/powerpc64/elf/Makefile | 2 ++
|
||||
7 files changed, 13 insertions(+), 0 deletions(-)
|
||||
diff -Nrup a/inet/Makefile b/inet/Makefile
|
||||
--- a/inet/Makefile 2012-08-29 07:45:37.000000000 -0600
|
||||
+++ b/inet/Makefile 2012-08-30 09:42:41.981592916 -0600
|
||||
@@ -54,6 +54,8 @@ tests := htontest test_ifindex tst-ntoa
|
||||
|
||||
include ../Rules
|
||||
|
||||
+CFLAGS-tst-inet6_rth.c += -fno-strict-aliasing
|
||||
+
|
||||
ifeq ($(have-thread-library),yes)
|
||||
|
||||
CFLAGS-gethstbyad_r.c = -fexceptions
|
||||
diff -Nrup a/sysdeps/powerpc/powerpc64/Makefile b/sysdeps/powerpc/powerpc64/Makefile
|
||||
--- a/sysdeps/powerpc/powerpc64/Makefile 2012-08-30 09:42:17.872692135 -0600
|
||||
+++ b/sysdeps/powerpc/powerpc64/Makefile 2012-08-30 09:42:42.024592741 -0600
|
||||
@@ -37,6 +37,8 @@ CFLAGS-rtld-strnlen.os = $(no-special-re
|
||||
|
||||
CFLAGS-libc-start.c += -fno-asynchronous-unwind-tables
|
||||
|
||||
+CFLAGS-gmon-start.c += -fno-strict-aliasing
|
||||
+
|
||||
ifeq ($(subdir),csu)
|
||||
sysdep_routines += hp-timing
|
||||
elide-routines.os += hp-timing
|
@ -1,52 +0,0 @@
|
||||
diff -rup a/resolv/res_query.c b/resolv/res_query.c
|
||||
--- a/resolv/res_query.c 2012-02-16 22:51:17.451796009 -0700
|
||||
+++ b/resolv/res_query.c 2012-02-16 22:54:42.522623598 -0700
|
||||
@@ -122,6 +122,7 @@ __libc_res_nquery(res_state statp,
|
||||
int *resplen2)
|
||||
{
|
||||
HEADER *hp = (HEADER *) answer;
|
||||
+ HEADER *hp2;
|
||||
int n, use_malloc = 0;
|
||||
u_int oflags = statp->_flags;
|
||||
|
||||
@@ -239,26 +240,25 @@ __libc_res_nquery(res_state statp,
|
||||
/* __libc_res_nsend might have reallocated the buffer. */
|
||||
hp = (HEADER *) *answerp;
|
||||
|
||||
- /* We simplify the following tests by assigning HP to HP2. It
|
||||
- is easy to verify that this is the same as ignoring all
|
||||
- tests of HP2. */
|
||||
- HEADER *hp2 = answerp2 ? (HEADER *) *answerp2 : hp;
|
||||
-
|
||||
- if (n < (int) sizeof (HEADER) && answerp2 != NULL
|
||||
- && *resplen2 > (int) sizeof (HEADER))
|
||||
+ /* We simplify the following tests by assigning HP to HP2 or
|
||||
+ vice versa. It is easy to verify that this is the same as
|
||||
+ ignoring all tests of HP or HP2. */
|
||||
+ if (answerp2 == NULL || *resplen2 < (int) sizeof (HEADER))
|
||||
{
|
||||
- /* Special case of partial answer. */
|
||||
- assert (hp != hp2);
|
||||
- hp = hp2;
|
||||
+ hp2 = hp;
|
||||
}
|
||||
- else if (answerp2 != NULL && *resplen2 < (int) sizeof (HEADER)
|
||||
- && n > (int) sizeof (HEADER))
|
||||
+ else
|
||||
{
|
||||
- /* Special case of partial answer. */
|
||||
- assert (hp != hp2);
|
||||
- hp2 = hp;
|
||||
+ hp2 = (HEADER *) *answerp2;
|
||||
+ if (n < (int) sizeof (HEADER))
|
||||
+ {
|
||||
+ hp = hp2;
|
||||
+ }
|
||||
}
|
||||
|
||||
+ /* Make sure both hp and hp2 are defined */
|
||||
+ assert((hp != NULL) && (hp2 != NULL));
|
||||
+
|
||||
if ((hp->rcode != NOERROR || ntohs(hp->ancount) == 0)
|
||||
&& (hp2->rcode != NOERROR || ntohs(hp2->ancount) == 0)) {
|
||||
#ifdef DEBUG
|
24
glibc.spec
24
glibc.spec
@ -1,4 +1,4 @@
|
||||
%define glibcsrcdir glibc-2.16.90-2af1b328
|
||||
%define glibcsrcdir glibc-2.16.90-1a538b9f
|
||||
%define glibcversion 2.16.90
|
||||
### glibc.spec.in follows:
|
||||
%define run_glibc_tests 1
|
||||
@ -27,7 +27,7 @@
|
||||
Summary: The GNU libc libraries
|
||||
Name: glibc
|
||||
Version: %{glibcversion}
|
||||
Release: 34%{?dist}
|
||||
Release: 35%{?dist}
|
||||
# GPLv2+ is used in a bunch of programs, LGPLv2+ is used for libraries.
|
||||
# Things that are linked directly into dynamically linked programs
|
||||
# and shared libraries (e.g. crt files, lib*_nonshared.a) have an additional
|
||||
@ -90,9 +90,9 @@ Patch0009: %{name}-rh657588.patch
|
||||
# stap, needs to be sent upstream
|
||||
Patch0010: %{name}-stap-libm.patch
|
||||
|
||||
Patch0012: %{name}-fedora-linux-tcsetattr.patch
|
||||
Patch0014: %{name}-fedora-nptl-linklibc.patch
|
||||
|
||||
Patch0018: %{name}-fedora-strict-aliasing.patch
|
||||
Patch0018: %{name}-fedora-localedata-locales-fixes.patch
|
||||
Patch0019: %{name}-fedora-nis-rh188246.patch
|
||||
Patch0020: %{name}-fedora-manual-dircategory.patch
|
||||
Patch0024: %{name}-fedora-locarchive.patch
|
||||
@ -120,8 +120,6 @@ Patch0040: %{name}-fedora-i386-tls-direct-seg-refs.patch
|
||||
Patch0041: %{name}-fedora-pt_chown.patch
|
||||
Patch0042: %{name}-fedora-include-bits-ldbl.patch
|
||||
Patch0043: %{name}-fedora-ldd.patch
|
||||
Patch0044: %{name}-fedora-linux-tcsetattr.patch
|
||||
Patch0045: %{name}-fedora-localedata-locales-fixes.patch
|
||||
|
||||
#
|
||||
# Patches from upstream
|
||||
@ -136,9 +134,6 @@ Patch0045: %{name}-fedora-localedata-locales-fixes.patch
|
||||
|
||||
Patch2011: %{name}-rh757881.patch
|
||||
|
||||
# Upstream BZ 13013
|
||||
Patch2012: %{name}-rh730856.patch
|
||||
|
||||
Patch2013: %{name}-rh741105.patch
|
||||
Patch2015: %{name}-rh770439.patch
|
||||
Patch2016: %{name}-rh789209.patch
|
||||
@ -393,7 +388,7 @@ package or when debugging this package.
|
||||
%patch0009 -p1
|
||||
%patch0010 -p1
|
||||
%patch2011 -p1
|
||||
%patch2012 -p1
|
||||
%patch0012 -p1
|
||||
%patch2013 -p1
|
||||
%patch0014 -p1
|
||||
%patch2015 -p1
|
||||
@ -425,8 +420,6 @@ package or when debugging this package.
|
||||
%patch0041 -p1
|
||||
%patch0042 -p1
|
||||
%patch0043 -p1
|
||||
%patch0044 -p1
|
||||
%patch0045 -p1
|
||||
|
||||
# On powerpc32, hp timing is only available in power4/power6
|
||||
# libs, not in base, so pre-power4 dynamic linker is incompatible
|
||||
@ -1221,6 +1214,13 @@ rm -f *.filelist*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Nov 30 2012 Jeff Law <law@redhat.com> - 2.16.90-35
|
||||
- Resync with master (#882137).
|
||||
- Remove local patch for strict-aliasing warnings that
|
||||
is no longer needed.
|
||||
- Remove local patch for 730856 that is no longer needed.
|
||||
- Repack patchlist.
|
||||
|
||||
* Thu Nov 29 2012 Jeff Law <law@redhat.com> - 2.16.90-34
|
||||
- Remove local patch which "temporarily" re-added currences
|
||||
obsoleted by the Euro.
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
f708bdecec850f4035d5242f80be3d02 glibc-2.16.90-2af1b328-fedora.tar.gz
|
||||
35892d87ef0c9cbb694ef023b37019f2 glibc-2.16.90-2af1b328.tar.gz
|
||||
f55e091ccdae9a29dd183116091ed679 glibc-2.16.90-1a538b9f-fedora.tar.gz
|
||||
37289795583e3897226edf1ad24c261a glibc-2.16.90-1a538b9f.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user