fix a statfs configure check
This commit is contained in:
parent
e25bf3737d
commit
f3e67eddfe
@ -3,7 +3,7 @@
|
||||
Summary: A library of handy utility functions
|
||||
Name: glib2
|
||||
Version: 2.17.4
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.gtk.org
|
||||
@ -25,6 +25,9 @@ Patch2: gio-2.16-only-pass-uri-to-gio-apps.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=529694
|
||||
Patch3: gio-2.16-selinux-set-support.diff
|
||||
|
||||
# fixed in svn
|
||||
Patch4: statfs-check.patch
|
||||
|
||||
%description
|
||||
GLib is the low-level core library that forms the basis
|
||||
for projects such as GTK+ and GNOME. It provides data structure
|
||||
@ -58,6 +61,7 @@ of version 2 of the GLib library.
|
||||
%setup -q -n glib-%{version}
|
||||
%patch2 -p1 -b .only-pass-uri-to-gio-apps
|
||||
%patch3 -p0 -b .selinux
|
||||
%patch4 -p1 -b .statfs-check
|
||||
|
||||
%build
|
||||
%configure --disable-gtk-doc --enable-static
|
||||
@ -132,6 +136,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/lib*.a
|
||||
|
||||
%changelog
|
||||
* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 2.17.4-2
|
||||
- Fix statfs configure check
|
||||
|
||||
* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 2.17.4-1
|
||||
- Update to 2.17.4
|
||||
|
||||
|
78
statfs-check.patch
Normal file
78
statfs-check.patch
Normal file
@ -0,0 +1,78 @@
|
||||
diff -up glib-2.17.4/configure.in.statfs-check glib-2.17.4/configure.in
|
||||
--- glib-2.17.4/configure.in.statfs-check 2008-07-21 18:24:45.000000000 -0400
|
||||
+++ glib-2.17.4/configure.in 2008-07-21 18:25:19.000000000 -0400
|
||||
@@ -847,6 +847,7 @@ AC_CHECK_HEADERS([mntent.h sys/mnttab.h
|
||||
AC_CHECK_MEMBERS([struct stat.st_mtimensec, struct stat.st_mtim.tv_nsec, struct stat.st_atimensec, struct stat.st_atim.tv_nsec, struct stat.st_ctimensec, struct stat.st_ctim.tv_nsec])
|
||||
AC_CHECK_MEMBERS([struct stat.st_blksize, struct stat.st_blocks, struct statfs.f_fstypename, struct statfs.f_bavail],,, [#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
diff -up glib-2.17.4/configure.statfs-check glib-2.17.4/configure
|
||||
--- glib-2.17.4/configure.statfs-check 2008-07-21 18:25:36.000000000 -0400
|
||||
+++ glib-2.17.4/configure 2008-07-21 18:25:47.000000000 -0400
|
||||
@@ -33300,6 +33300,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33349,6 +33350,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33421,6 +33423,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33470,6 +33473,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33542,6 +33546,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33591,6 +33596,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33663,6 +33669,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
||||
@@ -33712,6 +33719,7 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/statfs.h>
|
||||
#include <unistd.h>
|
||||
#ifdef HAVE_SYS_PARAM_H
|
||||
#include <sys/param.h>
|
Loading…
Reference in New Issue
Block a user