Update to 2.73.1

Refresh hmac patch. Remove unnecessary chrpath usage.
This commit is contained in:
David King 2022-06-21 22:01:43 +01:00
parent a6c06e2d2b
commit d160263355
3 changed files with 43 additions and 57 deletions

View File

@ -1,10 +1,10 @@
Name: glib2 Name: glib2
Version: 2.72.2 Version: 2.73.1
Release: %autorelease Release: %autorelease
Summary: A library of handy utility functions Summary: A library of handy utility functions
License: LGPLv2+ License: LGPLv2+
URL: https://www.gtk.org URL: https://www.gtk.org
Source0: https://download.gnome.org/sources/glib/2.72/glib-%{version}.tar.xz Source0: https://download.gnome.org/sources/glib/2.72/glib-%{version}.tar.xz
# Required for RHEL core crypto components policy. Good for Fedora too. # Required for RHEL core crypto components policy. Good for Fedora too.
@ -17,7 +17,6 @@ Patch0: gnutls-hmac.patch
# Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596 # Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596
Patch1: gdesktopappinfo.patch Patch1: gdesktopappinfo.patch
BuildRequires: chrpath
BuildRequires: gcc BuildRequires: gcc
BuildRequires: gcc-c++ BuildRequires: gcc-c++
BuildRequires: gettext BuildRequires: gettext
@ -97,10 +96,6 @@ the functionality of the installed glib2 package.
%autosetup -n glib-%{version} -p1 %autosetup -n glib-%{version} -p1
%build %build
# No surprise bundled libraries
rm -rf glib/pcre
rm -rf subprojects
%meson \ %meson \
-Dman=true \ -Dman=true \
-Ddtrace=true \ -Ddtrace=true \
@ -129,8 +124,6 @@ rm -rf subprojects
# do this, see https://github.com/mesonbuild/meson/issues/5027. # do this, see https://github.com/mesonbuild/meson/issues/5027.
touch -r gio/gdbus-2.0/codegen/config.py.in %{buildroot}%{_datadir}/glib-2.0/codegen/*.py touch -r gio/gdbus-2.0/codegen/config.py.in %{buildroot}%{_datadir}/glib-2.0/codegen/*.py
chrpath --delete %{buildroot}%{_libdir}/*.so
# Perform byte compilation manually to avoid issues with # Perform byte compilation manually to avoid issues with
# irreproducibility of the default invalidation mode, see # irreproducibility of the default invalidation mode, see
# https://www.python.org/dev/peps/pep-0552/ and # https://www.python.org/dev/peps/pep-0552/ and
@ -158,8 +151,8 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || : glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
%files -f glib20.lang %files -f glib20.lang
%license COPYING %license LICENSES/LGPL-2.1-or-later.txt
%doc AUTHORS NEWS README %doc NEWS README.md
%{_libdir}/libglib-2.0.so.* %{_libdir}/libglib-2.0.so.*
%{_libdir}/libgthread-2.0.so.* %{_libdir}/libgthread-2.0.so.*
%{_libdir}/libgmodule-2.0.so.* %{_libdir}/libgmodule-2.0.so.*

View File

@ -1,4 +1,4 @@
From ef7a063ee6f5bd8642fd04b717e7d075b9f33ec0 Mon Sep 17 00:00:00 2001 From 26f1dfc846cc6c712fc34f039e75261f4a821c97 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org> From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 18:44:43 +0000 Date: Fri, 7 Jun 2019 18:44:43 +0000
Subject: [PATCH 1/4] ghmac: Split off wrapper functions into ghmac-utils.c Subject: [PATCH 1/4] ghmac: Split off wrapper functions into ghmac-utils.c
@ -164,11 +164,11 @@ index 000000000..a17359ff1
+ (const guchar *) str, length); + (const guchar *) str, length);
+} +}
diff --git a/glib/ghmac.c b/glib/ghmac.c diff --git a/glib/ghmac.c b/glib/ghmac.c
index 54da9f936..8358897b0 100644 index 7ad28d6f0..516b01b24 100644
--- a/glib/ghmac.c --- a/glib/ghmac.c
+++ b/glib/ghmac.c +++ b/glib/ghmac.c
@@ -327,115 +327,3 @@ g_hmac_get_digest (GHmac *hmac, @@ -353,115 +353,3 @@ g_hmac_get_digest (GHmac *hmac,
g_checksum_update (hmac->digesto, buffer, len); g_checksum_update (hmac->digesto, buffer, len_signed);
g_checksum_get_digest (hmac->digesto, buffer, digest_len); g_checksum_get_digest (hmac->digesto, buffer, digest_len);
} }
- -
@ -284,10 +284,10 @@ index 54da9f936..8358897b0 100644
- (const guchar *) str, length); - (const guchar *) str, length);
-} -}
diff --git a/glib/meson.build b/glib/meson.build diff --git a/glib/meson.build b/glib/meson.build
index 025e448ad..a672857b4 100644 index 4f8240b24..224d1b781 100644
--- a/glib/meson.build --- a/glib/meson.build
+++ b/glib/meson.build +++ b/glib/meson.build
@@ -244,6 +244,7 @@ glib_sources = files( @@ -248,6 +248,7 @@ glib_sources = files(
'ggettext.c', 'ggettext.c',
'ghash.c', 'ghash.c',
'ghmac.c', 'ghmac.c',
@ -296,10 +296,10 @@ index 025e448ad..a672857b4 100644
'ghostutils.c', 'ghostutils.c',
'giochannel.c', 'giochannel.c',
-- --
2.34.1 2.36.1
From bf0e7adb2e60f02fc2fb9c25f773379c1c3a3ec7 Mon Sep 17 00:00:00 2001 From 3f5a2aa275d779e832cddab6bdb391fed8e8d8ae Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org> From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 19:36:54 +0000 Date: Fri, 7 Jun 2019 19:36:54 +0000
Subject: [PATCH 2/4] Add a gnutls backend for GHmac Subject: [PATCH 2/4] Add a gnutls backend for GHmac
@ -355,16 +355,16 @@ https://gitlab.gnome.org/GNOME/glib/-/merge_requests/903
glib/ghmac.c | 15 ++++ glib/ghmac.c | 15 ++++
glib/meson.build | 10 ++- glib/meson.build | 10 ++-
meson.build | 7 ++ meson.build | 7 ++
meson_options.txt | 7 +- meson_options.txt | 5 ++
7 files changed, 260 insertions(+), 7 deletions(-) 7 files changed, 259 insertions(+), 6 deletions(-)
create mode 100644 glib/gchecksumprivate.h create mode 100644 glib/gchecksumprivate.h
create mode 100644 glib/ghmac-gnutls.c create mode 100644 glib/ghmac-gnutls.c
diff --git a/glib/gchecksum.c b/glib/gchecksum.c diff --git a/glib/gchecksum.c b/glib/gchecksum.c
index 29b479bc6..929958c3a 100644 index fea7803cd..3c443840e 100644
--- a/glib/gchecksum.c --- a/glib/gchecksum.c
+++ b/glib/gchecksum.c +++ b/glib/gchecksum.c
@@ -20,7 +20,7 @@ @@ -22,7 +22,7 @@
#include <string.h> #include <string.h>
@ -373,7 +373,7 @@ index 29b479bc6..929958c3a 100644
#include "gslice.h" #include "gslice.h"
#include "gmem.h" #include "gmem.h"
@@ -173,9 +173,9 @@ sha_byte_reverse (guint32 *buffer, @@ -175,9 +175,9 @@ sha_byte_reverse (guint32 *buffer,
} }
#endif /* G_BYTE_ORDER == G_BIG_ENDIAN */ #endif /* G_BYTE_ORDER == G_BIG_ENDIAN */
@ -386,7 +386,7 @@ index 29b479bc6..929958c3a 100644
{ {
gsize i, len = digest_len * 2; gsize i, len = digest_len * 2;
gchar *retval; gchar *retval;
@@ -194,6 +194,7 @@ digest_to_string (guint8 *digest, @@ -196,6 +196,7 @@ digest_to_string (guint8 *digest,
return retval; return retval;
} }
@ -627,10 +627,10 @@ index 000000000..9fb775f89
+ *digest_len = g_checksum_type_get_length (hmac->digest_type); + *digest_len = g_checksum_type_get_length (hmac->digest_type);
+} +}
diff --git a/glib/ghmac.c b/glib/ghmac.c diff --git a/glib/ghmac.c b/glib/ghmac.c
index 8358897b0..ba0d2d55c 100644 index 516b01b24..a4851cc64 100644
--- a/glib/ghmac.c --- a/glib/ghmac.c
+++ b/glib/ghmac.c +++ b/glib/ghmac.c
@@ -33,6 +33,9 @@ @@ -35,6 +35,9 @@
#include "gtypes.h" #include "gtypes.h"
#include "glibintl.h" #include "glibintl.h"
@ -640,7 +640,7 @@ index 8358897b0..ba0d2d55c 100644
/** /**
* SECTION:hmac * SECTION:hmac
@@ -84,6 +87,18 @@ struct _GHmac @@ -86,6 +89,18 @@ struct _GHmac
* Support for digests of type %G_CHECKSUM_SHA512 has been added in GLib 2.42. * Support for digests of type %G_CHECKSUM_SHA512 has been added in GLib 2.42.
* Support for %G_CHECKSUM_SHA384 was added in GLib 2.52. * Support for %G_CHECKSUM_SHA384 was added in GLib 2.52.
* *
@ -660,10 +660,10 @@ index 8358897b0..ba0d2d55c 100644
* Use g_hmac_unref() to free the memory allocated by it. * Use g_hmac_unref() to free the memory allocated by it.
* *
diff --git a/glib/meson.build b/glib/meson.build diff --git a/glib/meson.build b/glib/meson.build
index a672857b4..2c43ac0d4 100644 index 224d1b781..9c9919d0a 100644
--- a/glib/meson.build --- a/glib/meson.build
+++ b/glib/meson.build +++ b/glib/meson.build
@@ -243,7 +243,6 @@ glib_sources = files( @@ -247,7 +247,6 @@ glib_sources = files(
'gfileutils.c', 'gfileutils.c',
'ggettext.c', 'ggettext.c',
'ghash.c', 'ghash.c',
@ -671,7 +671,7 @@ index a672857b4..2c43ac0d4 100644
'ghmac-utils.c', 'ghmac-utils.c',
'ghook.c', 'ghook.c',
'ghostutils.c', 'ghostutils.c',
@@ -299,6 +298,7 @@ glib_sources = files( @@ -303,6 +302,7 @@ glib_sources = files(
'guriprivate.h', 'guriprivate.h',
'gutils.c', 'gutils.c',
'gutilsprivate.h', 'gutilsprivate.h',
@ -679,7 +679,7 @@ index a672857b4..2c43ac0d4 100644
'guuid.c', 'guuid.c',
'gvariant.c', 'gvariant.c',
'gvariant-core.c', 'gvariant-core.c',
@@ -352,6 +352,12 @@ else @@ -358,6 +358,12 @@ else
glib_dtrace_hdr = [] glib_dtrace_hdr = []
endif endif
@ -692,7 +692,7 @@ index a672857b4..2c43ac0d4 100644
pcre_static_args = [] pcre_static_args = []
if use_pcre_static_flag if use_pcre_static_flag
@@ -370,7 +376,7 @@ libglib = library('glib-2.0', @@ -376,7 +382,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags], link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc, include_directories : configinc,
link_with: [charset_lib, gnulib_lib], link_with: [charset_lib, gnulib_lib],
@ -702,10 +702,10 @@ index a672857b4..2c43ac0d4 100644
objc_args : glib_c_args, objc_args : glib_c_args,
) )
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 6e566d483..268f02b6f 100644 index 1234ba064..5d2c5ce72 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -2103,6 +2103,13 @@ if host_system == 'linux' @@ -2101,6 +2101,13 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found()) glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif endif
@ -718,9 +718,9 @@ index 6e566d483..268f02b6f 100644
+ +
if host_system == 'windows' if host_system == 'windows'
winsock2 = cc.find_library('ws2_32') winsock2 = cc.find_library('ws2_32')
endif else
diff --git a/meson_options.txt b/meson_options.txt diff --git a/meson_options.txt b/meson_options.txt
index 6cd7bc90a..65af1d276 100644 index a52eed9d2..4eb577798 100644
--- a/meson_options.txt --- a/meson_options.txt
+++ b/meson_options.txt +++ b/meson_options.txt
@@ -34,6 +34,11 @@ option('libmount', @@ -34,6 +34,11 @@ option('libmount',
@ -735,18 +735,11 @@ index 6cd7bc90a..65af1d276 100644
option('man', option('man',
type : 'boolean', type : 'boolean',
value : false, value : false,
@@ -121,4 +126,4 @@ option('glib_checks',
option('libelf',
type : 'feature',
value : 'auto',
- description : 'Enable support for listing and extracting from ELF resource files with gresource tool')
\ No newline at end of file
+ description : 'Enable support for listing and extracting from ELF resource files with gresource tool')
-- --
2.34.1 2.36.1
From 2fd58b32475d9f708a600cac16de7a159cfd11d5 Mon Sep 17 00:00:00 2001 From 31fce00ed870052205f7014ca594c751d87b1b0e Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com> From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:35:00 -0500 Date: Wed, 16 Jun 2021 20:35:00 -0500
Subject: [PATCH 3/4] dlopen GnuTLS instead of linking directly Subject: [PATCH 3/4] dlopen GnuTLS instead of linking directly
@ -915,10 +908,10 @@ index 9fb775f89..1800fc2e0 100644
hmac->digest_type = digest_type; hmac->digest_type = digest_type;
diff --git a/glib/ghmac.c b/glib/ghmac.c diff --git a/glib/ghmac.c b/glib/ghmac.c
index ba0d2d55c..913bf3864 100644 index a4851cc64..20e64fd00 100644
--- a/glib/ghmac.c --- a/glib/ghmac.c
+++ b/glib/ghmac.c +++ b/glib/ghmac.c
@@ -33,7 +33,7 @@ @@ -35,7 +35,7 @@
#include "gtypes.h" #include "gtypes.h"
#include "glibintl.h" #include "glibintl.h"
@ -928,10 +921,10 @@ index ba0d2d55c..913bf3864 100644
#endif #endif
diff --git a/glib/meson.build b/glib/meson.build diff --git a/glib/meson.build b/glib/meson.build
index 2c43ac0d4..6b6f692d9 100644 index 9c9919d0a..eefba8a0d 100644
--- a/glib/meson.build --- a/glib/meson.build
+++ b/glib/meson.build +++ b/glib/meson.build
@@ -376,7 +376,7 @@ libglib = library('glib-2.0', @@ -382,7 +382,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags], link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc, include_directories : configinc,
link_with: [charset_lib, gnulib_lib], link_with: [charset_lib, gnulib_lib],
@ -941,10 +934,10 @@ index 2c43ac0d4..6b6f692d9 100644
objc_args : glib_c_args, objc_args : glib_c_args,
) )
diff --git a/meson.build b/meson.build diff --git a/meson.build b/meson.build
index 268f02b6f..e24d68f74 100644 index 5d2c5ce72..27f30c4a8 100644
--- a/meson.build --- a/meson.build
+++ b/meson.build +++ b/meson.build
@@ -2103,11 +2103,9 @@ if host_system == 'linux' @@ -2101,11 +2101,9 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found()) glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif endif
@ -959,10 +952,10 @@ index 268f02b6f..e24d68f74 100644
if host_system == 'windows' if host_system == 'windows'
-- --
2.34.1 2.36.1
From c79f7b8560f8e7449eff3956bae2ab93cd11b018 Mon Sep 17 00:00:00 2001 From 0d8f792d2f2b359d00f2465120cb7dc60db107a5 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com> From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:46:24 -0500 Date: Wed, 16 Jun 2021 20:46:24 -0500
Subject: [PATCH 4/4] Add test for GHmac in FIPS mode Subject: [PATCH 4/4] Add test for GHmac in FIPS mode
@ -1093,5 +1086,5 @@ index 3ac3206df..2fa447984 100644
return g_test_run (); return g_test_run ();
} }
-- --
2.34.1 2.36.1

View File

@ -1 +1 @@
SHA512 (glib-2.72.2.tar.xz) = 9a1121be1d5b1de50fb732d55298a8deb6e6e7fe02e06ab18fdfbc51a0f0d77c13c5faf29a227b5746b0f8c1c0502fc79c36cef2b7a62c4701b9deffe5887e69 SHA512 (glib-2.73.1.tar.xz) = cb4bb51593c782534f8922d547d1fbb1800bfc51b01d96c42f335379d4ed22905804678d5bdb0c21ee61f0e20782f0013188c4d3f41e43e3f1ed3fb85e31d166