This commit is contained in:
Matthias Clasen 2008-01-08 14:00:58 +00:00
parent f142979080
commit 978e8ffdf0
7 changed files with 10 additions and 230 deletions

View File

@ -1 +1 @@
glib-2.15.0.tar.bz2 glib-2.15.1.tar.bz2

View File

@ -1,109 +0,0 @@
diff -up glib-2.15.0/gio/gdesktopappinfo.c.desktopfiles glib-2.15.0/gio/gdesktopappinfo.c
--- glib-2.15.0/gio/gdesktopappinfo.c.desktopfiles 2007-12-20 10:20:45.000000000 -0500
+++ glib-2.15.0/gio/gdesktopappinfo.c 2007-12-22 13:39:30.000000000 -0500
@@ -920,10 +920,10 @@ static gboolean
g_desktop_app_info_supports_uris (GAppInfo *appinfo)
{
GDesktopAppInfo *info = G_DESKTOP_APP_INFO (appinfo);
-
- return
- (strstr (info->exec, "%u") != NULL) ||
- (strstr (info->exec, "%U") != NULL);
+
+ return info->exec &&
+ ((strstr (info->exec, "%u") != NULL) ||
+ (strstr (info->exec, "%U") != NULL));
}
static gboolean
@@ -1581,7 +1581,8 @@ g_app_info_get_default_for_type (const c
* g_app_info_get_default_for_uri_scheme:
* @uri_scheme: a string containing a URI scheme.
*
- * Gets the default application for launching applications using this URI scheme.
+ * Gets the default application for launching applications
+ * using this URI scheme.
*
* TODO: This is currently unimplemented.
*
@@ -1625,11 +1626,12 @@ get_apps_from_dir (GHashTable *apps,
/* Don't return apps that don't take arguments */
if (appinfo &&
- g_desktop_app_info_get_is_hidden (appinfo) &&
- strstr (appinfo->exec,"%U") == NULL &&
- strstr (appinfo->exec,"%u") == NULL &&
- strstr (appinfo->exec,"%f") == NULL &&
- strstr (appinfo->exec,"%F") == NULL)
+ (g_desktop_app_info_get_is_hidden (appinfo) ||
+ (appinfo->exec &&
+ strstr (appinfo->exec,"%U") == NULL &&
+ strstr (appinfo->exec,"%u") == NULL &&
+ strstr (appinfo->exec,"%f") == NULL &&
+ strstr (appinfo->exec,"%F") == NULL)))
{
g_object_unref (appinfo);
appinfo = NULL;
@@ -1679,7 +1681,7 @@ g_app_info_get_all (void)
const char * const *dirs;
GHashTable *apps;
GHashTableIter iter;
- gpointer key;
+ gpointer value;
int i;
GList *infos;
@@ -1695,8 +1697,11 @@ g_app_info_get_all (void)
infos = NULL;
g_hash_table_iter_init (&iter, apps);
- while (g_hash_table_iter_next (&iter, &key, NULL))
- infos = g_list_prepend (infos, key);
+ while (g_hash_table_iter_next (&iter, NULL, &value))
+ {
+ if (value)
+ infos = g_list_prepend (infos, value);
+ }
g_hash_table_destroy (apps);
@@ -2142,13 +2147,13 @@ append_desktop_entry (GList *list,
* get_all_desktop_entries_for_mime_type:
* @mime_type: a mime type.
*
- * Returns all the desktop filenames for @mime_type. The desktop files
+ * Returns all the desktop ids for @mime_type. The desktop files
* are listed in an order so that default applications are listed before
* non-default ones, and handlers for inherited mimetypes are listed
* after the base ones.
*
- * Return value: a #GList containing the desktop filenames containing the
- * @mime_type.
+ * Return value: a #GList containing the desktop ids which claim
+ * to handle @mime_type.
*/
static GList *
get_all_desktop_entries_for_mime_type (const char *base_mime_type)
diff -up glib-2.15.0/gio/gappinfo.c.desktopfiles glib-2.15.0/gio/gappinfo.c
--- glib-2.15.0/gio/gappinfo.c.desktopfiles 2007-12-20 10:20:45.000000000 -0500
+++ glib-2.15.0/gio/gappinfo.c 2007-12-22 13:38:09.000000000 -0500
@@ -139,6 +139,9 @@ g_app_info_equal (GAppInfo *appinfo1,
* platform dependent. For instance on Unix this is the
* desktop file id from the xdg menu specification.
*
+ * Note that the returned ID may be %NULL, depending on how
+ * the @appinfo has been constructed.
+ *
* Returns: a string containing the application's ID.
**/
const char *
@@ -180,8 +183,7 @@ g_app_info_get_name (GAppInfo *appinfo)
* Gets a human-readable description of an installed application.
*
* Returns: a string containing a description of the
- * application @appinfo, or %NULL if none. The returned string should be not freed
- * when no longer needed.
+ * application @appinfo, or %NULL if none.
**/
const char *
g_app_info_get_description (GAppInfo *appinfo)

View File

@ -1,35 +0,0 @@
--- glib-2.11.1/Makefile.in.libdir 2006-05-15 12:23:18.000000000 -0400
+++ glib-2.11.1/Makefile.in 2006-05-25 15:03:13.000000000 -0400
@@ -287,13 +287,13 @@
gtk-doc.make
-configexecincludedir = $(libdir)/glib-2.0/include
+configexecincludedir = $(prefix)$(libdir)/glib-2.0/include
CONFIGURE_DEPENDENCIES = acglib.m4
BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)$(libdir)/pkgconfig
pkgconfig_DATA = glib-2.0.pc gobject-2.0.pc gmodule-2.0.pc gmodule-export-2.0.pc gmodule-no-export-2.0.pc gthread-2.0.pc
# install mkinstalldirs for glib-gettextize's benefit
--- glib-2.11.1/glib-2.0.pc.in.libdir 2006-05-25 15:04:08.000000000 -0400
+++ glib-2.11.1/glib-2.0.pc.in 2006-05-25 15:06:06.000000000 -0400
@@ -2,6 +2,7 @@
exec_prefix=@exec_prefix@
libdir=@libdir@
includedir=@includedir@
+configexecincludedir=@prefix@@libdir@/glib-2.0/include
glib_genmarshal=glib-genmarshal
gobject_query=gobject-query
@@ -11,5 +12,5 @@
Description: C Utility Library
Version: @VERSION@
Libs: -L${libdir} -lglib-2.0 @INTLLIBS@ @ICONV_LIBS@
-Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include
+Cflags: -I${includedir}/glib-2.0 -I${configexecincludedir}

View File

@ -1,37 +0,0 @@
--- glib-2.15.0/glib/gtestutils.h.jj 2007-12-21 05:53:51.000000000 +0100
+++ glib-2.15.0/glib/gtestutils.h 2007-12-21 11:50:46.000000000 +0100
@@ -22,7 +22,7 @@
#include <glib.h>
-G_BEGIN_DECLS;
+G_BEGIN_DECLS
typedef struct GTestCase GTestCase;
typedef struct GTestSuite GTestSuite;
@@ -118,7 +118,7 @@ void g_test_queue_destroy
typedef enum {
G_TEST_TRAP_SILENCE_STDOUT = 1 << 7,
G_TEST_TRAP_SILENCE_STDERR = 1 << 8,
- G_TEST_TRAP_INHERIT_STDIN = 1 << 9,
+ G_TEST_TRAP_INHERIT_STDIN = 1 << 9
} GTestTrapFlags;
gboolean g_test_trap_fork (guint64 usec_timeout,
GTestTrapFlags test_trap_flags);
@@ -215,7 +215,7 @@ typedef enum {
G_TEST_LOG_STOP_CASE, // d:status d:nforks d:elapsed
G_TEST_LOG_MIN_RESULT, // s:blurb d:result
G_TEST_LOG_MAX_RESULT, // s:blurb d:result
- G_TEST_LOG_MESSAGE, // s:blurb
+ G_TEST_LOG_MESSAGE // s:blurb
} GTestLogType;
typedef struct {
@@ -240,6 +240,6 @@ void g_test_log_buffer_push
GTestLogMsg* g_test_log_buffer_pop (GTestLogBuffer *tbuffer);
void g_test_log_msg_free (GTestLogMsg *tmsg);
-G_END_DECLS;
+G_END_DECLS
#endif /* __G_TEST_UTILS_H__ */

View File

@ -2,8 +2,8 @@
Summary: A library of handy utility functions Summary: A library of handy utility functions
Name: glib2 Name: glib2
Version: 2.15.0 Version: 2.15.1
Release: 4%{?dist} Release: 1%{?dist}
License: LGPLv2+ License: LGPLv2+
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.gtk.org URL: http://www.gtk.org
@ -14,9 +14,11 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: pkgconfig >= 1:0.14 BuildRequires: pkgconfig >= 1:0.14
BuildRequires: gamin-devel BuildRequires: gamin-devel
BuildRequires: gettext BuildRequires: gettext
BuildRequires: libattr-devel
BuildRequires: libselinux-devel
# for sys/inotify.h
BuildRequires: glibc-devel
Patch0: glib-2.15.0-gtestutils.patch
Patch1: desktopfiles.patch
%description %description
GLib is the low-level core library that forms the basis GLib is the low-level core library that forms the basis
@ -49,13 +51,8 @@ of version 2 of the GLib library.
%prep %prep
%setup -q -n glib-%{version} %setup -q -n glib-%{version}
%patch0 -p1 -b .gtestutils.patch
%patch1 -p1 -b .desktopfiles
%build %build
for i in config.guess config.sub ; do
test -f /usr/share/libtool/$i && cp /usr/share/libtool/$i .
done
%configure --disable-gtk-doc --enable-static %configure --disable-gtk-doc --enable-static
make %{?_smp_mflags} make %{?_smp_mflags}
@ -126,6 +123,8 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/lib*.a %{_libdir}/lib*.a
%changelog %changelog
* Tue Jan 8 2007 Matthias Clasen <mclasen@redhat.com> - 2.15.1-1
-
* Sat Dec 22 2007 Matthias Clasen <mclasen@redhat.com> - 2.15.0-4 * Sat Dec 22 2007 Matthias Clasen <mclasen@redhat.com> - 2.15.0-4
- Another attempt - Another attempt

View File

@ -1,38 +0,0 @@
diff -up glib-2.13.7/glib/gthread.c.ppc-cast glib-2.13.7/glib/gthread.c
--- glib-2.13.7/glib/gthread.c.ppc-cast 2007-07-12 21:43:31.000000000 -0400
+++ glib-2.13.7/glib/gthread.c 2007-07-12 21:43:45.000000000 -0400
@@ -223,11 +223,11 @@ void
g_once_init_leave (volatile gsize *value_location,
gsize initialization_value)
{
- g_return_if_fail (g_atomic_pointer_get (value_location) == 0);
+ g_return_if_fail (g_atomic_pointer_get ((gpointer*) value_location) == 0);
g_return_if_fail (initialization_value != 0);
g_return_if_fail (g_once_init_list != NULL);
- g_atomic_pointer_set (value_location, initialization_value);
+ g_atomic_pointer_set ((gpointer*) value_location, (gpointer) initialization_value);
g_mutex_lock (g_once_mutex);
g_once_init_list = g_slist_remove (g_once_init_list, (gpointer*) value_location);
g_cond_broadcast (g_once_cond);
@@ -255,7 +255,7 @@ g_static_mutex_get_mutex_impl (GMutex**
g_mutex_lock (g_once_mutex);
if (!(*mutex))
- g_atomic_pointer_set (mutex, g_mutex_new());
+ g_atomic_pointer_set ((gpointer*) mutex, g_mutex_new());
g_mutex_unlock (g_once_mutex);
diff -up glib-2.13.7/glib/gthread.h.ppc-cast glib-2.13.7/glib/gthread.h
--- glib-2.13.7/glib/gthread.h.ppc-cast 2007-07-12 21:43:27.000000000 -0400
+++ glib-2.13.7/glib/gthread.h 2007-07-12 21:43:43.000000000 -0400
@@ -332,7 +332,7 @@ void g_once_init_leav
G_INLINE_FUNC gboolean
g_once_init_enter (volatile gsize *value_location)
{
- if G_LIKELY (g_atomic_pointer_get (value_location) !=0)
+ if G_LIKELY (g_atomic_pointer_get ((gpointer*) value_location) !=0)
return FALSE;
else
return g_once_init_enter_impl (value_location);

View File

@ -1 +1 @@
52536475a3f301842cf3448f19af094c glib-2.15.0.tar.bz2 b3a2ca18e618927d03d39000f2155958 glib-2.15.1.tar.bz2