Update to 2.68.4
Resolves: #1996969 (cherry picked from Fedora commit 9815d53431c8ab46eae232a705c7ab0214b34159)
This commit is contained in:
parent
0e96582cd3
commit
89f56b1d19
29
2180.patch
29
2180.patch
@ -1,29 +0,0 @@
|
||||
From 891319de22c1b173afab8adaf20a01df68f11d61 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Thu, 8 Jul 2021 17:26:43 -0700
|
||||
Subject: [PATCH] correctly use 3 parameters for close_range
|
||||
|
||||
libc implementation has 3 parameter e.g.
|
||||
https://www.freebsd.org/cgi/man.cgi?query=close_range&sektion=2&format=html
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
glib/gspawn.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/glib/gspawn.c b/glib/gspawn.c
|
||||
index 95f5b868e..a15fb1ca1 100644
|
||||
--- a/glib/gspawn.c
|
||||
+++ b/glib/gspawn.c
|
||||
@@ -1494,7 +1494,7 @@ safe_closefrom (int lowfd)
|
||||
*
|
||||
* Handle ENOSYS in case it’s supported in libc but not the kernel; if so,
|
||||
* fall back to safe_fdwalk(). */
|
||||
- if (close_range (lowfd, G_MAXUINT) != 0 && errno == ENOSYS)
|
||||
+ if (close_range (lowfd, G_MAXUINT, 0) != 0 && errno == ENOSYS)
|
||||
#endif /* HAVE_CLOSE_RANGE */
|
||||
(void) safe_fdwalk (close_func, GINT_TO_POINTER (lowfd));
|
||||
#endif
|
||||
--
|
||||
2.31.1
|
||||
|
10
glib2.spec
10
glib2.spec
@ -1,6 +1,6 @@
|
||||
Name: glib2
|
||||
Version: 2.68.3
|
||||
Release: 6%{?dist}
|
||||
Version: 2.68.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A library of handy utility functions
|
||||
|
||||
License: LGPLv2+
|
||||
@ -17,9 +17,6 @@ Patch0: gnutls-hmac.patch
|
||||
# Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596
|
||||
Patch1: 1596.patch
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2180
|
||||
Patch2: 2180.patch
|
||||
|
||||
# Add GPowerProfileMonitor
|
||||
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1965
|
||||
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2194
|
||||
@ -247,6 +244,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
%{_datadir}/installed-tests
|
||||
|
||||
%changelog
|
||||
* Sat Aug 21 2021 Kalev Lember <klember@redhat.com> - 2.68.4-1
|
||||
- Update to 2.68.4
|
||||
|
||||
* Wed Aug 18 2021 DJ Delorie <dj@redhat.com> - 2.68.3-6
|
||||
- Rebuilt for libffi 3.4.2 SONAME transition.
|
||||
Related: rhbz#1891914
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glib-2.68.3.tar.xz) = fb120105c4cb582491a53a0e4c61fe4bdd1f94b279bb7c362afd591369ede50a196c706375564ededf3550d4062a285b038e20b605e6d5dfe36f5d208f4bad3f
|
||||
SHA512 (glib-2.68.4.tar.xz) = be17d79b41d17fd2b144184d6e793180667b7d9ba299215ea6d4948b4c05f6d888b4868c48643e25935a34ee2f85ee1d03e53325151b7a61819437cbd3c84b10
|
||||
|
Loading…
Reference in New Issue
Block a user