parent
8b0678d3f0
commit
7aafbaff5d
29
close-range-ftbfs.patch
Normal file
29
close-range-ftbfs.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From b71117d89434db83d34bc1b981ca03d4be299576 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Thu, 8 Jul 2021 17:26:43 -0700
|
||||
Subject: [PATCH] correctly use 3 parameters for close_range
|
||||
|
||||
libc implementation has 3 parameter e.g.
|
||||
https://www.freebsd.org/cgi/man.cgi?query=close_range&sektion=2&format=html
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
---
|
||||
glib/gspawn.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/glib/gspawn.c b/glib/gspawn.c
|
||||
index 899647c2f..3073a10a4 100644
|
||||
--- a/glib/gspawn.c
|
||||
+++ b/glib/gspawn.c
|
||||
@@ -1520,7 +1520,7 @@ safe_closefrom (int lowfd)
|
||||
*
|
||||
* Handle ENOSYS in case it’s supported in libc but not the kernel; if so,
|
||||
* fall back to safe_fdwalk(). */
|
||||
- if (close_range (lowfd, G_MAXUINT) != 0 && errno == ENOSYS)
|
||||
+ if (close_range (lowfd, G_MAXUINT, 0) != 0 && errno == ENOSYS)
|
||||
#endif /* HAVE_CLOSE_RANGE */
|
||||
(void) safe_fdwalk (close_func, GINT_TO_POINTER (lowfd));
|
||||
#endif
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,11 +1,11 @@
|
||||
Name: glib2
|
||||
Version: 2.68.3
|
||||
Version: 2.69.0
|
||||
Release: %autorelease
|
||||
Summary: A library of handy utility functions
|
||||
|
||||
License: LGPLv2+
|
||||
URL: http://www.gtk.org
|
||||
Source0: http://download.gnome.org/sources/glib/2.68/glib-%{version}.tar.xz
|
||||
URL: https://www.gtk.org
|
||||
Source0: https://download.gnome.org/sources/glib/2.69/glib-%{version}.tar.xz
|
||||
|
||||
# Required for RHEL core crypto components policy. Good for Fedora too.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1630260
|
||||
@ -17,6 +17,9 @@ Patch0: gnutls-hmac.patch
|
||||
# Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596
|
||||
Patch1: gdesktopappinfo.patch
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2180
|
||||
Patch2: close-range-ftbfs.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
|
@ -1,4 +1,4 @@
|
||||
From ff90bb8474b1e724727f4014b446e7c851e609bd Mon Sep 17 00:00:00 2001
|
||||
From 561b594fe58c3ea1c6387c64c59f4816c1fd1c38 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Fri, 7 Jun 2019 18:44:43 +0000
|
||||
Subject: [PATCH 1/4] ghmac: Split off wrapper functions into ghmac-utils.c
|
||||
@ -284,10 +284,10 @@ index 49fd272f0..4f181f21f 100644
|
||||
- (const guchar *) str, length);
|
||||
-}
|
||||
diff --git a/glib/meson.build b/glib/meson.build
|
||||
index 8c18e6de4..329b8d197 100644
|
||||
index 93600b29e..cce338969 100644
|
||||
--- a/glib/meson.build
|
||||
+++ b/glib/meson.build
|
||||
@@ -253,6 +253,7 @@ glib_sources = files(
|
||||
@@ -251,6 +251,7 @@ glib_sources = files(
|
||||
'ggettext.c',
|
||||
'ghash.c',
|
||||
'ghmac.c',
|
||||
@ -298,7 +298,7 @@ index 8c18e6de4..329b8d197 100644
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From 5395d36e6685e0b7377794c59c5820970bb472ef Mon Sep 17 00:00:00 2001
|
||||
From b87b28e06c6300479e292782100e9b94ebb6a140 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Fri, 7 Jun 2019 19:36:54 +0000
|
||||
Subject: [PATCH 2/4] Add a gnutls backend for GHmac
|
||||
@ -659,10 +659,10 @@ index 4f181f21f..0e39ea40a 100644
|
||||
* Use g_hmac_unref() to free the memory allocated by it.
|
||||
*
|
||||
diff --git a/glib/meson.build b/glib/meson.build
|
||||
index 329b8d197..2417de53d 100644
|
||||
index cce338969..1f6bb35d1 100644
|
||||
--- a/glib/meson.build
|
||||
+++ b/glib/meson.build
|
||||
@@ -252,7 +252,6 @@ glib_sources = files(
|
||||
@@ -250,7 +250,6 @@ glib_sources = files(
|
||||
'gfileutils.c',
|
||||
'ggettext.c',
|
||||
'ghash.c',
|
||||
@ -670,7 +670,7 @@ index 329b8d197..2417de53d 100644
|
||||
'ghmac-utils.c',
|
||||
'ghook.c',
|
||||
'ghostutils.c',
|
||||
@@ -308,6 +307,7 @@ glib_sources = files(
|
||||
@@ -306,6 +305,7 @@ glib_sources = files(
|
||||
'guriprivate.h',
|
||||
'gutils.c',
|
||||
'gutilsprivate.h',
|
||||
@ -678,7 +678,7 @@ index 329b8d197..2417de53d 100644
|
||||
'guuid.c',
|
||||
'gvariant.c',
|
||||
'gvariant-core.c',
|
||||
@@ -352,6 +352,12 @@ else
|
||||
@@ -350,6 +350,12 @@ else
|
||||
glib_dtrace_hdr = []
|
||||
endif
|
||||
|
||||
@ -691,20 +691,20 @@ index 329b8d197..2417de53d 100644
|
||||
pcre_static_args = []
|
||||
|
||||
if use_pcre_static_flag
|
||||
@@ -378,7 +384,7 @@ libglib = library('glib-2.0',
|
||||
@@ -368,7 +374,7 @@ libglib = library('glib-2.0',
|
||||
# intl.lib is not compatible with SAFESEH
|
||||
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
|
||||
include_directories : configinc,
|
||||
- dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
+ dependencies : pcre_deps + [thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
- dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
+ dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
c_args : glib_c_args,
|
||||
objc_args : glib_c_args,
|
||||
)
|
||||
diff --git a/meson.build b/meson.build
|
||||
index e2eba1871..cca15f653 100644
|
||||
index 1b54fdcae..98f8925a2 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -2090,6 +2090,13 @@ if host_system == 'linux'
|
||||
@@ -2095,6 +2095,13 @@ if host_system == 'linux'
|
||||
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
|
||||
endif
|
||||
|
||||
@ -719,12 +719,12 @@ index e2eba1871..cca15f653 100644
|
||||
winsock2 = cc.find_library('ws2_32')
|
||||
endif
|
||||
diff --git a/meson_options.txt b/meson_options.txt
|
||||
index 072765361..c8f26ac02 100644
|
||||
index 6cd7bc90a..65af1d276 100644
|
||||
--- a/meson_options.txt
|
||||
+++ b/meson_options.txt
|
||||
@@ -39,6 +39,11 @@ option('internal_pcre',
|
||||
value : false,
|
||||
description : 'whether to use internal PCRE')
|
||||
@@ -34,6 +34,11 @@ option('libmount',
|
||||
value : 'auto',
|
||||
description : 'build with libmount support')
|
||||
|
||||
+option('gnutls',
|
||||
+ type : 'boolean',
|
||||
@ -734,10 +734,17 @@ index 072765361..c8f26ac02 100644
|
||||
option('man',
|
||||
type : 'boolean',
|
||||
value : false,
|
||||
@@ -121,4 +126,4 @@ option('glib_checks',
|
||||
option('libelf',
|
||||
type : 'feature',
|
||||
value : 'auto',
|
||||
- description : 'Enable support for listing and extracting from ELF resource files with gresource tool')
|
||||
\ No newline at end of file
|
||||
+ description : 'Enable support for listing and extracting from ELF resource files with gresource tool')
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From 61c175277acb8d1e080305acd444201c5ad1fb81 Mon Sep 17 00:00:00 2001
|
||||
From 379e559f5aa390272368f83ca3e6af092066ae75 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
||||
Date: Wed, 16 Jun 2021 20:35:00 -0500
|
||||
Subject: [PATCH 3/4] dlopen GnuTLS instead of linking directly
|
||||
@ -919,23 +926,23 @@ index 0e39ea40a..2d9be91b8 100644
|
||||
#endif
|
||||
|
||||
diff --git a/glib/meson.build b/glib/meson.build
|
||||
index 2417de53d..ba42951aa 100644
|
||||
index 1f6bb35d1..f4041e50c 100644
|
||||
--- a/glib/meson.build
|
||||
+++ b/glib/meson.build
|
||||
@@ -384,7 +384,7 @@ libglib = library('glib-2.0',
|
||||
@@ -374,7 +374,7 @@ libglib = library('glib-2.0',
|
||||
# intl.lib is not compatible with SAFESEH
|
||||
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
|
||||
include_directories : configinc,
|
||||
- dependencies : pcre_deps + [thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
+ dependencies : pcre_deps + [thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + [libdl_dep],
|
||||
- dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
|
||||
+ dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + [libdl_dep],
|
||||
c_args : glib_c_args,
|
||||
objc_args : glib_c_args,
|
||||
)
|
||||
diff --git a/meson.build b/meson.build
|
||||
index cca15f653..404ef1790 100644
|
||||
index 98f8925a2..bbe26e4e4 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -2090,11 +2090,9 @@ if host_system == 'linux'
|
||||
@@ -2095,11 +2095,9 @@ if host_system == 'linux'
|
||||
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
|
||||
endif
|
||||
|
||||
@ -952,7 +959,7 @@ index cca15f653..404ef1790 100644
|
||||
--
|
||||
2.31.1
|
||||
|
||||
From 7d1d96311b6ecd4f90ebbdd6fc58d28e06a86887 Mon Sep 17 00:00:00 2001
|
||||
From 54e7d0982c73692e92ddd8eaa328f2fbedf05688 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
||||
Date: Wed, 16 Jun 2021 20:46:24 -0500
|
||||
Subject: [PATCH 4/4] Add test for GHmac in FIPS mode
|
||||
@ -1084,3 +1091,4 @@ index 3ac3206df..2fa447984 100644
|
||||
}
|
||||
--
|
||||
2.31.1
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (glib-2.68.3.tar.xz) = fb120105c4cb582491a53a0e4c61fe4bdd1f94b279bb7c362afd591369ede50a196c706375564ededf3550d4062a285b038e20b605e6d5dfe36f5d208f4bad3f
|
||||
SHA512 (glib-2.69.0.tar.xz) = 1de7517c2dfde724a45507383c909bdaa5d2c2452449b7e091057fb8bbf1ea10dcd7fbb6c7e67735287551bd13e2bbfee910ed848a1a53209a13b43eb7046480
|
||||
|
Loading…
Reference in New Issue
Block a user