Update to 2.53.5
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
7601a56f32
commit
78ad5e06b9
@ -1,52 +0,0 @@
|
|||||||
From 039c40e6ec96020e568fb6c1e45dc48f3c4fa6de Mon Sep 17 00:00:00 2001
|
|
||||||
From: Emmanuele Bassi <ebassi@gnome.org>
|
|
||||||
Date: Fri, 21 Jul 2017 15:33:37 +0100
|
|
||||||
Subject: [PATCH] =?UTF-8?q?Revert=20"GKeyFile=20=E2=80=93=20Add=20array=20?=
|
|
||||||
=?UTF-8?q?length=20annotations=20to=20to=5Fdata(),=20get=5Fkeys()=20and?=
|
|
||||||
=?UTF-8?q?=20get=5Fgroups()"?=
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
This reverts commit fd329f4853f180eb92746f39fc96fd5d91394009.
|
|
||||||
|
|
||||||
The commit changed the Introspection ABI, and it requires a change in
|
|
||||||
any application using an introspection-based language binding.
|
|
||||||
---
|
|
||||||
glib/gkeyfile.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/glib/gkeyfile.c b/glib/gkeyfile.c
|
|
||||||
index 4ac7c087a..9831fbe6c 100644
|
|
||||||
--- a/glib/gkeyfile.c
|
|
||||||
+++ b/glib/gkeyfile.c
|
|
||||||
@@ -1489,7 +1489,7 @@ g_key_file_flush_parse_buffer (GKeyFile *key_file,
|
|
||||||
* Note that this function never reports an error,
|
|
||||||
* so it is safe to pass %NULL as @error.
|
|
||||||
*
|
|
||||||
- * Returns: (array length=length): a newly allocated string holding
|
|
||||||
+ * Returns: a newly allocated string holding
|
|
||||||
* the contents of the #GKeyFile
|
|
||||||
*
|
|
||||||
* Since: 2.6
|
|
||||||
@@ -1559,7 +1559,7 @@ g_key_file_to_data (GKeyFile *key_file,
|
|
||||||
* be found, %NULL is returned and @error is set to
|
|
||||||
* #G_KEY_FILE_ERROR_GROUP_NOT_FOUND.
|
|
||||||
*
|
|
||||||
- * Returns: (array zero-terminated=1 length=length) (transfer full): a newly-allocated %NULL-terminated array of strings.
|
|
||||||
+ * Returns: (array zero-terminated=1) (transfer full): a newly-allocated %NULL-terminated array of strings.
|
|
||||||
* Use g_strfreev() to free it.
|
|
||||||
*
|
|
||||||
* Since: 2.6
|
|
||||||
@@ -1654,7 +1654,7 @@ g_key_file_get_start_group (GKeyFile *key_file)
|
|
||||||
* The array of returned groups will be %NULL-terminated, so
|
|
||||||
* @length may optionally be %NULL.
|
|
||||||
*
|
|
||||||
- * Returns: (array zero-terminated=1 length=length) (transfer full): a newly-allocated %NULL-terminated array of strings.
|
|
||||||
+ * Returns: (array zero-terminated=1) (transfer full): a newly-allocated %NULL-terminated array of strings.
|
|
||||||
* Use g_strfreev() to free it.
|
|
||||||
* Since: 2.6
|
|
||||||
**/
|
|
||||||
--
|
|
||||||
2.13.0
|
|
||||||
|
|
@ -1,62 +0,0 @@
|
|||||||
From ca69df0f16fd0bda99baf609a8ce9f38e1039f65 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Emmanuele Bassi <ebassi@gnome.org>
|
|
||||||
Date: Tue, 1 Aug 2017 10:11:09 +0100
|
|
||||||
Subject: [PATCH 1/2] Revert "glib-mkenums: fix parsing of /*< flags >*/
|
|
||||||
annotation"
|
|
||||||
|
|
||||||
This reverts commit 1672678bc48c1c060d1ee6bb3df124b3e4f9ca33.
|
|
||||||
|
|
||||||
A more comprehensive fix will follow.
|
|
||||||
---
|
|
||||||
gobject/glib-mkenums.in | 10 +++++-----
|
|
||||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gobject/glib-mkenums.in b/gobject/glib-mkenums.in
|
|
||||||
index 9fae3a8a9..a82a374cf 100755
|
|
||||||
--- a/gobject/glib-mkenums.in
|
|
||||||
+++ b/gobject/glib-mkenums.in
|
|
||||||
@@ -83,7 +83,7 @@ def write_output(output):
|
|
||||||
|
|
||||||
# glib-mkenums.py
|
|
||||||
# Information about the current enumeration
|
|
||||||
-flags = False # Is enumeration a bitmask?
|
|
||||||
+flags = None # Is enumeration a bitmask?
|
|
||||||
option_underscore_name = '' # Overriden underscore variant of the enum name
|
|
||||||
# for example to fix the cases we don't get the
|
|
||||||
# mixed-case -> underscorized transform right.
|
|
||||||
@@ -196,7 +196,7 @@ def parse_entries(file, file_name):
|
|
||||||
value = groups[1]
|
|
||||||
if len(groups) > 2:
|
|
||||||
options = groups[2]
|
|
||||||
- if not flags and value is not None and '<<' in value:
|
|
||||||
+ if flags is None and value is not None and '<<' in value:
|
|
||||||
seenbitshift = 1
|
|
||||||
|
|
||||||
if options is not None:
|
|
||||||
@@ -449,12 +449,12 @@ def process_file(curfilename):
|
|
||||||
if 'skip' in options:
|
|
||||||
continue
|
|
||||||
enum_prefix = options.get('prefix', None)
|
|
||||||
- flags = 'flags' in options
|
|
||||||
+ flags = options.get('flags', None)
|
|
||||||
option_lowercase_name = options.get('lowercase_name', None)
|
|
||||||
option_underscore_name = options.get('underscore_name', None)
|
|
||||||
else:
|
|
||||||
enum_prefix = None
|
|
||||||
- flags = False
|
|
||||||
+ flags = None
|
|
||||||
option_lowercase_name = None
|
|
||||||
option_underscore_name = None
|
|
||||||
|
|
||||||
@@ -479,7 +479,7 @@ def process_file(curfilename):
|
|
||||||
parse_entries(curfile, curfilename)
|
|
||||||
|
|
||||||
# figure out if this was a flags or enums enumeration
|
|
||||||
- if not flags:
|
|
||||||
+ if flags is None:
|
|
||||||
flags = seenbitshift
|
|
||||||
|
|
||||||
# Autogenerate a prefix
|
|
||||||
--
|
|
||||||
2.13.0
|
|
||||||
|
|
@ -1,29 +0,0 @@
|
|||||||
From 8cc99502022944917f5dd78ce1d1427582081396 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Alberts=20Muktup=C4=81vels?= <alberts.muktupavels@gmail.com>
|
|
||||||
Date: Tue, 1 Aug 2017 12:18:42 +0300
|
|
||||||
Subject: [PATCH 2/2] glib-mkenums: fix parsing of flags annotation
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=779332
|
|
||||||
---
|
|
||||||
gobject/glib-mkenums.in | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/gobject/glib-mkenums.in b/gobject/glib-mkenums.in
|
|
||||||
index a82a374cf..d4bfd11c3 100755
|
|
||||||
--- a/gobject/glib-mkenums.in
|
|
||||||
+++ b/gobject/glib-mkenums.in
|
|
||||||
@@ -450,6 +450,11 @@ def process_file(curfilename):
|
|
||||||
continue
|
|
||||||
enum_prefix = options.get('prefix', None)
|
|
||||||
flags = options.get('flags', None)
|
|
||||||
+ if 'flags' in options:
|
|
||||||
+ if flags is None:
|
|
||||||
+ flags = 1
|
|
||||||
+ else:
|
|
||||||
+ flags = int(flags)
|
|
||||||
option_lowercase_name = options.get('lowercase_name', None)
|
|
||||||
option_underscore_name = options.get('underscore_name', None)
|
|
||||||
else:
|
|
||||||
--
|
|
||||||
2.13.0
|
|
||||||
|
|
19
glib2.spec
19
glib2.spec
@ -4,22 +4,17 @@
|
|||||||
%global __python %{__python3}
|
%global __python %{__python3}
|
||||||
|
|
||||||
Name: glib2
|
Name: glib2
|
||||||
Version: 2.53.4
|
Version: 2.53.5
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A library of handy utility functions
|
Summary: A library of handy utility functions
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
Source0: http://download.gnome.org/sources/glib/2.53/glib-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/glib/2.53/glib-%{version}.tar.xz
|
||||||
|
|
||||||
# Backported from upstream
|
|
||||||
Patch0: 0001-Revert-GKeyFile-Add-array-length-annotations-to-to_d.patch
|
|
||||||
Patch1: 0001-Revert-glib-mkenums-fix-parsing-of-flags-annotation.patch
|
|
||||||
Patch2: 0002-glib-mkenums-fix-parsing-of-flags-annotation.patch
|
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-interpreter
|
||||||
# for sys/inotify.h
|
# for sys/inotify.h
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libattr-devel
|
BuildRequires: libattr-devel
|
||||||
@ -85,10 +80,7 @@ The glib2-tests package contains tests that can be used to verify
|
|||||||
the functionality of the installed glib2 package.
|
the functionality of the installed glib2 package.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n glib-%{version}
|
%autosetup -n glib-%{version} -p1
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Bug 1324770: Also explicitly remove PCRE sources since we use --with-pcre=system
|
# Bug 1324770: Also explicitly remove PCRE sources since we use --with-pcre=system
|
||||||
@ -239,6 +231,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.53.5-1
|
||||||
|
- Update to 2.53.5
|
||||||
|
|
||||||
* Tue Aug 01 2017 Kalev Lember <klember@redhat.com> - 2.53.4-4
|
* Tue Aug 01 2017 Kalev Lember <klember@redhat.com> - 2.53.4-4
|
||||||
- Backport glib-mkenums flags annotation parsing fixes
|
- Backport glib-mkenums flags annotation parsing fixes
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glib-2.53.4.tar.xz) = c11ac1efde612f6cfa91048b67dcd12d4669e63b6b4eefd8287f2024d33b2a6ba582d6b4c21b2195184bf5b887e4dd5bb5048a2e6b25eb2b07fc5654b585a801
|
SHA512 (glib-2.53.5.tar.xz) = 6d327146dcca9abd059ffbc57e453de474c34ac7cf565020c87d09c09e7b94f886eeb109a4a83496cd956f193746865afea99314353f12f4275fb724cdd9c612
|
||||||
|
Loading…
Reference in New Issue
Block a user