Update to 2.41.5
This commit is contained in:
parent
2c8f4e7a31
commit
7173be9291
@ -1,33 +0,0 @@
|
|||||||
From 450fea253095c7dd8a6293af8f86ea9b81ad46b2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ryan Lortie <desrt@desrt.ca>
|
|
||||||
Date: Thu, 4 Sep 2014 13:17:27 -0400
|
|
||||||
Subject: [PATCH] GDesktopAppInfo: fix default app logic
|
|
||||||
|
|
||||||
We use "tweaks" structures to track how a particular directory impacts
|
|
||||||
the list of added, removed and default applications. We maintain this
|
|
||||||
set of tweaks for each directory, in a hash table, keyed by unaliased
|
|
||||||
mime type name, in order to facilitate fast lookups.
|
|
||||||
|
|
||||||
A typo in the logic for creating and maintaining the uniqueness of these
|
|
||||||
structures was causing the default app to be selected incorrectly from
|
|
||||||
time to time. Fix that.
|
|
||||||
---
|
|
||||||
gio/gdesktopappinfo.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
|
|
||||||
index 1d38d4a..ddec690 100644
|
|
||||||
--- a/gio/gdesktopappinfo.c
|
|
||||||
+++ b/gio/gdesktopappinfo.c
|
|
||||||
@@ -641,7 +641,7 @@ desktop_file_dir_unindexed_get_tweaks (DesktopFileDir *dir,
|
|
||||||
gchar *unaliased_type;
|
|
||||||
|
|
||||||
unaliased_type = _g_unix_content_type_unalias (mime_type);
|
|
||||||
- tweaks = g_hash_table_lookup (dir->mime_tweaks, mime_type);
|
|
||||||
+ tweaks = g_hash_table_lookup (dir->mime_tweaks, unaliased_type);
|
|
||||||
|
|
||||||
if (tweaks == NULL)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
10
glib2.spec
10
glib2.spec
@ -2,8 +2,8 @@
|
|||||||
|
|
||||||
Summary: A library of handy utility functions
|
Summary: A library of handy utility functions
|
||||||
Name: glib2
|
Name: glib2
|
||||||
Version: 2.41.4
|
Version: 2.41.5
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
@ -30,8 +30,6 @@ BuildRequires: chrpath
|
|||||||
# required for GIO content-type support
|
# required for GIO content-type support
|
||||||
Requires: shared-mime-info
|
Requires: shared-mime-info
|
||||||
|
|
||||||
Patch0: broken-default-apps.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GLib is the low-level core library that forms the basis for projects
|
GLib is the low-level core library that forms the basis for projects
|
||||||
such as GTK+ and GNOME. It provides data structure handling for C,
|
such as GTK+ and GNOME. It provides data structure handling for C,
|
||||||
@ -83,7 +81,6 @@ the functionality of the installed glib2 package.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n glib-%{version}
|
%setup -q -n glib-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Support builds of both git snapshots and tarballs packed with autogoo
|
# Support builds of both git snapshots and tarballs packed with autogoo
|
||||||
@ -221,6 +218,9 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 2.41.5-1
|
||||||
|
- Update to 2.41.5
|
||||||
|
|
||||||
* Thu Sep 4 2014 Matthias Clasen <mclasen@redhat.com> 2.41.4-3
|
* Thu Sep 4 2014 Matthias Clasen <mclasen@redhat.com> 2.41.4-3
|
||||||
- Don't remove rpath from gdbus-peer test - it doesn't work without it
|
- Don't remove rpath from gdbus-peer test - it doesn't work without it
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user