Update to 2.57.1
This commit is contained in:
parent
38b0fc282d
commit
61bd4d25e7
@ -1,13 +0,0 @@
|
|||||||
diff --git a/gio/gdbus-2.0/codegen/codegen_main.py b/gio/gdbus-2.0/codegen/codegen_main.py
|
|
||||||
index 9d9099f..1cfe7c1 100755
|
|
||||||
--- a/gio/gdbus-2.0/codegen/codegen_main.py
|
|
||||||
+++ b/gio/gdbus-2.0/codegen/codegen_main.py
|
|
||||||
@@ -209,7 +209,7 @@ def codegen_main():
|
|
||||||
print_error('Using --body requires --output')
|
|
||||||
|
|
||||||
c_file = args.output
|
|
||||||
- header_name = os.path.splitext(c_file)[0] + '.h'
|
|
||||||
+ header_name = os.path.splitext(os.path.basename(c_file))[0] + '.h'
|
|
||||||
|
|
||||||
all_ifaces = []
|
|
||||||
for fname in args.files + args.xml_files:
|
|
15
glib2.spec
15
glib2.spec
@ -4,22 +4,18 @@
|
|||||||
%global __python %{__python3}
|
%global __python %{__python3}
|
||||||
|
|
||||||
Name: glib2
|
Name: glib2
|
||||||
Version: 2.56.1
|
Version: 2.57.1
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A library of handy utility functions
|
Summary: A library of handy utility functions
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.gtk.org
|
URL: http://www.gtk.org
|
||||||
Source0: http://download.gnome.org/sources/glib/2.56/glib-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/glib/2.57/glib-%{version}.tar.xz
|
||||||
|
|
||||||
# Include upstream patch to fix gdbus-codegen when used with meson 0.46
|
|
||||||
# https://gitlab.gnome.org/GNOME/glib/commit/cd1f82d8fc741a2203582c12cc21b4dacf7e1872
|
|
||||||
Patch0: glib2-fix-gdbus-codegen.patch
|
|
||||||
|
|
||||||
# https://gitlab.gnome.org/GNOME/glib/merge_requests/90
|
# https://gitlab.gnome.org/GNOME/glib/merge_requests/90
|
||||||
# https://gitlab.gnome.org/GNOME/glib/merge_requests/102
|
# https://gitlab.gnome.org/GNOME/glib/merge_requests/102
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1584916
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1584916
|
||||||
Patch1: glib2-gfdonotificationbackend-fix-possible-invalid-pointer.patch
|
Patch0: glib2-gfdonotificationbackend-fix-possible-invalid-pointer.patch
|
||||||
|
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -224,6 +220,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/installed-tests
|
%{_datadir}/installed-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 20 2018 Ondrej Holy <oholy@redhat.com> - 2.57.1-1
|
||||||
|
- Update to 2.57.1
|
||||||
|
|
||||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.56.1-6
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.56.1-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (glib-2.56.1.tar.xz) = 7e96cc23f3fa42a41b1974ae8fa2a7b123449643f265763d464620afcb011668e2de013ed2a6e5f13b6bd1bf3ab8eab43c05bf4a8ee0d99b7808767ab4fa69f4
|
SHA512 (glib-2.57.1.tar.xz) = fad52b079731338d2a573c460750cdbc757e249f5276f57a4cb5e1833e65e3fc353da78c3253db820a69af2e1444f6d32874d862580e199570a64965401388b1
|
||||||
|
Loading…
Reference in New Issue
Block a user