Update to 2.71.0

This commit is contained in:
David King 2022-01-08 23:44:43 +00:00
parent df270abbbe
commit 55d1b00f41
4 changed files with 32 additions and 1085 deletions

View File

@ -1,5 +1,5 @@
Name: glib2
Version: 2.70.2
Version: 2.71.0
Release: %autorelease
Summary: A library of handy utility functions
@ -17,10 +17,6 @@ Patch0: gnutls-hmac.patch
# Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596
Patch1: gdesktopappinfo.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1910092
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1968
Patch2: gspawn.patch
BuildRequires: chrpath
BuildRequires: gcc
BuildRequires: gcc-c++

View File

@ -1,4 +1,4 @@
From 561b594fe58c3ea1c6387c64c59f4816c1fd1c38 Mon Sep 17 00:00:00 2001
From ef7a063ee6f5bd8642fd04b717e7d075b9f33ec0 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 18:44:43 +0000
Subject: [PATCH 1/4] ghmac: Split off wrapper functions into ghmac-utils.c
@ -164,10 +164,10 @@ index 000000000..a17359ff1
+ (const guchar *) str, length);
+}
diff --git a/glib/ghmac.c b/glib/ghmac.c
index 49fd272f0..4f181f21f 100644
index 54da9f936..8358897b0 100644
--- a/glib/ghmac.c
+++ b/glib/ghmac.c
@@ -329,115 +329,3 @@ g_hmac_get_digest (GHmac *hmac,
@@ -327,115 +327,3 @@ g_hmac_get_digest (GHmac *hmac,
g_checksum_update (hmac->digesto, buffer, len);
g_checksum_get_digest (hmac->digesto, buffer, digest_len);
}
@ -284,10 +284,10 @@ index 49fd272f0..4f181f21f 100644
- (const guchar *) str, length);
-}
diff --git a/glib/meson.build b/glib/meson.build
index 93600b29e..cce338969 100644
index 025e448ad..a672857b4 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -251,6 +251,7 @@ glib_sources = files(
@@ -244,6 +244,7 @@ glib_sources = files(
'ggettext.c',
'ghash.c',
'ghmac.c',
@ -296,9 +296,10 @@ index 93600b29e..cce338969 100644
'ghostutils.c',
'giochannel.c',
--
2.31.1
2.34.1
From b87b28e06c6300479e292782100e9b94ebb6a140 Mon Sep 17 00:00:00 2001
From bf0e7adb2e60f02fc2fb9c25f773379c1c3a3ec7 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 19:36:54 +0000
Subject: [PATCH 2/4] Add a gnutls backend for GHmac
@ -626,7 +627,7 @@ index 000000000..9fb775f89
+ *digest_len = g_checksum_type_get_length (hmac->digest_type);
+}
diff --git a/glib/ghmac.c b/glib/ghmac.c
index 4f181f21f..0e39ea40a 100644
index 8358897b0..ba0d2d55c 100644
--- a/glib/ghmac.c
+++ b/glib/ghmac.c
@@ -33,6 +33,9 @@
@ -659,10 +660,10 @@ index 4f181f21f..0e39ea40a 100644
* Use g_hmac_unref() to free the memory allocated by it.
*
diff --git a/glib/meson.build b/glib/meson.build
index cce338969..1f6bb35d1 100644
index a672857b4..2c43ac0d4 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -250,7 +250,6 @@ glib_sources = files(
@@ -243,7 +243,6 @@ glib_sources = files(
'gfileutils.c',
'ggettext.c',
'ghash.c',
@ -670,7 +671,7 @@ index cce338969..1f6bb35d1 100644
'ghmac-utils.c',
'ghook.c',
'ghostutils.c',
@@ -306,6 +305,7 @@ glib_sources = files(
@@ -299,6 +298,7 @@ glib_sources = files(
'guriprivate.h',
'gutils.c',
'gutilsprivate.h',
@ -678,7 +679,7 @@ index cce338969..1f6bb35d1 100644
'guuid.c',
'gvariant.c',
'gvariant-core.c',
@@ -350,6 +350,12 @@ else
@@ -352,6 +352,12 @@ else
glib_dtrace_hdr = []
endif
@ -691,20 +692,20 @@ index cce338969..1f6bb35d1 100644
pcre_static_args = []
if use_pcre_static_flag
@@ -368,7 +374,7 @@ libglib = library('glib-2.0',
# intl.lib is not compatible with SAFESEH
@@ -370,7 +376,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc,
link_with: [charset_lib, gnulib_lib],
- dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
c_args : glib_c_args,
objc_args : glib_c_args,
)
diff --git a/meson.build b/meson.build
index 1b54fdcae..98f8925a2 100644
index 6e566d483..268f02b6f 100644
--- a/meson.build
+++ b/meson.build
@@ -2095,6 +2095,13 @@ if host_system == 'linux'
@@ -2103,6 +2103,13 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif
@ -742,9 +743,10 @@ index 6cd7bc90a..65af1d276 100644
\ No newline at end of file
+ description : 'Enable support for listing and extracting from ELF resource files with gresource tool')
--
2.31.1
2.34.1
From 379e559f5aa390272368f83ca3e6af092066ae75 Mon Sep 17 00:00:00 2001
From 2fd58b32475d9f708a600cac16de7a159cfd11d5 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:35:00 -0500
Subject: [PATCH 3/4] dlopen GnuTLS instead of linking directly
@ -913,7 +915,7 @@ index 9fb775f89..1800fc2e0 100644
hmac->digest_type = digest_type;
diff --git a/glib/ghmac.c b/glib/ghmac.c
index 0e39ea40a..2d9be91b8 100644
index ba0d2d55c..913bf3864 100644
--- a/glib/ghmac.c
+++ b/glib/ghmac.c
@@ -33,7 +33,7 @@
@ -926,23 +928,23 @@ index 0e39ea40a..2d9be91b8 100644
#endif
diff --git a/glib/meson.build b/glib/meson.build
index 1f6bb35d1..f4041e50c 100644
index 2c43ac0d4..6b6f692d9 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -374,7 +374,7 @@ libglib = library('glib-2.0',
# intl.lib is not compatible with SAFESEH
@@ -376,7 +376,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc,
link_with: [charset_lib, gnulib_lib],
- dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + [libdl_dep],
c_args : glib_c_args,
objc_args : glib_c_args,
)
diff --git a/meson.build b/meson.build
index 98f8925a2..bbe26e4e4 100644
index 268f02b6f..e24d68f74 100644
--- a/meson.build
+++ b/meson.build
@@ -2095,11 +2095,9 @@ if host_system == 'linux'
@@ -2103,11 +2103,9 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif
@ -957,9 +959,10 @@ index 98f8925a2..bbe26e4e4 100644
if host_system == 'windows'
--
2.31.1
2.34.1
From 54e7d0982c73692e92ddd8eaa328f2fbedf05688 Mon Sep 17 00:00:00 2001
From c79f7b8560f8e7449eff3956bae2ab93cd11b018 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:46:24 -0500
Subject: [PATCH 4/4] Add test for GHmac in FIPS mode
@ -1090,5 +1093,5 @@ index 3ac3206df..2fa447984 100644
return g_test_run ();
}
--
2.31.1
2.34.1

File diff suppressed because it is too large Load Diff

View File

@ -1 +1 @@
SHA512 (glib-2.70.2.tar.xz) = 872e3f06f87f21a32446b41aac7454fd6bf4d665c753121f6e9772cddebc592b79d88713fc6b8d510636af9f9c4528a9d508d8c4225c6dfeb928390120fb4809
SHA512 (glib-2.71.0.tar.xz) = 833ac450d046e7293a2cabe3157ca393ca0aeac007163384e1705f1860933ae5f1cd1f7f733fd4732c3eaaaa42a941a1c486432c3768ce15238acb37bc2649d6