Update to 2.73.2

- Rebase gnutls-hmac.patch
- Rebase gdesktopappinfo.patch
- Drop 2784.patch as it's been fixed upstream
- Build with pcre2 instead of pcre
This commit is contained in:
Kalev Lember 2022-07-14 15:11:18 +02:00
parent 5cfc8d9d4f
commit 34b203d549
5 changed files with 71 additions and 130 deletions

View File

@ -1,63 +0,0 @@
From d4043eced5c7f21b1a4942b305f9ded127cbdb83 Mon Sep 17 00:00:00 2001
From: Simon McVittie <smcv@debian.org>
Date: Sun, 26 Jun 2022 12:04:32 +0100
Subject: [PATCH] Revert "gobject: Use g_datalist_id_remove_multiple"
This reverts commit fa8c7c0 "gobject: Use g_datalist_id_remove_multiple"
(or more specifically the parts of it that were not already reverted
in 01ac1d9 "gobject: Fix crash when disposing a GtkAccelGroup".
Workaround for https://gitlab.gnome.org/GNOME/glib/-/issues/2676
Bug: https://gitlab.gnome.org/GNOME/glib/-/issues/2676
---
gobject/gobject.c | 24 ++++++------------------
1 file changed, 6 insertions(+), 18 deletions(-)
diff --git a/gobject/gobject.c b/gobject/gobject.c
index 5ba8fd017b..1c6bfedfae 100644
--- a/gobject/gobject.c
+++ b/gobject/gobject.c
@@ -1353,17 +1353,10 @@ g_object_do_get_property (GObject *object,
static void
g_object_real_dispose (GObject *object)
{
- GQuark keys[3] = {
- quark_closure_array,
- quark_weak_refs,
- quark_weak_locations,
- };
-
g_signal_handlers_destroy (object);
- /* FIXME: This should be simplified down to a single remove_multiple() call.
- * See https://gitlab.gnome.org/GNOME/glib/-/issues/2672 */
- g_datalist_id_remove_multiple (&object->qdata, keys, 1);
- g_datalist_id_remove_multiple (&object->qdata, keys + 1, 2);
+ g_datalist_id_set_data (&object->qdata, quark_closure_array, NULL);
+ g_datalist_id_set_data (&object->qdata, quark_weak_refs, NULL);
+ g_datalist_id_set_data (&object->qdata, quark_weak_locations, NULL);
}
#ifdef G_ENABLE_DEBUG
@@ -3888,15 +3881,10 @@ g_object_unref (gpointer _object)
}
/* we are still in the process of taking away the last ref */
+ g_datalist_id_set_data (&object->qdata, quark_closure_array, NULL);
g_signal_handlers_destroy (object);
- {
- GQuark keys[3] = {
- quark_closure_array,
- quark_weak_refs,
- quark_weak_locations,
- };
- g_datalist_id_remove_multiple (&object->qdata, keys, G_N_ELEMENTS (keys));
- }
+ g_datalist_id_set_data (&object->qdata, quark_weak_refs, NULL);
+ g_datalist_id_set_data (&object->qdata, quark_weak_locations, NULL);
/* decrement the last reference */
old_ref = g_atomic_int_add (&object->ref_count, -1);
--
GitLab

View File

@ -1,4 +1,4 @@
From 5e42384cc4499293259a8a37a737014a56de34df Mon Sep 17 00:00:00 2001
From 19f690a7aa6a942b804a7e13aedff38066cb0a8b Mon Sep 17 00:00:00 2001
From: Benjamin Berg <bberg@redhat.com>
Date: Fri, 23 Oct 2020 18:20:01 +0200
Subject: [PATCH 1/4] tests: Iterate mainloop during launch test
@ -14,10 +14,10 @@ session bus.
1 file changed, 1 insertion(+)
diff --git a/gio/tests/desktop-app-info.c b/gio/tests/desktop-app-info.c
index fcc29c579..743230cbb 100644
index 6d3f4e853..9d3166075 100644
--- a/gio/tests/desktop-app-info.c
+++ b/gio/tests/desktop-app-info.c
@@ -334,6 +334,7 @@ wait_for_file (const gchar *want_this,
@@ -532,6 +532,7 @@ wait_for_file (const gchar *want_this,
*/
while (access (want_this, F_OK) != 0)
{
@ -26,9 +26,10 @@ index fcc29c579..743230cbb 100644
g_assert_cmpuint (retries, >, 0);
retries--;
--
2.31.1
2.36.1
From ba3b85a8fea0151e74de50e841a7f16f9b077a56 Mon Sep 17 00:00:00 2001
From 517d565fd1b0b0ac6a1b480153ee1440dd37974c Mon Sep 17 00:00:00 2001
From: Benjamin Berg <bberg@redhat.com>
Date: Mon, 27 Jul 2020 22:22:32 +0200
Subject: [PATCH 2/4] gdesktopappinfo: Move launched applications into
@ -59,10 +60,10 @@ DBus call finishes.
1 file changed, 227 insertions(+), 37 deletions(-)
diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
index 1a4b97918..afdcd42ac 100644
index c0950ae75..570e49e57 100644
--- a/gio/gdesktopappinfo.c
+++ b/gio/gdesktopappinfo.c
@@ -2730,6 +2730,148 @@ notify_desktop_launch (GDBusConnection *session_bus,
@@ -2827,6 +2827,148 @@ emit_launch_started (GAppLaunchContext *context,
#define _SPAWN_FLAGS_DEFAULT (G_SPAWN_SEARCH_PATH)
@ -211,7 +212,7 @@ index 1a4b97918..afdcd42ac 100644
static gboolean
g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
GDBusConnection *session_bus,
@@ -2750,13 +2892,14 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2847,13 +2989,14 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
GList *old_uris;
GList *dup_uris;
@ -229,7 +230,7 @@ index 1a4b97918..afdcd42ac 100644
if (launch_context)
envp = g_app_launch_context_get_environment (launch_context);
else
@@ -2770,27 +2913,19 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2867,27 +3010,19 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
do
{
GPid pid;
@ -263,7 +264,7 @@ index 1a4b97918..afdcd42ac 100644
for (iter = old_uris; iter != NULL && iter != dup_uris; iter = iter->next)
launched_uris = g_list_prepend (launched_uris, iter->data);
launched_uris = g_list_reverse (launched_uris);
@@ -2799,7 +2934,7 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2896,7 +3031,7 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
{
g_set_error_literal (error, G_IO_ERROR, G_IO_ERROR_FAILED,
_("Unable to find terminal required for application"));
@ -272,7 +273,7 @@ index 1a4b97918..afdcd42ac 100644
}
if (info->filename)
@@ -2808,7 +2943,6 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2905,7 +3040,6 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
info->filename,
TRUE);
@ -280,7 +281,7 @@ index 1a4b97918..afdcd42ac 100644
if (launch_context)
{
GList *launched_files = create_files_for_uris (launched_uris);
@@ -2837,38 +2971,93 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2936,38 +3070,93 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
* with a wrapper program (grep the GLib git history for
* `gio-launch-desktop` for an example of this which could be
* resurrected). */
@ -386,7 +387,7 @@ index 1a4b97918..afdcd42ac 100644
if (pid_callback != NULL)
pid_callback (info, pid, pid_callback_data);
@@ -2893,19 +3082,20 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2992,19 +3181,20 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
sn_id,
launched_uris);
@ -414,9 +415,10 @@ index 1a4b97918..afdcd42ac 100644
return completed;
}
--
2.31.1
2.36.1
From cd67a1b0256d2397dac0836e154f3449b63a6b19 Mon Sep 17 00:00:00 2001
From 17d4021c1f38ae35f3eda0f0b44085e4bca97a58 Mon Sep 17 00:00:00 2001
From: Benjamin Berg <bberg@redhat.com>
Date: Tue, 28 Jul 2020 12:11:13 +0200
Subject: [PATCH 3/4] gdesktopappinfo: Handle task completion from spawn
@ -429,14 +431,14 @@ This fixes the behaviour of the previous commit which would not
correctly move the process into the scope if the application exited
right after the task returned.
---
gio/gdesktopappinfo.c | 212 +++++++++++++++++++++++++++++-------------
1 file changed, 146 insertions(+), 66 deletions(-)
gio/gdesktopappinfo.c | 217 ++++++++++++++++++++++++++++--------------
1 file changed, 146 insertions(+), 71 deletions(-)
diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
index afdcd42ac..8d0f1688e 100644
index 570e49e57..62c93e671 100644
--- a/gio/gdesktopappinfo.c
+++ b/gio/gdesktopappinfo.c
@@ -2849,11 +2849,17 @@ create_systemd_scope (GDBusConnection *session_bus,
@@ -2946,11 +2946,17 @@ create_systemd_scope (GDBusConnection *session_bus,
g_free (unit_name);
}
@ -454,7 +456,7 @@ index afdcd42ac..8d0f1688e 100644
GVariant *res = NULL;
GError *error = NULL;
@@ -2865,13 +2871,47 @@ systemd_scope_created_cb (GObject *object,
@@ -2962,13 +2968,47 @@ systemd_scope_created_cb (GObject *object,
}
/* Unblock the waiting wrapper binary. */
@ -503,7 +505,7 @@ index afdcd42ac..8d0f1688e 100644
static gboolean
g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
GDBusConnection *session_bus,
@@ -2886,9 +2926,10 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2983,9 +3023,10 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
gint stdin_fd,
gint stdout_fd,
gint stderr_fd,
@ -516,7 +518,7 @@ index afdcd42ac..8d0f1688e 100644
GList *old_uris;
GList *dup_uris;
@@ -2898,8 +2939,15 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -2995,8 +3036,15 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
char *sn_id = NULL;
int argc;
@ -532,7 +534,7 @@ index afdcd42ac..8d0f1688e 100644
if (launch_context)
envp = g_app_launch_context_get_environment (launch_context);
else
@@ -2922,8 +2970,8 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3019,8 +3067,8 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
gpointer setup_data = user_setup_data;
old_uris = dup_uris;
@ -543,7 +545,7 @@ index afdcd42ac..8d0f1688e 100644
/* Get the subset of URIs we're launching with this process */
for (iter = old_uris; iter != NULL && iter != dup_uris; iter = iter->next)
@@ -2932,9 +2980,9 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3029,9 +3077,9 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
if (info->terminal && !prepend_terminal_to_vector (&argc, &argv))
{
@ -556,7 +558,7 @@ index afdcd42ac..8d0f1688e 100644
}
if (info->filename)
@@ -2991,9 +3039,9 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3090,9 +3138,9 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
* otherwise our wrapper script will close both sides. */
if (!g_unix_open_pipe (wrapper_data.pipe, 0, NULL))
{
@ -569,7 +571,7 @@ index afdcd42ac..8d0f1688e 100644
}
/* Set CLOEXEC on the write pipe, so we don't need to deal with it in the child. */
@@ -3030,7 +3078,7 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3129,7 +3177,7 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
stdin_fd,
stdout_fd,
stderr_fd,
@ -578,7 +580,7 @@ index afdcd42ac..8d0f1688e 100644
{
#if defined(__linux__) && !defined(__BIONIC__)
close (wrapper_data.pipe[0]);
@@ -3049,11 +3097,29 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3148,11 +3196,29 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
close (wrapper_data.pipe[0]);
if (session_bus)
@ -613,7 +615,7 @@ index afdcd42ac..8d0f1688e 100644
else
close (wrapper_data.pipe[1]);
#endif
@@ -3088,8 +3154,6 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
@@ -3187,8 +3253,6 @@ g_desktop_app_info_launch_uris_with_spawn (GDesktopAppInfo *info,
}
while (dup_uris != NULL);
@ -622,7 +624,7 @@ index afdcd42ac..8d0f1688e 100644
out:
g_strfreev (argv);
g_strfreev (envp);
@@ -3097,7 +3161,52 @@ out:
@@ -3196,7 +3260,52 @@ out:
g_list_free (launched_uris);
g_free (sn_id);
@ -676,7 +678,7 @@ index afdcd42ac..8d0f1688e 100644
}
static gchar *
@@ -3246,17 +3355,9 @@ g_desktop_app_info_launch_uris_internal (GAppInfo *appinfo,
@@ -3421,17 +3530,9 @@ g_desktop_app_info_launch_uris_internal (GAppInfo *appinfo,
success = g_desktop_app_info_launch_uris_with_spawn (info, session_bus, info->exec, uris, launch_context,
spawn_flags, user_setup, user_setup_data,
pid_callback, pid_callback_data,
@ -696,7 +698,7 @@ index afdcd42ac..8d0f1688e 100644
return success;
}
@@ -3310,18 +3411,6 @@ launch_uris_with_dbus_cb (GObject *object,
@@ -3485,18 +3586,6 @@ launch_uris_with_dbus_cb (GObject *object,
g_object_unref (task);
}
@ -715,7 +717,7 @@ index afdcd42ac..8d0f1688e 100644
static void
launch_uris_bus_get_cb (GObject *object,
GAsyncResult *result,
@@ -3330,12 +3419,20 @@ launch_uris_bus_get_cb (GObject *object,
@@ -3505,12 +3594,20 @@ launch_uris_bus_get_cb (GObject *object,
GTask *task = G_TASK (user_data);
GDesktopAppInfo *info = G_DESKTOP_APP_INFO (g_task_get_source_object (task));
LaunchUrisData *data = g_task_get_task_data (task);
@ -737,7 +739,7 @@ index afdcd42ac..8d0f1688e 100644
if (session_bus && info->app_id)
{
/* FIXME: The g_document_portal_add_documents() function, which is called
@@ -3343,34 +3440,21 @@ launch_uris_bus_get_cb (GObject *object,
@@ -3518,39 +3615,21 @@ launch_uris_bus_get_cb (GObject *object,
* uses blocking calls.
*/
g_desktop_app_info_launch_uris_with_dbus (info, session_bus,
@ -764,11 +766,16 @@ index afdcd42ac..8d0f1688e 100644
- g_task_return_error (task, g_steal_pointer (&error));
- g_object_unref (task);
- }
- else
- else if (session_bus)
- g_dbus_connection_flush (session_bus,
- cancellable,
- launch_uris_flush_cb,
- g_steal_pointer (&task));
- else
- {
- g_task_return_boolean (task, TRUE);
- g_clear_object (&task);
- }
+ g_steal_pointer (&task), NULL);
}
@ -776,7 +783,7 @@ index afdcd42ac..8d0f1688e 100644
g_clear_object (&session_bus);
}
@@ -5186,16 +5270,12 @@ g_desktop_app_info_launch_action (GDesktopAppInfo *info,
@@ -5368,16 +5447,12 @@ g_desktop_app_info_launch_action (GDesktopAppInfo *info,
if (exec_line)
g_desktop_app_info_launch_uris_with_spawn (info, session_bus, exec_line, NULL, launch_context,
_SPAWN_FLAGS_DEFAULT, NULL, NULL, NULL, NULL,
@ -796,9 +803,10 @@ index afdcd42ac..8d0f1688e 100644
/* Epilogue {{{1 */
--
2.31.1
2.36.1
From 8da8a3ef6df8af6de8bd388192bebe8b51b3e782 Mon Sep 17 00:00:00 2001
From 5ca7b700ab906a663220434659483c140f2d170a Mon Sep 17 00:00:00 2001
From: Benjamin Berg <bberg@redhat.com>
Date: Thu, 17 Sep 2020 17:35:58 +0200
Subject: [PATCH 4/4] gdesktopappinfo: Add SourcePath= to transient systemd
@ -814,10 +822,10 @@ See https://invent.kde.org/frameworks/kio/-/merge_requests/124
1 file changed, 13 insertions(+)
diff --git a/gio/gdesktopappinfo.c b/gio/gdesktopappinfo.c
index 8d0f1688e..a833de4e6 100644
index 62c93e671..1091d3859 100644
--- a/gio/gdesktopappinfo.c
+++ b/gio/gdesktopappinfo.c
@@ -2777,6 +2777,7 @@ create_systemd_scope (GDBusConnection *session_bus,
@@ -2874,6 +2874,7 @@ create_systemd_scope (GDBusConnection *session_bus,
{
GVariantBuilder builder;
const char *app_name = g_get_application_name ();
@ -825,7 +833,7 @@ index 8d0f1688e..a833de4e6 100644
char *appid = NULL;
char *appid_escaped = NULL;
char *snid_escaped = NULL;
@@ -2802,6 +2803,8 @@ create_systemd_scope (GDBusConnection *session_bus,
@@ -2899,6 +2900,8 @@ create_systemd_scope (GDBusConnection *session_bus,
*/
unit_name = g_strdup_printf ("app-glib-%s-%d.scope", appid_escaped, pid);
@ -834,7 +842,7 @@ index 8d0f1688e..a833de4e6 100644
g_variant_builder_init (&builder, G_VARIANT_TYPE ("(ssa(sv)a(sa(sv)))"));
g_variant_builder_add (&builder, "s", unit_name);
g_variant_builder_add (&builder, "s", "fail");
@@ -2815,6 +2818,16 @@ create_systemd_scope (GDBusConnection *session_bus,
@@ -2912,6 +2915,16 @@ create_systemd_scope (GDBusConnection *session_bus,
"Description",
g_variant_new_take_string (g_strdup_printf ("Application launched by %s",
app_name)));
@ -852,4 +860,5 @@ index 8d0f1688e..a833de4e6 100644
"(sv)",
"PIDs",
--
2.31.1
2.36.1

View File

@ -1,5 +1,5 @@
Name: glib2
Version: 2.73.1
Version: 2.73.2
Release: %autorelease
Summary: A library of handy utility functions
@ -17,11 +17,6 @@ Patch0: gnutls-hmac.patch
# Proposed upstream at https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1596
Patch1: gdesktopappinfo.patch
# Revert parts of a commit to avoid "weak_locations != NULL" crashes:
# https://gitlab.gnome.org/GNOME/glib/-/issues/2676
# https://gitlab.gnome.org/GNOME/glib/-/merge_requests/2784
Patch2: 2784.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: gettext
@ -36,7 +31,7 @@ BuildRequires: meson
BuildRequires: systemtap-sdt-devel
BuildRequires: pkgconfig(libelf)
BuildRequires: pkgconfig(libffi)
BuildRequires: pkgconfig(libpcre)
BuildRequires: pkgconfig(libpcre2-8)
BuildRequires: pkgconfig(mount)
BuildRequires: pkgconfig(sysprof-capture-4)
BuildRequires: pkgconfig(zlib)

View File

@ -1,4 +1,4 @@
From 26f1dfc846cc6c712fc34f039e75261f4a821c97 Mon Sep 17 00:00:00 2001
From 4fb2d2ba67cbf97a728ef5fe8b29e1f3df0a7f85 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 18:44:43 +0000
Subject: [PATCH 1/4] ghmac: Split off wrapper functions into ghmac-utils.c
@ -284,7 +284,7 @@ index 7ad28d6f0..516b01b24 100644
- (const guchar *) str, length);
-}
diff --git a/glib/meson.build b/glib/meson.build
index 4f8240b24..224d1b781 100644
index 6062c11a1..6624dab48 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -248,6 +248,7 @@ glib_sources = files(
@ -299,7 +299,7 @@ index 4f8240b24..224d1b781 100644
2.36.1
From 3f5a2aa275d779e832cddab6bdb391fed8e8d8ae Mon Sep 17 00:00:00 2001
From 9df3337f963e2317ae23e7fc8dabf536c218c629 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Fri, 7 Jun 2019 19:36:54 +0000
Subject: [PATCH 2/4] Add a gnutls backend for GHmac
@ -660,7 +660,7 @@ index 516b01b24..a4851cc64 100644
* Use g_hmac_unref() to free the memory allocated by it.
*
diff --git a/glib/meson.build b/glib/meson.build
index 224d1b781..9c9919d0a 100644
index 6624dab48..4e3365f61 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -247,7 +247,6 @@ glib_sources = files(
@ -689,23 +689,23 @@ index 224d1b781..9c9919d0a 100644
+ glib_sources += files('ghmac.c')
+endif
+
pcre_static_args = []
pcre2_static_args = []
if use_pcre_static_flag
if use_pcre2_static_flag
@@ -376,7 +382,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc,
link_with: [charset_lib, gnulib_lib],
- dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
- dependencies : [pcre2, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre2, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
c_args : glib_c_args,
objc_args : glib_c_args,
)
diff --git a/meson.build b/meson.build
index 1234ba064..5d2c5ce72 100644
index b3dea2ea1..464e59e09 100644
--- a/meson.build
+++ b/meson.build
@@ -2101,6 +2101,13 @@ if host_system == 'linux'
@@ -2113,6 +2113,13 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif
@ -739,7 +739,7 @@ index a52eed9d2..4eb577798 100644
2.36.1
From 31fce00ed870052205f7014ca594c751d87b1b0e Mon Sep 17 00:00:00 2001
From 019c4323d379c80344a0146e1fee2008fd6d3b51 Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:35:00 -0500
Subject: [PATCH 3/4] dlopen GnuTLS instead of linking directly
@ -921,23 +921,23 @@ index a4851cc64..20e64fd00 100644
#endif
diff --git a/glib/meson.build b/glib/meson.build
index 9c9919d0a..eefba8a0d 100644
index 4e3365f61..3b2a246c4 100644
--- a/glib/meson.build
+++ b/glib/meson.build
@@ -382,7 +382,7 @@ libglib = library('glib-2.0',
link_args : [noseh_link_args, glib_link_flags, win32_ldflags],
include_directories : configinc,
link_with: [charset_lib, gnulib_lib],
- dependencies : [pcre, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + [libdl_dep],
- dependencies : [pcre2, thread_dep, librt] + libgnutls_dep + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep],
+ dependencies : [pcre2, thread_dep, librt] + libintl_deps + libiconv + platform_deps + [gnulib_libm_dependency, libm] + [libsysprof_capture_dep] + [libdl_dep],
c_args : glib_c_args,
objc_args : glib_c_args,
)
diff --git a/meson.build b/meson.build
index 5d2c5ce72..27f30c4a8 100644
index 464e59e09..366c35fef 100644
--- a/meson.build
+++ b/meson.build
@@ -2101,11 +2101,9 @@ if host_system == 'linux'
@@ -2113,11 +2113,9 @@ if host_system == 'linux'
glib_conf.set('HAVE_LIBMOUNT', libmount_dep.found())
endif
@ -955,7 +955,7 @@ index 5d2c5ce72..27f30c4a8 100644
2.36.1
From 0d8f792d2f2b359d00f2465120cb7dc60db107a5 Mon Sep 17 00:00:00 2001
From 67f0f37e072b8629644efd4a657f73ce72da042b Mon Sep 17 00:00:00 2001
From: Michael Catanzaro <mcatanzaro@redhat.com>
Date: Wed, 16 Jun 2021 20:46:24 -0500
Subject: [PATCH 4/4] Add test for GHmac in FIPS mode

View File

@ -1 +1 @@
SHA512 (glib-2.73.1.tar.xz) = cb4bb51593c782534f8922d547d1fbb1800bfc51b01d96c42f335379d4ed22905804678d5bdb0c21ee61f0e20782f0013188c4d3f41e43e3f1ed3fb85e31d166
SHA512 (glib-2.73.2.tar.xz) = ae980c0aac89cde1298efeb0c174a122c23113e671405dc30c882b7237622c7c0f5cdf896852015b6f55ae09a756c293d7a57061a874014ac42c2d3e4450aab9