- glew 1.5.4 - add glew.pc
This commit is contained in:
parent
0849125820
commit
ef02c615c6
@ -1 +1 @@
|
||||
glew-1.5.2.tgz
|
||||
glew-1.5.4.tgz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
||||
--- glew-1.5.2/Makefile.jx 2010-02-09 13:33:15.000000000 -0500
|
||||
+++ glew-1.5.2/Makefile 2010-02-09 13:35:51.000000000 -0500
|
||||
diff -up glew-1.5.4/Makefile.add glew-1.5.4/Makefile
|
||||
--- glew-1.5.4/Makefile.add 2010-05-29 17:53:22.000000000 +1000
|
||||
+++ glew-1.5.4/Makefile 2010-05-29 17:53:27.000000000 +1000
|
||||
@@ -78,7 +78,7 @@ GLEWINFO.BIN.OBJS = $(GLEWINFO.BIN.SRCS:
|
||||
VISUALINFO.BIN = visualinfo$(BIN.SUFFIX)
|
||||
VISUALINFO.BIN.SRCS = src/visualinfo.c
|
||||
@ -8,5 +8,5 @@ diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
||||
-BIN.LIBS = -Llib $(LDFLAGS.DYNAMIC) -l$(NAME) $(LDFLAGS.EXTRA) $(LDFLAGS.GL)
|
||||
+BIN.LIBS = -Llib $(LDFLAGS.DYNAMIC) -l$(NAME) $(LDFLAGS.EXTRA) $(LDFLAGS.GL) -lX11
|
||||
|
||||
all debug: lib/$(LIB.SHARED) lib/$(LIB.STATIC) bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN)
|
||||
all debug: lib/$(LIB.SHARED) lib/$(LIB.STATIC) bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) glew.pc
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up glew-1.5.2/config/Makefile.linux.jx glew-1.5.2/config/Makefile.linux
|
||||
--- glew-1.5.2/config/Makefile.linux.jx 2009-12-31 12:06:19.000000000 -0500
|
||||
+++ glew-1.5.2/config/Makefile.linux 2010-02-02 10:16:40.000000000 -0500
|
||||
diff -up glew-1.5.4/config/Makefile.linux.make glew-1.5.4/config/Makefile.linux
|
||||
--- glew-1.5.4/config/Makefile.linux.make 2010-04-28 08:16:36.000000000 +1000
|
||||
+++ glew-1.5.4/config/Makefile.linux 2010-05-29 18:12:26.000000000 +1000
|
||||
@@ -7,14 +7,8 @@ endif
|
||||
PICFLAG = -fPIC
|
||||
LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
||||
@ -18,9 +18,9 @@ diff -up glew-1.5.2/config/Makefile.linux.jx glew-1.5.2/config/Makefile.linux
|
||||
LDFLAGS.STATIC = -Wl,-Bstatic
|
||||
LDFLAGS.DYNAMIC = -Wl,-Bdynamic
|
||||
NAME = GLEW
|
||||
diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
||||
--- glew-1.5.2/Makefile.jx 2009-12-31 12:06:19.000000000 -0500
|
||||
+++ glew-1.5.2/Makefile 2010-02-02 10:21:23.000000000 -0500
|
||||
diff -up glew-1.5.4/Makefile.make glew-1.5.4/Makefile
|
||||
--- glew-1.5.4/Makefile.make 2010-04-28 08:16:36.000000000 +1000
|
||||
+++ glew-1.5.4/Makefile 2010-05-29 18:19:11.000000000 +1000
|
||||
@@ -41,9 +41,9 @@ $(error "Platform '$(SYSTEM)' not suppor
|
||||
endif
|
||||
|
||||
@ -52,7 +52,14 @@ diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
||||
|
||||
%.o: %.c
|
||||
$(CC) -c $(CFLAGS) -o $@ $<
|
||||
@@ -122,7 +122,7 @@ ifeq ($(patsubst mingw%,mingw,$(SYSTEM))
|
||||
@@ -125,13 +125,14 @@ install: all
|
||||
$(INSTALL) -d -m 0755 $(BINDIR)
|
||||
$(INSTALL) -d -m 0755 $(INCDIR)
|
||||
$(INSTALL) -d -m 0755 $(LIBDIR)
|
||||
+ $(INSTALL) -d -m 0755 $(LIBDIR)/pkgconfig
|
||||
# runtime
|
||||
ifeq ($(patsubst mingw%,mingw,$(SYSTEM)), mingw)
|
||||
$(STRIP) -x lib/$(LIB.SHARED)
|
||||
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
|
||||
else
|
||||
$(STRIP) -x lib/$(LIB.SHARED)
|
||||
@ -61,7 +68,7 @@ diff -up glew-1.5.2/Makefile.jx glew-1.5.2/Makefile
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
|
||||
endif
|
||||
# development files
|
||||
@@ -137,7 +137,7 @@ else
|
||||
@@ -147,7 +148,7 @@ else
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
|
||||
endif
|
||||
# utilities
|
||||
|
12
glew.spec
12
glew.spec
@ -1,6 +1,6 @@
|
||||
Name: glew
|
||||
Version: 1.5.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.5.4
|
||||
Release: 1%{?dist}
|
||||
Summary: The OpenGL Extension Wrangler Library
|
||||
Group: System Environment/Libraries
|
||||
License: BSD and MIT
|
||||
@ -33,8 +33,8 @@ Development files for glew
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch0 -p1 -b .make
|
||||
%patch1 -p1 -b .add
|
||||
|
||||
sed -i -e 's/\r//g' config/config.guess
|
||||
|
||||
@ -68,10 +68,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/libGLEW.so
|
||||
%{_libdir}/pkgconfig/glew.pc
|
||||
%{_includedir}/GL/*.h
|
||||
%doc doc/*
|
||||
|
||||
%changelog
|
||||
* Sat May 29 2010 Dave Airlie <airlied@redhat.com> 1.5.4-1
|
||||
- glew 1.5.4 - add glew.pc
|
||||
|
||||
* Tue Feb 09 2010 Adam Jackson <ajax@redhat.com> 1.5.2-2
|
||||
- glew-1.5.2-add-needed.patch: Fix FTBFS from --no-add-needed
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user