glew 1.5.5
This commit is contained in:
parent
7d270f5a15
commit
a34623c0af
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
glew-1.5.4.tgz
|
||||
/glew-1.5.5.tgz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up glew-1.5.4/config/Makefile.linux.make glew-1.5.4/config/Makefile.linux
|
||||
--- glew-1.5.4/config/Makefile.linux.make 2010-04-28 08:16:36.000000000 +1000
|
||||
+++ glew-1.5.4/config/Makefile.linux 2010-05-29 18:12:26.000000000 +1000
|
||||
diff -up glew-1.5.5/config/Makefile.linux.make glew-1.5.5/config/Makefile.linux
|
||||
--- glew-1.5.5/config/Makefile.linux.make 2010-07-13 12:36:44.000000000 -0400
|
||||
+++ glew-1.5.5/config/Makefile.linux 2010-08-25 16:24:05.000000000 -0400
|
||||
@@ -7,14 +7,8 @@ endif
|
||||
PICFLAG = -fPIC
|
||||
LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
||||
@ -18,9 +18,9 @@ diff -up glew-1.5.4/config/Makefile.linux.make glew-1.5.4/config/Makefile.linux
|
||||
LDFLAGS.STATIC = -Wl,-Bstatic
|
||||
LDFLAGS.DYNAMIC = -Wl,-Bdynamic
|
||||
NAME = GLEW
|
||||
diff -up glew-1.5.4/Makefile.make glew-1.5.4/Makefile
|
||||
--- glew-1.5.4/Makefile.make 2010-04-28 08:16:36.000000000 +1000
|
||||
+++ glew-1.5.4/Makefile 2010-05-29 18:19:11.000000000 +1000
|
||||
diff -up glew-1.5.5/Makefile.make glew-1.5.5/Makefile
|
||||
--- glew-1.5.5/Makefile.make 2010-07-13 12:36:45.000000000 -0400
|
||||
+++ glew-1.5.5/Makefile 2010-08-25 16:25:27.000000000 -0400
|
||||
@@ -41,9 +41,9 @@ $(error "Platform '$(SYSTEM)' not suppor
|
||||
endif
|
||||
|
||||
@ -52,14 +52,7 @@ diff -up glew-1.5.4/Makefile.make glew-1.5.4/Makefile
|
||||
|
||||
%.o: %.c
|
||||
$(CC) -c $(CFLAGS) -o $@ $<
|
||||
@@ -125,13 +125,14 @@ install: all
|
||||
$(INSTALL) -d -m 0755 $(BINDIR)
|
||||
$(INSTALL) -d -m 0755 $(INCDIR)
|
||||
$(INSTALL) -d -m 0755 $(LIBDIR)
|
||||
+ $(INSTALL) -d -m 0755 $(LIBDIR)/pkgconfig
|
||||
# runtime
|
||||
ifeq ($(patsubst mingw%,mingw,$(SYSTEM)), mingw)
|
||||
$(STRIP) -x lib/$(LIB.SHARED)
|
||||
@@ -132,7 +132,7 @@ ifeq ($(patsubst mingw%,mingw,$(SYSTEM))
|
||||
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
|
||||
else
|
||||
$(STRIP) -x lib/$(LIB.SHARED)
|
||||
@ -68,7 +61,7 @@ diff -up glew-1.5.4/Makefile.make glew-1.5.4/Makefile
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
|
||||
endif
|
||||
# development files
|
||||
@@ -147,7 +148,7 @@ else
|
||||
@@ -148,7 +148,7 @@ else
|
||||
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
|
||||
endif
|
||||
# utilities
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: glew
|
||||
Version: 1.5.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.5.5
|
||||
Release: 1%{?dist}
|
||||
Summary: The OpenGL Extension Wrangler Library
|
||||
Group: System Environment/Libraries
|
||||
License: BSD and MIT
|
||||
@ -73,6 +73,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc doc/*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 25 2010 Adam Jackson <ajax@redhat.com> 1.5.5-1
|
||||
- glew 1.5.5
|
||||
|
||||
* Fri Jul 30 2010 Dave Airlie <airlied@redhat.com> 1.5.4-2
|
||||
- fix glew.pc file as pointed out by David Aguilar
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user