- Add missing GL_FLOAT_MATXxX defines
This commit is contained in:
parent
e0219dcac2
commit
9ce121dee7
16
glew-1.4.0-GL_FLOAT_MATXxX.patch
Normal file
16
glew-1.4.0-GL_FLOAT_MATXxX.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up glew/include/GL/glew.h~ glew/include/GL/glew.h
|
||||||
|
--- glew/include/GL/glew.h~ 2008-01-12 21:02:24.000000000 +0100
|
||||||
|
+++ glew/include/GL/glew.h 2008-01-12 21:02:24.000000000 +0100
|
||||||
|
@@ -2317,6 +2317,12 @@ typedef void (GLAPIENTRY * PFNGLVERTEXAT
|
||||||
|
#define GL_PIXEL_UNPACK_BUFFER 0x88EC
|
||||||
|
#define GL_PIXEL_PACK_BUFFER_BINDING 0x88ED
|
||||||
|
#define GL_PIXEL_UNPACK_BUFFER_BINDING 0x88EF
|
||||||
|
+#define GL_FLOAT_MAT2x3 0x8B65
|
||||||
|
+#define GL_FLOAT_MAT2x4 0x8B66
|
||||||
|
+#define GL_FLOAT_MAT3x2 0x8B67
|
||||||
|
+#define GL_FLOAT_MAT3x4 0x8B68
|
||||||
|
+#define GL_FLOAT_MAT4x2 0x8B69
|
||||||
|
+#define GL_FLOAT_MAT4x3 0x8B6A
|
||||||
|
#define GL_SRGB 0x8C40
|
||||||
|
#define GL_SRGB8 0x8C41
|
||||||
|
#define GL_SRGB_ALPHA 0x8C42
|
10
glew.spec
10
glew.spec
@ -1,6 +1,6 @@
|
|||||||
Name: glew
|
Name: glew
|
||||||
Version: 1.4.0
|
Version: 1.4.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: The OpenGL Extension Wrangler Library
|
Summary: The OpenGL Extension Wrangler Library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -21,6 +21,7 @@ Patch0: glew-1.3.6-pathandstrip.patch
|
|||||||
Patch1: glew-1.4.0-auto-make.patch
|
Patch1: glew-1.4.0-auto-make.patch
|
||||||
Patch2: glew-1.4.0-unused-direct-shlib-dependency.patch
|
Patch2: glew-1.4.0-unused-direct-shlib-dependency.patch
|
||||||
Patch3: glew-1.4.0-license-doc.patch
|
Patch3: glew-1.4.0-license-doc.patch
|
||||||
|
Patch4: glew-1.4.0-GL_FLOAT_MATXxX.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
|
|
||||||
@ -54,6 +55,10 @@ mkdir auto/registry
|
|||||||
touch auto/registry/.dummy auto/extensions/.dummy
|
touch auto/registry/.dummy auto/extensions/.dummy
|
||||||
make -C auto ../include/GL/glew.h
|
make -C auto ../include/GL/glew.h
|
||||||
make -C auto ../include/GL/glxew.h
|
make -C auto ../include/GL/glxew.h
|
||||||
|
# This is a patch to the autogenerated include/GL/glew.h file, so don't apply
|
||||||
|
# before that file is generated. I have no clue why these defines do not get
|
||||||
|
# properly added by the generation process, but they don't.
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -90,6 +95,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.0-4
|
||||||
|
- Add missing GL_FLOAT_MATXxX defines
|
||||||
|
|
||||||
* Sat Aug 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.0-3
|
* Sat Aug 18 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.0-3
|
||||||
- Fix multiple unused direct shlib dependencies in libGLEW.so
|
- Fix multiple unused direct shlib dependencies in libGLEW.so
|
||||||
- Remove the "SGI Free Software License B" and "GLX Public License" tekst from
|
- Remove the "SGI Free Software License B" and "GLX Public License" tekst from
|
||||||
|
Loading…
Reference in New Issue
Block a user