bump to 1.5.8
add soname.patch to fix the internal SONAME of the MX library
This commit is contained in:
parent
7069dc0374
commit
53c3e730bb
21
glew-1.5.8-soname.patch
Normal file
21
glew-1.5.8-soname.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- glew-1.5.8/Makefile 2011-03-23 15:07:32.456140865 -0700
|
||||||
|
+++ glew-1.5.8/Makefile.new 2011-03-23 15:08:29.169450772 -0700
|
||||||
|
@@ -131,7 +131,7 @@
|
||||||
|
$(AR) cr $@ $^
|
||||||
|
|
||||||
|
lib/$(LIB.SHARED.MX): $(LIB.SOBJS.MX)
|
||||||
|
- $(LD) $(LDFLAGS.SO) -o $@ $^ $(LIB.LDFLAGS) $(LIB.LIBS)
|
||||||
|
+ $(LD) $(LDFLAGS.SO.MX) -o $@ $^ $(LIB.LDFLAGS) $(LIB.LIBS)
|
||||||
|
ifeq ($(filter-out mingw% cygwin,$(SYSTEM)),)
|
||||||
|
else
|
||||||
|
$(LN) $(LIB.SHARED.MX) lib/$(LIB.SONAME.MX)
|
||||||
|
--- glew-1.5.8/config/Makefile.linux 2011-03-23 15:07:32.570143498 -0700
|
||||||
|
+++ glew-1.5.8/config/Makefile.linux.new 2011-03-23 15:08:09.650999994 -0700
|
||||||
|
@@ -3,6 +3,7 @@
|
||||||
|
LD = cc
|
||||||
|
PICFLAG = -fPIC
|
||||||
|
LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
|
||||||
|
+LDFLAGS.SO.MX = -shared -Wl,-soname=$(LIB.SONAME.MX)
|
||||||
|
M_ARCH ?= $(shell uname -m)
|
||||||
|
LIBDIR = $(GLEW_DEST)$(libdir)
|
||||||
|
LDFLAGS.GL = -lGL -lX11 -lGLU
|
13
glew.spec
13
glew.spec
@ -1,6 +1,6 @@
|
|||||||
Name: glew
|
Name: glew
|
||||||
Version: 1.5.7
|
Version: 1.5.8
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The OpenGL Extension Wrangler Library
|
Summary: The OpenGL Extension Wrangler Library
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD and MIT
|
License: BSD and MIT
|
||||||
@ -12,7 +12,9 @@ Patch1: glew-1.5.7-add-needed.patch
|
|||||||
# From upstream: build MX-enabled library, with a different soname
|
# From upstream: build MX-enabled library, with a different soname
|
||||||
# http://glew.git.sourceforge.net/git/gitweb.cgi?p=glew/glew;a=commitdiff;h=18455eb40fe2d71f5f78cce0bf44eb302c224016
|
# http://glew.git.sourceforge.net/git/gitweb.cgi?p=glew/glew;a=commitdiff;h=18455eb40fe2d71f5f78cce0bf44eb302c224016
|
||||||
# (rediffed for our makefile changes)
|
# (rediffed for our makefile changes)
|
||||||
Patch2: glew-1.5.7-glewmx.patch
|
Patch2: glew-1.5.8-glewmx.patch
|
||||||
|
# Fixes the soname of libGLEWmx, sent upstream
|
||||||
|
Patch3: glew-1.5.8-soname.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
|
|
||||||
@ -40,6 +42,7 @@ Development files for glew
|
|||||||
%patch0 -p1 -b .make
|
%patch0 -p1 -b .make
|
||||||
%patch1 -p1 -b .add
|
%patch1 -p1 -b .add
|
||||||
%patch2 -p1 -b .glewmx
|
%patch2 -p1 -b .glewmx
|
||||||
|
%patch3 -p1 -b .soname
|
||||||
|
|
||||||
sed -i -e 's/\r//g' config/config.guess
|
sed -i -e 's/\r//g' config/config.guess
|
||||||
|
|
||||||
@ -81,6 +84,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc doc/*
|
%doc doc/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 23 2011 Adam Williamson <awilliam@redhat.com> - 1.5.8-1
|
||||||
|
- bump to 1.5.8
|
||||||
|
- add soname.patch to fix the internal SONAME of the MX library
|
||||||
|
|
||||||
* Wed Mar 23 2011 Adam Williamson <awilliam@redhat.com> - 1.5.7-3
|
* Wed Mar 23 2011 Adam Williamson <awilliam@redhat.com> - 1.5.7-3
|
||||||
- add glewmx.patch (upstream commit 302c224016, always build the
|
- add glewmx.patch (upstream commit 302c224016, always build the
|
||||||
MX-enabled version of the library as well as non-MX version, under
|
MX-enabled version of the library as well as non-MX version, under
|
||||||
|
Loading…
Reference in New Issue
Block a user