- New upstream version, now SGI licensed stuff free out of the box!

- Unfortunately some of the included docs are under a non free license,
    therefor this package is based on a modified tarbal with these files
    removed
This commit is contained in:
Hans de Goede 2008-01-22 11:12:51 +00:00
parent 9ce121dee7
commit 1cd6f8000a
8 changed files with 44 additions and 130 deletions

View File

@ -1,2 +1 @@
glew-1.4.0-src-clean.tgz
glew-mesa-replacement-headers.tgz
glew-1.5.0-src-clean.tgz

View File

@ -1,16 +0,0 @@
The original version of GLEW contains files under 4 licenses:
BSD
GPLv2+
SGI Free Software License B
GLX Public License
The last 2 licenses are not Free software licenses and thus not acceptable for
Fedora. The version shipped by Fedora has the encumbered files removed and
replaced by files from Mesa. These replacement files are licensed under the
MIT license, which is BSD and GPL compatible.
Also note that the GPL licensed files are scripts which generate parts of the
C-code in GLEW, these scripts itself are only part of the GLEW sources shipped
by Fedora, not of the binary rpm. Thus the binary package is licensed under the
BSD license, and only under the BSD license. This is important for other
packages which use the GLEW library.

View File

@ -1,6 +1,7 @@
--- glew/Makefile.orig 2007-03-02 16:56:00.000000000 +0000
+++ glew/Makefile 2007-03-04 19:56:19.000000000 +0000
@@ -41,9 +41,9 @@
diff -up glew/Makefile.orig glew/Makefile
--- glew/Makefile.orig 2007-12-28 04:05:25.000000000 +0100
+++ glew/Makefile 2008-01-21 20:30:35.000000000 +0100
@@ -41,16 +41,16 @@ $(error "Platform '$(SYSTEM)' not suppor
endif
GLEW_DEST ?= /usr
@ -13,33 +14,32 @@
SHARED_OBJ_EXT ?= o
TARDIR = ../glew-$(GLEW_VERSION)
TARBALL = ../glew_$(GLEW_VERSION).tar.gz
@@ -57,7 +57,7 @@
STRIP =
AR = ar
INSTALL = install
-STRIP = strip
+STRIP = true
RM = rm -f
LN = ln -sf
ifeq ($(MAKECMDGOALS), debug)
@@ -117,7 +117,7 @@ ifeq ($(patsubst mingw%,mingw,$(SYSTEM))
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
else
OPT = $(POPT)
-STRIP = -s
+STRIP =
endif
INCLUDE = -Iinclude
CFLAGS = $(OPT) $(WARN) $(INCLUDE) $(CFLAGS.EXTRA)
@@ -121,7 +121,7 @@
$(INSTALL) -m 0644 lib/$(LIB.SHARED) $(LIBDIR)/
$(STRIP) -x lib/$(LIB.SHARED)
- $(INSTALL) -m 0644 lib/$(LIB.SHARED) $(LIBDIR)/
+ $(INSTALL) -m 0755 lib/$(LIB.SHARED) $(LIBDIR)/
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
else
- $(INSTALL) $(STRIP) -m 0644 lib/$(LIB.SHARED) $(LIBDIR)/
+ $(INSTALL) $(STRIP) -m 0755 lib/$(LIB.SHARED) $(LIBDIR)/
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
endif
endif
@@ -137,7 +137,7 @@
$(INSTALL) -m 0644 lib/$(LIB.STATIC) $(LIBDIR)/
# development files
@@ -132,7 +132,7 @@ else
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
else
- $(INSTALL) $(STRIP) -m 0644 lib/$(LIB.STATIC) $(LIBDIR)/
+ $(INSTALL) $(STRIP) -m 0755 lib/$(LIB.STATIC) $(LIBDIR)/
$(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
endif
endif
# utilities
- $(INSTALL) -s -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
+ $(INSTALL) -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
uninstall:
$(RM) $(INCDIR)/wglew.h
--- glew/config/Makefile.linux.orig 2007-03-01 06:49:21.000000000 +0000
+++ glew/config/Makefile.linux 2007-03-04 19:38:17.000000000 +0000
@@ -9,10 +9,10 @@

View File

@ -1,16 +0,0 @@
diff -up glew/include/GL/glew.h~ glew/include/GL/glew.h
--- glew/include/GL/glew.h~ 2008-01-12 21:02:24.000000000 +0100
+++ glew/include/GL/glew.h 2008-01-12 21:02:24.000000000 +0100
@@ -2317,6 +2317,12 @@ typedef void (GLAPIENTRY * PFNGLVERTEXAT
#define GL_PIXEL_UNPACK_BUFFER 0x88EC
#define GL_PIXEL_PACK_BUFFER_BINDING 0x88ED
#define GL_PIXEL_UNPACK_BUFFER_BINDING 0x88EF
+#define GL_FLOAT_MAT2x3 0x8B65
+#define GL_FLOAT_MAT2x4 0x8B66
+#define GL_FLOAT_MAT3x2 0x8B67
+#define GL_FLOAT_MAT3x4 0x8B68
+#define GL_FLOAT_MAT4x2 0x8B69
+#define GL_FLOAT_MAT4x3 0x8B6A
#define GL_SRGB 0x8C40
#define GL_SRGB8 0x8C41
#define GL_SRGB_ALPHA 0x8C42

View File

@ -1,19 +0,0 @@
diff -up glew/auto/Makefile~ glew/auto/Makefile
--- glew/auto/Makefile~ 2007-08-06 21:39:42.000000000 +0200
+++ glew/auto/Makefile 2007-08-06 21:39:42.000000000 +0200
@@ -105,7 +105,6 @@ $(I.DEST)/glew.h: $(EXT)/.dummy
@echo "--------------------------------------------------------------------"
test -d $(I.DEST) || mkdir -p $(I.DEST)
cp -f $(SRC)/glew_license.h $@
- cat $(SRC)/sgi_license.h >> $@
cat $(SRC)/glew_head.h >> $@
$(BIN)/make_header.pl GLAPIENTRY GL $(GL_CORE_SPEC) >> $@
$(BIN)/make_header.pl GLAPIENTRY GL $(GL_EXT_SPEC) >> $@
@@ -138,7 +137,6 @@ $(I.DEST)/glxew.h: $(EXT)/.dummy
@echo "Creating glxew.h"
@echo "--------------------------------------------------------------------"
cp -f $(SRC)/glew_license.h $@
- cat $(SRC)/glx_license.h >> $@
cat $(SRC)/glxew_head.h >> $@
$(BIN)/make_header.pl '' GLX $(GLX_CORE_SPEC) >> $@
$(BIN)/make_header.pl '' GLX $(GLX_EXT_SPEC) >> $@

View File

@ -1,19 +0,0 @@
diff -up glew/doc/credits.html~ glew/doc/credits.html
--- glew/doc/credits.html~ 2007-08-18 10:06:03.000000000 +0200
+++ glew/doc/credits.html 2007-08-18 10:06:03.000000000 +0200
@@ -88,10 +88,11 @@ which modifications were made by Michael
<p>
GLEW is originally derived from the <a
href="http://www.levp.de/3d/">EXTGL</a> project by Lev Povalahev. The
-source code is licensed under the modified BSD license, the <a
-href="sgi.txt">SGI Free Software License B</a>, and the <a
-href="glx.txt">GLX Public License</a>. The automatic code
-generation scripts are released under the <a href="gpl.txt">GPL</a>.
+source code is licensed under the modified BSD license, parts which were
+licensed under the non free SGI Free Software License B and GLX Public
+License have been <a href="../glew-1.4.0/LICENSE-README.fedora">replaced</a>
+by MIT licensed files from Mesa. The automatic code generation scripts are
+released under the <a href="gpl.txt">GPL</a>.
</p>
</td>

View File

@ -1,27 +1,20 @@
Name: glew
Version: 1.4.0
Release: 4%{?dist}
Version: 1.5.0
Release: 1%{?dist}
Summary: The OpenGL Extension Wrangler Library
Group: System Environment/Libraries
License: BSD
License: BSD and MIT
URL: http://glew.sourceforge.net
# This is http://downloads.sourceforge.net/glew/glew-%{version}-src.tgz
# With the following files removed because they are subject to the
# "SGI Free Software License B" resp "GLX Public License" :
# include/GL/glew.h include/GL/glxew.h auto/src/glew_head.h
# auto/src/glxew_head.h auto/src/sgi_license.h auto/src/glx_license.h
# doc/sgi.txt doc/glx.txt
# The files under the doc dir in this archive are under this non free license:
# Copyright (C) 2002-2008, Milan Ikits <milan ikits[]ieee org>
# Copyright (C) 2002-2008, Marcelo E. Magallon <mmagallo[]debian org>
# This documentation may not be modified or redistributed in any
# form, except by the copyright holder.
# and therefor these files have been removed.
Source0: glew-%{version}-src-clean.tgz
# These are modified headers from Mesa, with all post GL[x] 1.1 defines and
# prototypes removed, these replace the removed encumbered auto/src/glew_head.h
# and auto/src/glxew_head.h files
Source1: glew-mesa-replacement-headers.tgz
Source2: LICENSE-README.fedora
Patch0: glew-1.3.6-pathandstrip.patch
Patch1: glew-1.4.0-auto-make.patch
Patch2: glew-1.4.0-unused-direct-shlib-dependency.patch
Patch3: glew-1.4.0-license-doc.patch
Patch4: glew-1.4.0-GL_FLOAT_MATXxX.patch
Patch1: glew-1.4.0-unused-direct-shlib-dependency.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libGLU-devel
@ -45,20 +38,9 @@ Development files for glew
%prep
%setup -q -a 1 -n %{name}
%setup -q -n %{name}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
cp %{SOURCE2} .
mkdir auto/registry
touch auto/registry/.dummy auto/extensions/.dummy
make -C auto ../include/GL/glew.h
make -C auto ../include/GL/glxew.h
# This is a patch to the autogenerated include/GL/glew.h file, so don't apply
# before that file is generated. I have no clue why these defines do not get
# properly added by the generation process, but they don't.
%patch4 -p1
%build
@ -83,18 +65,22 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc LICENSE-README.fedora
%doc LICENSE.txt
%{_bindir}/*
%{_libdir}/libGLEW.so.*
%files devel
%defattr(-,root,root,-)
%doc doc/*
%{_libdir}/libGLEW.so
%{_includedir}/GL/*.h
%changelog
* Mon Jan 21 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.5.0-1
- New upstream version, now SGI licensed stuff free out of the box!
- Unfortunately some of the included docs are under a non free license,
therefor this package is based on a modified tarbal with these files removed
* Sat Jan 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.0-4
- Add missing GL_FLOAT_MATXxX defines

View File

@ -1,2 +1 @@
c8b8f2db1b68886baf6c0849807884b4 glew-1.4.0-src-clean.tgz
211daf41c394153f3d989195898145a6 glew-mesa-replacement-headers.tgz
2920724f7a462fff84346b4de2c8aebe glew-1.5.0-src-clean.tgz