Bump bundled mozjs version
Follow F40 and update to 115.12.0. Resolves: https://issues.redhat.com/browse/RHEL-45601
This commit is contained in:
parent
c508718e7c
commit
fd11e4dbc0
1
.gitignore
vendored
1
.gitignore
vendored
@ -149,3 +149,4 @@ gjs-0.7.1.tar.gz
|
||||
/gjs-1.79.90.tar.xz
|
||||
/gjs-1.80.2.tar.xz
|
||||
/firefox-115.7.0esr.source.tar.xz
|
||||
/firefox-115.12.0esr.source.tar.xz
|
||||
|
15
gjs.spec
15
gjs.spec
@ -1,12 +1,12 @@
|
||||
%global glib2_version 2.66.0
|
||||
%global gobject_introspection_version 1.66.0
|
||||
%global mozjs115_version 115.7.0
|
||||
%global mozjs115_version 115.12.0
|
||||
|
||||
%global bundled_mozjs 1
|
||||
|
||||
%if 0%{?bundled_mozjs}
|
||||
%global mozjs_major 115
|
||||
%global mozjs_version 115.7.0
|
||||
%global mozjs_major %%(cut -d "." -f 1 <<<%{mozjs115_version})
|
||||
%global mozjs_version %{mozjs115_version}
|
||||
|
||||
# LTO - Enable in Release builds, but consider disabling for development as it increases compile time
|
||||
%global mozjs_build_with_lto 1
|
||||
@ -29,7 +29,7 @@
|
||||
|
||||
Name: gjs
|
||||
Version: 1.80.2
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: Javascript Bindings for GNOME
|
||||
|
||||
# The following files contain code from Mozilla which
|
||||
@ -77,6 +77,9 @@ Patch20: spidermonkey_checks_disable.patch
|
||||
|
||||
# s390x/ppc64 fixes
|
||||
Patch21: 0001-Skip-failing-tests-on-ppc64-and-s390x.patch
|
||||
|
||||
# Test fixes
|
||||
Patch30: tests-Replace-pipes-with-shlex-for-Python-3.13.patch
|
||||
%endif
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
@ -306,6 +309,10 @@ popd
|
||||
%{_datadir}/installed-tests/
|
||||
|
||||
%changelog
|
||||
* Mon Jul 01 2024 Florian Müllner <fmuellner@redhat.com> - 1.80.2-7
|
||||
- Bump bundled mozjs version
|
||||
Resolves: RHEL-45601
|
||||
|
||||
* Mon Jul 01 2024 Florian Müllner <fmuellner@redhat.com> - 1.80.2-6
|
||||
- Re-enable LTO for all archs
|
||||
Resolves: RHEL-40915
|
||||
|
@ -6,6 +6,7 @@ non262/Intl/DateTimeFormat/day-period-hour-cycle.js
|
||||
non262/Intl/DateTimeFormat/fractional-second-digits-append-item.js
|
||||
non262/Intl/DateTimeFormat/related-year.js
|
||||
non262/Intl/DateTimeFormat/timeZone_backzone.js
|
||||
non262/Intl/DateTimeFormat/timeZone_version.js
|
||||
non262/Intl/DisplayNames/calendar.js
|
||||
non262/Intl/DisplayNames/currency.js
|
||||
non262/Intl/DisplayNames/language-dialect.js
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (gjs-1.80.2.tar.xz) = cc9a9073f741ee60eff2d2ce808cca7f40e97798f9ffa9197ebc3780a8a5df6e174ba76293bf7547fc8fa7e82be6a828a633a5aa8ba27d551dec72d635b6c5bd
|
||||
SHA512 (firefox-115.7.0esr.source.tar.xz) = d468d8ef117d76e0660c5359c3becf0502354c61bdaaeb4137d86f52b50143abec2ac4578af69afa5670700b57efff1c7323ca23e3339a9eaaa888dee7e8e922
|
||||
SHA512 (firefox-115.12.0esr.source.tar.xz) = d98475061d870e0f3aa920b7c0b9b0c1cbdb3f4102f760f1d1c5ea3e45e216c673c8d3662501e7e78af4950a003a519e94b57e9b1eda8d615c159cdf62130e89
|
||||
|
32
tests-Replace-pipes-with-shlex-for-Python-3.13.patch
Normal file
32
tests-Replace-pipes-with-shlex-for-Python-3.13.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From dae1848488117166227b00cd7dcadf704b770339 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
|
||||
Date: Wed, 12 Jun 2024 15:56:03 +0200
|
||||
Subject: [PATCH] tests: Replace pipes with shlex for Python 3.13
|
||||
|
||||
---
|
||||
js/src/tests/lib/results.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/js/src/tests/lib/results.py b/js/src/tests/lib/results.py
|
||||
index f902060..ba0c7c6 100644
|
||||
--- a/js/src/tests/lib/results.py
|
||||
+++ b/js/src/tests/lib/results.py
|
||||
@@ -1,5 +1,5 @@
|
||||
import json
|
||||
-import pipes
|
||||
+import shlex
|
||||
import re
|
||||
|
||||
from .progressbar import NullProgressBar, ProgressBar
|
||||
@@ -9,7 +9,7 @@ from .structuredlog import TestLogger
|
||||
|
||||
|
||||
def escape_cmdline(args):
|
||||
- return " ".join([pipes.quote(a) for a in args])
|
||||
+ return " ".join([shlex.quote(a) for a in args])
|
||||
|
||||
|
||||
class TestOutput:
|
||||
--
|
||||
2.45.1
|
||||
|
Loading…
Reference in New Issue
Block a user