Install missing headers
This commit is contained in:
parent
afe6c5d659
commit
f2fe80fc78
11
gjs.spec
11
gjs.spec
@ -1,6 +1,6 @@
|
||||
Name: gjs
|
||||
Version: 1.29.15
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Javascript Bindings for GNOME
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -23,6 +23,9 @@ BuildRequires: pkgconfig
|
||||
# Bootstrap requirements
|
||||
BuildRequires: gtk-doc gnome-common
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=655482
|
||||
Patch0: install-gi-headers.patch
|
||||
|
||||
%description
|
||||
Gjs allows using GNOME libraries from Javascript. It's based on the
|
||||
Spidermonkey Javascript engine from Mozilla and the GObject introspection
|
||||
@ -40,6 +43,9 @@ Files for development with %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1 -b .headers
|
||||
rm -f configure
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
%configure --disable-static)
|
||||
@ -81,6 +87,9 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Thu Aug 04 2011 Bastien Nocera <bnocera@redhat.com> 1.29.15-3
|
||||
- Install missing headers
|
||||
|
||||
* Thu Jul 28 2011 Colin Walters <walters@verbum.org> - 1.29.15-2
|
||||
- BR latest g-i to fix build issue
|
||||
|
||||
|
63
install-gi-headers.patch
Normal file
63
install-gi-headers.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From 4217cb5e07519ea41fdff9b906b93ce6946c109e Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Sat, 30 Jul 2011 11:40:25 -0400
|
||||
Subject: [PATCH] Install gi/ headers again
|
||||
|
||||
libpeas currently requires these; we were installing them before, and
|
||||
since we export almost all of our internals in for gjs-module.pc, might
|
||||
as well keep doing these for now.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=655482
|
||||
---
|
||||
Makefile.am | 28 ++++++++++++++--------------
|
||||
1 files changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index edf0c25..b088289 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -36,7 +36,20 @@ nobase_gjs_module_include_HEADERS = \
|
||||
gjs/importer.h \
|
||||
gjs/jsapi-util.h \
|
||||
gjs/mem.h \
|
||||
- gjs/native.h
|
||||
+ gjs/native.h \
|
||||
+ gi/ns.h \
|
||||
+ gi/object.h \
|
||||
+ gi/foreign.h \
|
||||
+ gi/param.h \
|
||||
+ gi/repo.h \
|
||||
+ gi/union.h \
|
||||
+ gi/value.h \
|
||||
+ gi/arg.h \
|
||||
+ gi/boxed.h \
|
||||
+ gi/closure.h \
|
||||
+ gi/enumeration.h \
|
||||
+ gi/function.h \
|
||||
+ gi/keep-alive.h
|
||||
|
||||
noinst_HEADERS += \
|
||||
gjs/jsapi-private.h \
|
||||
@@ -108,20 +121,7 @@ libgjs_la_SOURCES = \
|
||||
|
||||
# For historical reasons, some files live in gi/
|
||||
libgjs_la_SOURCES += \
|
||||
- gi/arg.h \
|
||||
- gi/boxed.h \
|
||||
- gi/closure.h \
|
||||
- gi/enumeration.h \
|
||||
- gi/function.h \
|
||||
- gi/keep-alive.h \
|
||||
gi/gjs_gi_trace.h \
|
||||
- gi/ns.h \
|
||||
- gi/object.h \
|
||||
- gi/foreign.h \
|
||||
- gi/param.h \
|
||||
- gi/repo.h \
|
||||
- gi/union.h \
|
||||
- gi/value.h \
|
||||
gi/arg.c \
|
||||
gi/boxed.c \
|
||||
gi/closure.c \
|
||||
--
|
||||
1.7.6
|
Loading…
Reference in New Issue
Block a user