Update to 1.65.92
This commit is contained in:
parent
61d2abdb6f
commit
805a907762
1
.gitignore
vendored
1
.gitignore
vendored
@ -110,3 +110,4 @@ gjs-0.7.1.tar.gz
|
|||||||
/gjs-1.65.4.tar.xz
|
/gjs-1.65.4.tar.xz
|
||||||
/gjs-1.65.90.tar.xz
|
/gjs-1.65.90.tar.xz
|
||||||
/gjs-1.65.91.tar.xz
|
/gjs-1.65.91.tar.xz
|
||||||
|
/gjs-1.65.92.tar.xz
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From dc15ab81baf589a071b241da90e2ee83c83baef3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Williamson <awilliam@redhat.com>
|
|
||||||
Date: Fri, 28 Aug 2020 13:33:04 -0700
|
|
||||||
Subject: [PATCH] gjs_dbus_implementation_emit_signal: don't try to unref NULL
|
|
||||||
|
|
||||||
07221d6d (which added support for multiple bus connections)
|
|
||||||
added a `g_variant_unref(parameters)` call here, but it needs to
|
|
||||||
only be done if `parameters` is not `NULL`. This was causing
|
|
||||||
frequent "g_variant_unref: assertion 'value != NULL' failed"
|
|
||||||
errors in the journal, see
|
|
||||||
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3102 .
|
|
||||||
|
|
||||||
Signed-off-by: Adam Williamson <awilliam@redhat.com>
|
|
||||||
---
|
|
||||||
libgjs-private/gjs-gdbus-wrapper.c | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/libgjs-private/gjs-gdbus-wrapper.c b/libgjs-private/gjs-gdbus-wrapper.c
|
|
||||||
index f7361366..eb0516f9 100644
|
|
||||||
--- a/libgjs-private/gjs-gdbus-wrapper.c
|
|
||||||
+++ b/libgjs-private/gjs-gdbus-wrapper.c
|
|
||||||
@@ -395,7 +395,9 @@ gjs_dbus_implementation_emit_signal (GjsDBusImplementation *self,
|
|
||||||
|
|
||||||
g_object_unref(iter->data);
|
|
||||||
}
|
|
||||||
- g_variant_unref(parameters);
|
|
||||||
+ if (parameters != NULL)
|
|
||||||
+ g_variant_unref(parameters);
|
|
||||||
+
|
|
||||||
g_list_free(connections);
|
|
||||||
}
|
|
||||||
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
10
gjs.spec
10
gjs.spec
@ -4,8 +4,8 @@
|
|||||||
%global mozjs78_version 78.2.0-1
|
%global mozjs78_version 78.2.0-1
|
||||||
|
|
||||||
Name: gjs
|
Name: gjs
|
||||||
Version: 1.65.91
|
Version: 1.65.92
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Javascript Bindings for GNOME
|
Summary: Javascript Bindings for GNOME
|
||||||
|
|
||||||
# The following files contain code from Mozilla which
|
# The following files contain code from Mozilla which
|
||||||
@ -15,9 +15,6 @@ Summary: Javascript Bindings for GNOME
|
|||||||
License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
|
License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
|
||||||
URL: https://wiki.gnome.org/Projects/Gjs
|
URL: https://wiki.gnome.org/Projects/Gjs
|
||||||
Source0: https://download.gnome.org/sources/%{name}/1.65/%{name}-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/%{name}/1.65/%{name}-%{version}.tar.xz
|
||||||
# Fix frequent "g_variant_unref: assertion 'value != NULL' failed" errors
|
|
||||||
# https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/483
|
|
||||||
Patch0: 0001-gjs_dbus_implementation_emit_signal-don-t-try-to-unr.patch
|
|
||||||
|
|
||||||
BuildRequires: cairo-gobject-devel
|
BuildRequires: cairo-gobject-devel
|
||||||
BuildRequires: dbus-daemon
|
BuildRequires: dbus-daemon
|
||||||
@ -97,6 +94,9 @@ the functionality of the installed gjs package.
|
|||||||
%{_datadir}/installed-tests/
|
%{_datadir}/installed-tests/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Sep 06 2020 Kalev Lember <klember@redhat.com> - 1.65.92-1
|
||||||
|
- Update to 1.65.92
|
||||||
|
|
||||||
* Fri Aug 28 2020 Adam Williamson <awilliam@redhat.com> - 1.65.91-3
|
* Fri Aug 28 2020 Adam Williamson <awilliam@redhat.com> - 1.65.91-3
|
||||||
- Backport MR #483 to fix frequent g_variant_unref errors in journal
|
- Backport MR #483 to fix frequent g_variant_unref errors in journal
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (gjs-1.65.91.tar.xz) = 966ff6a073956fac83a5b9340580bd899efd42df09b97766c75842ef66c77e3e441c69274e73a29e36cb2b53d8bbc176e102e8520d1fa187a489d61c6e15404e
|
SHA512 (gjs-1.65.92.tar.xz) = 0e9c41c55cc07b81c4df482c4e6397508e369b7547dc371dcdaec12bc20cd4c332815fdca16db2b7ad92ffc445d6035963bb1bead8751c3a20f8f9e8e2703c3a
|
||||||
|
Loading…
Reference in New Issue
Block a user