Merge commit '91a1ee156251133fb2d628f611cb40c26cee046b'
Conflicts: gjs.spec
This commit is contained in:
commit
5f7847a7f0
2
.gitignore
vendored
2
.gitignore
vendored
@ -10,3 +10,5 @@ gjs-0.7.1.tar.gz
|
||||
/gjs-0.7.13.tar.bz2
|
||||
/gjs-0.7.14.tar.bz2
|
||||
/gjs-1.29.0.tar.xz
|
||||
/gjs-1.29.15.tar.xz
|
||||
/gjs-1.29.16.tar.xz
|
||||
|
22
gjs.spec
22
gjs.spec
@ -1,8 +1,7 @@
|
||||
Name: gjs
|
||||
Version: 1.29.0
|
||||
Release: 3%{?dist}
|
||||
Version: 1.29.16
|
||||
Release: 1%{?dist}
|
||||
Summary: Javascript Bindings for GNOME
|
||||
|
||||
Group: System Environment/Libraries
|
||||
# The following files contain code from Mozilla which
|
||||
# is triple licensed under MPL1.1/LGPLv2+/GPLv2+:
|
||||
@ -11,8 +10,7 @@ Group: System Environment/Libraries
|
||||
License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
|
||||
URL: http://live.gnome.org/Gjs/
|
||||
#VCS: git://git.gnome.org/gjs
|
||||
Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.29/%{name}-%{version}.tar.xz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Source0: http://download.gnome.org/sources/%{name}/1.29/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: js-devel
|
||||
BuildRequires: cairo-devel
|
||||
@ -41,6 +39,8 @@ Files for development with %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
rm -f configure
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
%configure --disable-static)
|
||||
@ -48,7 +48,6 @@ Files for development with %{name}.
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
#Remove libtool archives.
|
||||
@ -57,33 +56,32 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
%check
|
||||
#make check
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING NEWS README
|
||||
%{_bindir}/gjs
|
||||
%{_bindir}/gjs-console
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/gjs-1.0
|
||||
%{_libdir}/gjs/*.typelib
|
||||
%{_datadir}/gjs-1.0
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc examples/*
|
||||
%{_includedir}/gjs-1.0
|
||||
%{_libdir}/gjs/*.gir
|
||||
%{_libdir}/pkgconfig/gjs-1.0.pc
|
||||
%{_libdir}/pkgconfig/gjs-gi-1.0.pc
|
||||
%{_libdir}/pkgconfig/gjs-dbus-1.0.pc
|
||||
%{_libdir}/pkgconfig/gjs-internals-1.0.pc
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Thu Aug 18 2011 Matthias Clasen <mclasen@redhat.com> 1.29.16-1
|
||||
- Update to 1.29.16
|
||||
|
||||
* Thu Jul 28 2011 Colin Walters <walters@verbum.org> - 1.29.0-3
|
||||
- BR latest g-i to fix build issue
|
||||
|
||||
|
63
install-gi-headers.patch
Normal file
63
install-gi-headers.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From 4217cb5e07519ea41fdff9b906b93ce6946c109e Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Sat, 30 Jul 2011 11:40:25 -0400
|
||||
Subject: [PATCH] Install gi/ headers again
|
||||
|
||||
libpeas currently requires these; we were installing them before, and
|
||||
since we export almost all of our internals in for gjs-module.pc, might
|
||||
as well keep doing these for now.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=655482
|
||||
---
|
||||
Makefile.am | 28 ++++++++++++++--------------
|
||||
1 files changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index edf0c25..b088289 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -36,7 +36,20 @@ nobase_gjs_module_include_HEADERS = \
|
||||
gjs/importer.h \
|
||||
gjs/jsapi-util.h \
|
||||
gjs/mem.h \
|
||||
- gjs/native.h
|
||||
+ gjs/native.h \
|
||||
+ gi/ns.h \
|
||||
+ gi/object.h \
|
||||
+ gi/foreign.h \
|
||||
+ gi/param.h \
|
||||
+ gi/repo.h \
|
||||
+ gi/union.h \
|
||||
+ gi/value.h \
|
||||
+ gi/arg.h \
|
||||
+ gi/boxed.h \
|
||||
+ gi/closure.h \
|
||||
+ gi/enumeration.h \
|
||||
+ gi/function.h \
|
||||
+ gi/keep-alive.h
|
||||
|
||||
noinst_HEADERS += \
|
||||
gjs/jsapi-private.h \
|
||||
@@ -108,20 +121,7 @@ libgjs_la_SOURCES = \
|
||||
|
||||
# For historical reasons, some files live in gi/
|
||||
libgjs_la_SOURCES += \
|
||||
- gi/arg.h \
|
||||
- gi/boxed.h \
|
||||
- gi/closure.h \
|
||||
- gi/enumeration.h \
|
||||
- gi/function.h \
|
||||
- gi/keep-alive.h \
|
||||
gi/gjs_gi_trace.h \
|
||||
- gi/ns.h \
|
||||
- gi/object.h \
|
||||
- gi/foreign.h \
|
||||
- gi/param.h \
|
||||
- gi/repo.h \
|
||||
- gi/union.h \
|
||||
- gi/value.h \
|
||||
gi/arg.c \
|
||||
gi/boxed.c \
|
||||
gi/closure.c \
|
||||
--
|
||||
1.7.6
|
Loading…
Reference in New Issue
Block a user