Rebuild
JS API changed slightly once more. Just making the change directly instead of the patch to configure that's upstream in order to avoid adding a BuildRequire and call to autoconf.
This commit is contained in:
parent
3917b36321
commit
3ffb1b977f
14
gjs-0.7.9-ffb10.patch
Normal file
14
gjs-0.7.9-ffb10.patch
Normal file
@ -0,0 +1,14 @@
|
||||
Based on http://git.gnome.org/browse/gjs/commit/?id=950d000d94cef63496747119e7822f9978088864
|
||||
|
||||
diff -up gjs-0.7.9/gjs/jsapi-util.c.ffb10 gjs-0.7.9/gjs/jsapi-util.c
|
||||
--- gjs-0.7.9/gjs/jsapi-util.c.ffb10 2011-01-25 01:05:34.013344556 -0800
|
||||
+++ gjs-0.7.9/gjs/jsapi-util.c 2011-01-25 01:06:20.121768121 -0800
|
||||
@@ -255,7 +255,7 @@ gjs_init_context_standard (JSContext
|
||||
{
|
||||
JSObject *global;
|
||||
#ifdef HAVE_MOZJS_2
|
||||
- global = JS_NewGlobalObject(context, &global_class);
|
||||
+ global = JS_NewCompartmentAndGlobalObject(context, &global_class, NULL);
|
||||
if (global == NULL)
|
||||
return FALSE;
|
||||
#else
|
7
gjs.spec
7
gjs.spec
@ -1,6 +1,6 @@
|
||||
Name: gjs
|
||||
Version: 0.7.9
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Javascript Bindings for GNOME
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -12,6 +12,7 @@ License: MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
|
||||
URL: http://live.gnome.org/Gjs/
|
||||
#VCS: git://git.gnome.org/gjs
|
||||
Source0: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{version}/%{name}-%{version}.tar.bz2
|
||||
Patch0: gjs-0.7.9-ffb10.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: xulrunner-devel
|
||||
@ -38,6 +39,7 @@ Files for development with %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .ffb10
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi;
|
||||
@ -82,6 +84,9 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/*.so
|
||||
|
||||
%changelog
|
||||
* Tue Jan 25 2011 Christopher Aillon <caillon@redhat.com> - 0.7.9-3
|
||||
- Rebuild for new xulrunner
|
||||
|
||||
* Fri Jan 14 2011 Christopher Aillon <caillon@redhat.com> - 0.7.9-2
|
||||
- Rebuild for new xulrunner
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user