Update to 0.7.11
This commit is contained in:
parent
fd981f4869
commit
3fdcba5c82
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ gjs-0.7.1.tar.gz
|
|||||||
/gjs-0.7.8.tar.bz2
|
/gjs-0.7.8.tar.bz2
|
||||||
/gjs-0.7.9.tar.bz2
|
/gjs-0.7.9.tar.bz2
|
||||||
/gjs-0.7.10.tar.bz2
|
/gjs-0.7.10.tar.bz2
|
||||||
|
/gjs-0.7.11.tar.bz2
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
Based on http://git.gnome.org/browse/gjs/commit/?id=950d000d94cef63496747119e7822f9978088864
|
|
||||||
|
|
||||||
diff -up gjs-0.7.9/gjs/jsapi-util.c.ffb10 gjs-0.7.9/gjs/jsapi-util.c
|
|
||||||
--- gjs-0.7.9/gjs/jsapi-util.c.ffb10 2011-01-25 01:05:34.013344556 -0800
|
|
||||||
+++ gjs-0.7.9/gjs/jsapi-util.c 2011-01-25 01:06:20.121768121 -0800
|
|
||||||
@@ -255,7 +255,7 @@ gjs_init_context_standard (JSContext
|
|
||||||
{
|
|
||||||
JSObject *global;
|
|
||||||
#ifdef HAVE_MOZJS_2
|
|
||||||
- global = JS_NewGlobalObject(context, &global_class);
|
|
||||||
+ global = JS_NewCompartmentAndGlobalObject(context, &global_class, NULL);
|
|
||||||
if (global == NULL)
|
|
||||||
return FALSE;
|
|
||||||
#else
|
|
7
gjs.spec
7
gjs.spec
@ -1,6 +1,6 @@
|
|||||||
Name: gjs
|
Name: gjs
|
||||||
Version: 0.7.10
|
Version: 0.7.11
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Javascript Bindings for GNOME
|
Summary: Javascript Bindings for GNOME
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -88,6 +88,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 22 2011 Owen Taylor <otaylor@redhat.com> - 0.7.11-1
|
||||||
|
- Update to 0.7.11
|
||||||
|
|
||||||
* Thu Feb 10 2011 Christopher Aillon <caillon@redhat.com> - 0.7.10-4
|
* Thu Feb 10 2011 Christopher Aillon <caillon@redhat.com> - 0.7.10-4
|
||||||
- Require gecko-libs instead of xulrunner
|
- Require gecko-libs instead of xulrunner
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user