When building packages, we install to DESTDIR but we don't want this to end up hard-coded in the scripts. This needs discussed upstream to find a proper solution.
30 lines
926 B
Diff
30 lines
926 B
Diff
From d40d33173dc24d9b7ad6f5071994f90b5f9a71e8 Mon Sep 17 00:00:00 2001
|
|
From: Todd Zullinger <tmz@pobox.com>
|
|
Date: Wed, 27 Mar 2013 14:01:57 -0400
|
|
Subject: [PATCH] Drop DESTDIR from python instlibdir
|
|
|
|
When building packages, we install to DESTDIR but we don't want this to
|
|
end up hard-coded in the scripts.
|
|
|
|
This needs discussed upstream to find a proper solution.
|
|
---
|
|
git_remote_helpers/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/git_remote_helpers/Makefile b/git_remote_helpers/Makefile
|
|
index 3d12232..36d40b5 100644
|
|
--- a/git_remote_helpers/Makefile
|
|
+++ b/git_remote_helpers/Makefile
|
|
@@ -38,7 +38,7 @@ install: $(pysetupfile)
|
|
$(PYTHON_PATH) $(pysetupfile) install --prefix $(DESTDIR_SQ)$(prefix)
|
|
|
|
instlibdir: $(pysetupfile)
|
|
- @echo "$(DESTDIR_SQ)$(prefix)/$(PYLIBDIR)"
|
|
+ @echo "$(prefix)/$(PYLIBDIR)"
|
|
|
|
clean:
|
|
$(QUIET)$(PYTHON_PATH) $(pysetupfile) $(QUIETSETUP) clean -a
|
|
--
|
|
1.8.1
|
|
|