2.1.0
This commit is contained in:
parent
9055f38936
commit
fe074a6c9e
@ -1,44 +0,0 @@
|
||||
From a906459c2a89938e911f1650e6ce22315a1ec84d Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Fri, 4 Jan 2013 11:54:21 -0500
|
||||
Subject: [PATCH] git-subtree: Use gitexecdir instead of libexecdir
|
||||
|
||||
When the git subtree Makefile includes config.mak from the toplevel,
|
||||
it's useful to have the same variables set globally applied. Using
|
||||
gitexecdir instead of libexecdir respects the global settings more
|
||||
consistently.
|
||||
|
||||
Remove the unused gitdir variable as well.
|
||||
---
|
||||
contrib/subtree/Makefile | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/contrib/subtree/Makefile b/contrib/subtree/Makefile
|
||||
index 435b2de..dc8da19 100644
|
||||
--- a/contrib/subtree/Makefile
|
||||
+++ b/contrib/subtree/Makefile
|
||||
@@ -2,9 +2,8 @@
|
||||
-include ../../config.mak
|
||||
|
||||
prefix ?= /usr/local
|
||||
+gitexecdir ?= $(prefix)/libexec/git-core
|
||||
mandir ?= $(prefix)/share/man
|
||||
-libexecdir ?= $(prefix)/libexec/git-core
|
||||
-gitdir ?= $(shell git --exec-path)
|
||||
man1dir ?= $(mandir)/man1
|
||||
|
||||
gitver ?= $(word 3,$(shell git --version))
|
||||
@@ -30,8 +29,8 @@ $(GIT_SUBTREE): $(GIT_SUBTREE_SH)
|
||||
doc: $(GIT_SUBTREE_DOC) $(GIT_SUBTREE_HTML)
|
||||
|
||||
install: $(GIT_SUBTREE)
|
||||
- $(INSTALL) -d -m 755 $(DESTDIR)$(libexecdir)
|
||||
- $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(libexecdir)
|
||||
+ $(INSTALL) -d -m 755 $(DESTDIR)$(gitexecdir)
|
||||
+ $(INSTALL) -m 755 $(GIT_SUBTREE) $(DESTDIR)$(gitexecdir)
|
||||
|
||||
install-doc: install-man
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
9
git.spec
9
git.spec
@ -43,8 +43,8 @@
|
||||
%endif
|
||||
|
||||
Name: git
|
||||
Version: 2.0.4
|
||||
Release: 2%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
Group: Development/Tools
|
||||
@ -64,7 +64,6 @@ Patch0: git-1.8-gitweb-home-link.patch
|
||||
Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
# https://bugzilla.redhat.com/600411
|
||||
Patch3: git-1.7-el5-emacs-support.patch
|
||||
Patch5: 0001-git-subtree-Use-gitexecdir-instead-of-libexecdir.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -308,7 +307,6 @@ Requires: emacs-git = %{version}-%{release}
|
||||
%if %{emacs_old}
|
||||
%patch3 -p1
|
||||
%endif
|
||||
%patch5 -p1
|
||||
|
||||
%if %{use_prebuilt_docs}
|
||||
mkdir -p prebuilt_docs/{html,man}
|
||||
@ -633,6 +631,9 @@ rm -rf %{buildroot}
|
||||
# No files for you!
|
||||
|
||||
%changelog
|
||||
* Mon Aug 18 2014 Ondrej Oprala <ooprala@redhat.com - 2.1.0-1
|
||||
- 2.1.0
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
f072436581ac0c0e9660a0637fd3ae2c git-2.0.4.tar.gz
|
||||
63361c7aa7424d47b8ccdff09fafe1ba git-htmldocs-2.0.4.tar.gz
|
||||
b256562b05242250df07f6a91e0887a2 git-manpages-2.0.4.tar.gz
|
||||
40f059350019ff1f0763b315d0ca5c2e git-2.1.0.tar.gz
|
||||
920860531676844a232589b21c1fba35 git-htmldocs-2.1.0.tar.gz
|
||||
3a0745e8302a904c8359e8a5da594cc9 git-manpages-2.1.0.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user