Update to 2.21.0.rc1
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.21.0.txt
This commit is contained in:
parent
aefb419775
commit
f506af1ff5
@ -1,39 +0,0 @@
|
|||||||
From 32ca60bbf5bb3020bbf24036bc61003711ace611 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Todd Zullinger <tmz@pobox.com>
|
|
||||||
Date: Fri, 1 Feb 2019 19:36:41 -0500
|
|
||||||
Subject: [PATCH 1/2] t/lib-gpg: quote path to ${GNUPGHOME}/trustlist.txt
|
|
||||||
|
|
||||||
When gpgsm is installed, lib-gpg.sh attempts to update trustlist.txt to
|
|
||||||
relax the checking of some root certificate requirements. The path to
|
|
||||||
"${GNUPGHOME}" contains spaces which cause an "ambiguous redirect"
|
|
||||||
warning when bash is used to run the tests:
|
|
||||||
|
|
||||||
$ bash t7030-verify-tag.sh
|
|
||||||
/git/t/lib-gpg.sh: line 66: ${GNUPGHOME}/trustlist.txt: ambiguous redirect
|
|
||||||
ok 1 - create signed tags
|
|
||||||
ok 2 # skip create signed tags x509 (missing GPGSM)
|
|
||||||
...
|
|
||||||
|
|
||||||
No warning is issued when using bash called as /bin/sh, dash, or mksh.
|
|
||||||
|
|
||||||
Quote the path to ensure the redirect works as intended and sets the
|
|
||||||
GPGSM prereq. While we're here, drop the space after ">>".
|
|
||||||
|
|
||||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
|
||||||
---
|
|
||||||
t/lib-gpg.sh | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/t/lib-gpg.sh b/t/lib-gpg.sh
|
|
||||||
index f1277bef4f..207009793b 100755
|
|
||||||
--- a/t/lib-gpg.sh
|
|
||||||
+++ b/t/lib-gpg.sh
|
|
||||||
@@ -63,7 +63,7 @@ then
|
|
||||||
cut -d" " -f4 |
|
|
||||||
tr -d '\n' >"${GNUPGHOME}/trustlist.txt" &&
|
|
||||||
|
|
||||||
- echo " S relax" >> ${GNUPGHOME}/trustlist.txt &&
|
|
||||||
+ echo " S relax" >>"${GNUPGHOME}/trustlist.txt" &&
|
|
||||||
(gpgconf --kill gpg-agent >/dev/null 2>&1 || : ) &&
|
|
||||||
echo hello | gpgsm --homedir "${GNUPGHOME}" >/dev/null \
|
|
||||||
-u committer@example.com -o /dev/null --sign - 2>&1 &&
|
|
@ -1,40 +0,0 @@
|
|||||||
From 09436d6a5b6db6ab8e80ab449b3b841883b27d19 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Todd Zullinger <tmz@pobox.com>
|
|
||||||
Date: Sat, 2 Feb 2019 02:31:52 -0500
|
|
||||||
Subject: [PATCH 2/2] t/lib-gpg: drop redundant killing of gpg-agent
|
|
||||||
|
|
||||||
In 53fc999306 ("gpg-interface t: extend the existing GPG tests with
|
|
||||||
GPGSM", 2018-07-20), the gpgconf call which kills gpg-agent was copied
|
|
||||||
from the existing gpg setup code.
|
|
||||||
|
|
||||||
The reason for killing gpg-agent is given in 29ff1f8f74 ("t: lib-gpg:
|
|
||||||
flush gpg agent on startup", 2017-07-20):
|
|
||||||
|
|
||||||
When running gpg-relevant tests, a gpg-daemon is spawned for each
|
|
||||||
GNUPGHOME used. This daemon may stay running after the test and cache
|
|
||||||
file descriptors for the trash directories, even after the trash
|
|
||||||
directory is removed. This leads to ENOENT errors when attempting to
|
|
||||||
create files if tests are run multiple times.
|
|
||||||
|
|
||||||
Add a cleanup script to force flushing the gpg-agent for that GNUPGHOME
|
|
||||||
(if any) before setting up the GPG relevant-environment.
|
|
||||||
|
|
||||||
Killing gpg-agent once per test is sufficient.
|
|
||||||
|
|
||||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
|
||||||
---
|
|
||||||
t/lib-gpg.sh | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/t/lib-gpg.sh b/t/lib-gpg.sh
|
|
||||||
index 207009793b..8d28652b72 100755
|
|
||||||
--- a/t/lib-gpg.sh
|
|
||||||
+++ b/t/lib-gpg.sh
|
|
||||||
@@ -64,7 +64,6 @@ then
|
|
||||||
tr -d '\n' >"${GNUPGHOME}/trustlist.txt" &&
|
|
||||||
|
|
||||||
echo " S relax" >>"${GNUPGHOME}/trustlist.txt" &&
|
|
||||||
- (gpgconf --kill gpg-agent >/dev/null 2>&1 || : ) &&
|
|
||||||
echo hello | gpgsm --homedir "${GNUPGHOME}" >/dev/null \
|
|
||||||
-u committer@example.com -o /dev/null --sign - 2>&1 &&
|
|
||||||
test_set_prereq GPGSM
|
|
13
git.spec
13
git.spec
@ -84,11 +84,11 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Define for release candidates
|
# Define for release candidates
|
||||||
%global rcrev .rc0
|
%global rcrev .rc1
|
||||||
|
|
||||||
Name: git
|
Name: git
|
||||||
Version: 2.21.0
|
Version: 2.21.0
|
||||||
Release: 0.0%{?rcrev}%{?dist}
|
Release: 0.1%{?rcrev}%{?dist}
|
||||||
Summary: Fast Version Control System
|
Summary: Fast Version Control System
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: https://git-scm.com/
|
URL: https://git-scm.com/
|
||||||
@ -119,12 +119,6 @@ Source99: print-failed-test-output
|
|||||||
|
|
||||||
# https://bugzilla.redhat.com/490602
|
# https://bugzilla.redhat.com/490602
|
||||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||||
# Fix "ambiguous redirect" in t/lib-gpg.sh; it causes gpgsm tests to be skipped
|
|
||||||
# https://public-inbox.org/git/20190208031746.22683-2-tmz@pobox.com/
|
|
||||||
Patch2: 0001-t-lib-gpg-quote-path-to-GNUPGHOME-trustlist.txt.patch
|
|
||||||
# t/lib-gpg: drop redundant killing of gpg-agent
|
|
||||||
# https://public-inbox.org/git/20190208031746.22683-3-tmz@pobox.com/
|
|
||||||
Patch3: 0002-t-lib-gpg-drop-redundant-killing-of-gpg-agent.patch
|
|
||||||
|
|
||||||
%if %{with docs}
|
%if %{with docs}
|
||||||
# pod2man is needed to build Git.3pm
|
# pod2man is needed to build Git.3pm
|
||||||
@ -948,6 +942,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
|||||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 13 2019 Todd Zullinger <tmz@pobox.com> - 2.21.0-0.1.rc1
|
||||||
|
- Update to 2.21.0.rc1
|
||||||
|
|
||||||
* Thu Feb 07 2019 Todd Zullinger <tmz@pobox.com> - 2.21.0-0.0.rc0
|
* Thu Feb 07 2019 Todd Zullinger <tmz@pobox.com> - 2.21.0-0.0.rc0
|
||||||
- Update to 2.21.0.rc0
|
- Update to 2.21.0.rc0
|
||||||
- Remove %%changelog entries prior to 2017
|
- Remove %%changelog entries prior to 2017
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (git-2.21.0.rc0.tar.xz) = 8edd38460737b2a49dd6b27d211a4775f1b77df7bb502142341a96a25db05f5e9ec7f9788203414b2c275b0664cefefc7b9e3d4925fb3ed9acce02c4918b340a
|
SHA512 (git-2.21.0.rc1.tar.xz) = 4d8a4981e66b3d3f990b7901c037112ab25bd2a9b1eea8fc3b7b51cea9155edea8a73dedd3d15966239826a9b9162e4f58f87c41bc653ef1d8c5572913e9e49e
|
||||||
SHA512 (git-2.21.0.rc0.tar.sign) = 99e7092367092a4cce08b771cfe658eb768af7b2ad1f9ad6179467bf9612b25dbf02117f7c56b75517e97e40234113ead8fb22820f0e909dd55eb6fb391af8af
|
SHA512 (git-2.21.0.rc1.tar.sign) = 7e706a8551334c692634373b3647a5d45a983dd24bf96dafbffa9d447b60588e1e154d7b030bc863b5d12427293149516c591ce144cd8849de17dad870940553
|
||||||
|
Loading…
Reference in New Issue
Block a user