Update to 2.23.0-rc1
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.23.0.txt
This commit is contained in:
parent
f4c8506a97
commit
eb2423a5cb
@ -1,140 +0,0 @@
|
||||
From e1e7a77141bda8f2ab02f5ed8b0030cba793ec2d Mon Sep 17 00:00:00 2001
|
||||
From: Jeff King <peff@peff.net>
|
||||
Date: Tue, 30 Jul 2019 21:23:37 -0400
|
||||
Subject: [PATCH] t: sort output of hashmap iteration
|
||||
|
||||
The iteration order of a hashmap is undefined, and may depend on things
|
||||
like the exact set of items added, or the table has been grown or
|
||||
shrunk. In the case of an oidmap, it even depends on endianness, because
|
||||
we take the oid hash by casting sha1 bytes directly into an unsigned
|
||||
int.
|
||||
|
||||
Let's sort the test-tool output from any hash iterators. In the case of
|
||||
t0011, this is just future-proofing. But for t0016, it actually fixes a
|
||||
reported failure on the big-endian s390 and nonstop ports.
|
||||
|
||||
I didn't bother to teach the helper functions to optionally sort output.
|
||||
They are short enough that it's simpler to just repeat them inline for
|
||||
the iteration tests than it is to add a --sort option.
|
||||
|
||||
Reported-by: Randall S. Becker <rsbecker@nexbridge.com>
|
||||
Signed-off-by: Jeff King <peff@peff.net>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
---
|
||||
t/t0011-hashmap.sh | 58 ++++++++++++++++++++++++++++------------------
|
||||
t/t0016-oidmap.sh | 30 +++++++++++++++---------
|
||||
2 files changed, 55 insertions(+), 33 deletions(-)
|
||||
|
||||
diff --git a/t/t0011-hashmap.sh b/t/t0011-hashmap.sh
|
||||
index 9c96b3e3b10a9..5343ffd3f92c1 100755
|
||||
--- a/t/t0011-hashmap.sh
|
||||
+++ b/t/t0011-hashmap.sh
|
||||
@@ -170,31 +170,45 @@ NULL
|
||||
'
|
||||
|
||||
test_expect_success 'iterate' '
|
||||
-
|
||||
-test_hashmap "put key1 value1
|
||||
-put key2 value2
|
||||
-put fooBarFrotz value3
|
||||
-iterate" "NULL
|
||||
-NULL
|
||||
-NULL
|
||||
-key2 value2
|
||||
-key1 value1
|
||||
-fooBarFrotz value3"
|
||||
-
|
||||
+ test-tool hashmap >actual.raw <<-\EOF &&
|
||||
+ put key1 value1
|
||||
+ put key2 value2
|
||||
+ put fooBarFrotz value3
|
||||
+ iterate
|
||||
+ EOF
|
||||
+
|
||||
+ cat >expect <<-\EOF &&
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ fooBarFrotz value3
|
||||
+ key1 value1
|
||||
+ key2 value2
|
||||
+ EOF
|
||||
+
|
||||
+ sort <actual.raw >actual &&
|
||||
+ test_cmp expect actual
|
||||
'
|
||||
|
||||
test_expect_success 'iterate (case insensitive)' '
|
||||
-
|
||||
-test_hashmap "put key1 value1
|
||||
-put key2 value2
|
||||
-put fooBarFrotz value3
|
||||
-iterate" "NULL
|
||||
-NULL
|
||||
-NULL
|
||||
-fooBarFrotz value3
|
||||
-key2 value2
|
||||
-key1 value1" ignorecase
|
||||
-
|
||||
+ test-tool hashmap ignorecase >actual.raw <<-\EOF &&
|
||||
+ put key1 value1
|
||||
+ put key2 value2
|
||||
+ put fooBarFrotz value3
|
||||
+ iterate
|
||||
+ EOF
|
||||
+
|
||||
+ cat >expect <<-\EOF &&
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ fooBarFrotz value3
|
||||
+ key1 value1
|
||||
+ key2 value2
|
||||
+ EOF
|
||||
+
|
||||
+ sort <actual.raw >actual &&
|
||||
+ test_cmp expect actual
|
||||
'
|
||||
|
||||
test_expect_success 'grow / shrink' '
|
||||
diff --git a/t/t0016-oidmap.sh b/t/t0016-oidmap.sh
|
||||
index bbe719e950968..31f8276ba82ba 100755
|
||||
--- a/t/t0016-oidmap.sh
|
||||
+++ b/t/t0016-oidmap.sh
|
||||
@@ -86,17 +86,25 @@ NULL"
|
||||
'
|
||||
|
||||
test_expect_success 'iterate' '
|
||||
-
|
||||
-test_oidmap "put one 1
|
||||
-put two 2
|
||||
-put three 3
|
||||
-iterate" "NULL
|
||||
-NULL
|
||||
-NULL
|
||||
-$(git rev-parse two) 2
|
||||
-$(git rev-parse one) 1
|
||||
-$(git rev-parse three) 3"
|
||||
-
|
||||
+ test-tool oidmap >actual.raw <<-\EOF &&
|
||||
+ put one 1
|
||||
+ put two 2
|
||||
+ put three 3
|
||||
+ iterate
|
||||
+ EOF
|
||||
+
|
||||
+ # sort "expect" too so we do not rely on the order of particular oids
|
||||
+ sort >expect <<-EOF &&
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ NULL
|
||||
+ $(git rev-parse one) 1
|
||||
+ $(git rev-parse two) 2
|
||||
+ $(git rev-parse three) 3
|
||||
+ EOF
|
||||
+
|
||||
+ sort <actual.raw >actual &&
|
||||
+ test_cmp expect actual
|
||||
'
|
||||
|
||||
test_done
|
12
git.spec
12
git.spec
@ -84,11 +84,11 @@
|
||||
%endif
|
||||
|
||||
# Define for release candidates
|
||||
%global rcrev .rc0
|
||||
%global rcrev .rc1
|
||||
|
||||
Name: git
|
||||
Version: 2.23.0
|
||||
Release: 0.0%{?rcrev}%{?dist}
|
||||
Release: 0.1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -120,11 +120,6 @@ Source99: print-failed-test-output
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# Fix t0016-oidmap test failure on s390x
|
||||
# https://github.com/gitster/git/commit/e1e7a77141.patch
|
||||
# https://public-inbox.org/git/20190731012336.GA13880@sigill.intra.peff.net/
|
||||
Patch1: 0001-t-sort-output-of-hashmap-iteration.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: %{_bindir}/pod2man
|
||||
@ -1018,6 +1013,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Fri Aug 02 2019 Todd Zullinger <tmz@pobox.com> - 2.23.0-0.1.rc1
|
||||
- Update to 2.23.0-rc1
|
||||
|
||||
* Mon Jul 29 2019 Todd Zullinger <tmz@pobox.com> - 2.23.0-0.0.rc0
|
||||
- Update to 2.23.0-rc0
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.23.0.rc0.tar.xz) = 909d7de2210d754587840759455a0b8d04397ad510fee1009adf5910e89c763ae7434899cb24914d87b07b73ed26c74c5031f6f7df04f7eaacdd105958b8c665
|
||||
SHA512 (git-2.23.0.rc0.tar.sign) = 5739a9fe7d6435f620d542a7569bea1ebfc671570b18ce598f35548093cb453b0a1af9e73b92efcef2648d7c3755c922f7ad3ca4399db5174aebac4ee813a936
|
||||
SHA512 (git-2.23.0.rc1.tar.xz) = 189e390efe87df65e8b24bee33a214d7d2d795719f34b521f4181fbc7f88513c43ebc02108f3227ce7a2c28876521f1de5ba50e06234d1a5f5e251660dc04964
|
||||
SHA512 (git-2.23.0.rc1.tar.sign) = 28001f2721a5b3124b4c42e330bb03aad61a7e6a246b3f691daf9a036ac73381aafef9f878880d8d23cb46814cfc4800010e82b24f14988a3b6ebafdcc461351
|
||||
|
Loading…
Reference in New Issue
Block a user