Sync version with the hotfix branch
Related: RHEL-64984
This commit is contained in:
parent
108e13eb71
commit
eace2ef1fe
@ -1,79 +0,0 @@
|
||||
From fbc6526ea651565889e437ce7b12c762ef858813 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ren=C3=A9=20Scharfe?= <l.s.r@web.de>
|
||||
Date: Tue, 12 Dec 2023 18:04:55 +0100
|
||||
Subject: [PATCH] t6300: avoid hard-coding object sizes
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
f4ee22b526 (ref-filter: add tests for objectsize:disk, 2018-12-24)
|
||||
hard-coded the expected object sizes. Coincidentally the size of commit
|
||||
and tag is the same with zlib at the default compression level.
|
||||
|
||||
1f5f8f3e85 (t6300: abstract away SHA-1-specific constants, 2020-02-22)
|
||||
encoded the sizes as a single value, which coincidentally also works
|
||||
with sha256.
|
||||
|
||||
Different compression libraries like zlib-ng may arrive at different
|
||||
values. Get them from the file system instead of hard-coding them to
|
||||
make switching the compression library (or changing the compression
|
||||
level) easier.
|
||||
|
||||
Reported-by: Ondrej Pohorelsky <opohorel@redhat.com>
|
||||
Signed-off-by: René Scharfe <l.s.r@web.de>
|
||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||
---
|
||||
t/t6300-for-each-ref.sh | 18 +++++++++---------
|
||||
1 file changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/t/t6300-for-each-ref.sh b/t/t6300-for-each-ref.sh
|
||||
index 00a060df0b5e81..c65c795fce2a58 100755
|
||||
--- a/t/t6300-for-each-ref.sh
|
||||
+++ b/t/t6300-for-each-ref.sh
|
||||
@@ -20,12 +20,13 @@ setdate_and_increment () {
|
||||
export GIT_COMMITTER_DATE GIT_AUTHOR_DATE
|
||||
}
|
||||
|
||||
-test_expect_success setup '
|
||||
- test_oid_cache <<-EOF &&
|
||||
- disklen sha1:138
|
||||
- disklen sha256:154
|
||||
- EOF
|
||||
+test_object_file_size () {
|
||||
+ oid=$(git rev-parse "$1")
|
||||
+ path=".git/objects/$(test_oid_to_path $oid)"
|
||||
+ test_file_size "$path"
|
||||
+}
|
||||
|
||||
+test_expect_success setup '
|
||||
# setup .mailmap
|
||||
cat >.mailmap <<-EOF &&
|
||||
A Thor <athor@example.com> A U Thor <author@example.com>
|
||||
@@ -94,7 +95,6 @@ test_atom () {
|
||||
}
|
||||
|
||||
hexlen=$(test_oid hexsz)
|
||||
-disklen=$(test_oid disklen)
|
||||
|
||||
test_atom head refname refs/heads/main
|
||||
test_atom head refname: refs/heads/main
|
||||
@@ -129,7 +129,7 @@ test_atom head push:strip=1 remotes/myfork/main
|
||||
test_atom head push:strip=-1 main
|
||||
test_atom head objecttype commit
|
||||
test_atom head objectsize $((131 + hexlen))
|
||||
-test_atom head objectsize:disk $disklen
|
||||
+test_atom head objectsize:disk $(test_object_file_size refs/heads/main)
|
||||
test_atom head deltabase $ZERO_OID
|
||||
test_atom head objectname $(git rev-parse refs/heads/main)
|
||||
test_atom head objectname:short $(git rev-parse --short refs/heads/main)
|
||||
@@ -203,8 +203,8 @@ test_atom tag upstream ''
|
||||
test_atom tag push ''
|
||||
test_atom tag objecttype tag
|
||||
test_atom tag objectsize $((114 + hexlen))
|
||||
-test_atom tag objectsize:disk $disklen
|
||||
-test_atom tag '*objectsize:disk' $disklen
|
||||
+test_atom tag objectsize:disk $(test_object_file_size refs/tags/testtag)
|
||||
+test_atom tag '*objectsize:disk' $(test_object_file_size refs/heads/main)
|
||||
test_atom tag deltabase $ZERO_OID
|
||||
test_atom tag '*deltabase' $ZERO_OID
|
||||
test_atom tag objectname $(git rev-parse refs/tags/testtag)
|
11
git.spec
11
git.spec
@ -92,7 +92,7 @@
|
||||
#global rcrev .rc0
|
||||
|
||||
Name: git
|
||||
Version: 2.43.0
|
||||
Version: 2.43.5
|
||||
Release: 2%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
@ -143,11 +143,6 @@ Patch5: 0003-t-lib-git-svn-try-harder-to-find-a-port.patch
|
||||
# https://github.com/git/git/commit/2386535511d1181afd4e892e2a866ffe5e1d7d21
|
||||
Patch6: git-2.43.0-slow-shallow-clones.patch
|
||||
|
||||
# t6300: avoid hard-coding object sizes
|
||||
#
|
||||
# https://github.com/git/git/commit/fbc6526ea651565889e437ce7b12c762ef858813
|
||||
Patch7: git-2.43.0-t6300-avoid-hard-coding-object-sizes.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: %{_bindir}/pod2man
|
||||
@ -1109,6 +1104,10 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Fri Nov 15 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.5-2
|
||||
- Sync version with the hotfix branch
|
||||
- Related: RHEL-64984
|
||||
|
||||
* Thu Nov 14 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.0-2
|
||||
- Add fix for extremely slow shallow clones
|
||||
- Repair t6300 on s390x
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.43.0.tar.xz) = d0c1694ae23ff7d523e617b98d7c9a9753a2ee58f92c21b67a192d1c57398a62ff9c1a34558ae31af8dc8d95122c219f39f654e99a3b4e7cfc3dd07be9e13203
|
||||
SHA512 (git-2.43.0.tar.sign) = 4ff055db9b7100c40427a570f8fb6ec4b5ea943d197597ca8061924afbc6eb46d28aaf46c31679addb8adaf4f672e7efb96e088b789d172b5270420a7e5fde67
|
||||
SHA512 (git-2.43.5.tar.xz) = 7c507e29d102d3597ae867c0bfb1befc4facdfb1934b2361ee390c4cd9f68753aef1542a955a0684441f4ccad2b3a7fa560677466ccab4ee457499b0968d41b0
|
||||
SHA512 (git-2.43.5.tar.sign) = 234877413715cccbd99a17e3be940b563d942717b65eabdfac703591cf5fe209d587d27d81f49564844772647612da9b7bc48e31b5530ef7afb48dbdba60cc58
|
||||
|
Loading…
Reference in New Issue
Block a user