update to 2.34.0
Release notes:
https://github.com/git/git/raw/v2.34.0/Documentation/RelNotes/2.34.0.txt
Add `BuildRequires: openssh` for the `ssh-keygen` command; it is needed
to test the newly-added ssh signing support¹. Refer to the `gpg.format`
and `gpg.ssh.*` variables in git-config(1) for details.
[Unfortunately, openssh-8.7 has a bug in the requisite `ssh-keygen -Y
find-principals` command, which will limit the usefulness of this
feature on Fedora 35/36 until openssh is either rebased to 8.8 or the
patch² is backported. The git testsuite has been taught to skip the
tests when this bug is present, in upstream ca7a5bf4bd (t/lib-gpg: avoid
broken versions of ssh-keygen, 2021-11-10), but that won't help users
who try out this new feature. Hopefully we can get openssh-8.7 in
Fedora 35 & 36 patched or updated before too long.]
We have `Requires: openssh-clients` in git-core already. The
openssh-clients package requires openssh so we don't _need_ to add an
install-time requirement to ensure the `ssh-keygen` command is
available.
Ignore RUNTIME_PREFIX and SYMLINKS_WINDOWS test prerequisites when
looking for missing test suite BuildRequires³.
The RUNTIME_PREFIX prerequisite was added in b7d11a0f5d (tests: exercise
the RUNTIME_PREFIX feature, 2021-07-24)⁴. It is used to build binaries
which can be easily relocated, which we don't need in our builds.
The SYMLINKS_WINDOWS prerequisite was added in 3e7d4888e5 (mingw: align
symlinks-related rmdir() behavior with Linux, 2021-08-02)⁵. It is, as
the name implies, Windows-specific.
¹ https://github.com/git/git/commit/b5726a5d9c (ssh signing: preliminary
refactoring and clean-up, 2021-09-10) and the commits which follow.
² https://github.com/openssh/openssh-portable/commit/ca0e455b93,
https://github.com/openssh/openssh-portable/commit/4afe431da9, and
https://www.mail-archive.com/source-changes@openbsd.org/msg127496.html
(plus the replies, which point out the typo in the first patch)
³ fa92661
(Add grep patterns for checking skipped tests, 2019-02-02)
⁴ https://github.com/git/git/commit/b7d11a0f5d
⁵ https://github.com/git/git/commit/3e7d4888e5
This commit is contained in:
parent
4414f619e3
commit
e8896ce365
@ -1,28 +0,0 @@
|
||||
From c221f23ebe2defeb31cfcab6387f8985b5c863bb Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Tue, 12 Oct 2021 21:00:55 -0400
|
||||
Subject: [PATCH] doc: add bundle-format to TECH_DOCS
|
||||
|
||||
A link to the bundle-format was added in 5c8273d57c (bundle doc: rewrite
|
||||
the "DESCRIPTION" section, 2021-07-31).
|
||||
|
||||
Ensure `technical/bundle-format.html` is created to avoid a broken link
|
||||
in `git-bundle.html`.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
Documentation/Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Documentation/Makefile b/Documentation/Makefile
|
||||
index f5605b7767..2021568cd5 100644
|
||||
--- a/Documentation/Makefile
|
||||
+++ b/Documentation/Makefile
|
||||
@@ -90,6 +90,7 @@ SP_ARTICLES += $(API_DOCS)
|
||||
TECH_DOCS += MyFirstContribution
|
||||
TECH_DOCS += MyFirstObjectWalk
|
||||
TECH_DOCS += SubmittingPatches
|
||||
+TECH_DOCS += technical/bundle-format
|
||||
TECH_DOCS += technical/hash-function-transition
|
||||
TECH_DOCS += technical/http-protocol
|
||||
TECH_DOCS += technical/index-format
|
@ -12,6 +12,8 @@ missing NATIVE_CRLF
|
||||
missing !PCRE
|
||||
missing !PTHREADS
|
||||
missing RFC1991
|
||||
missing RUNTIME_PREFIX
|
||||
missing SYMLINKS_WINDOWS
|
||||
missing TAR_NEEDS_PAX_FALLBACK
|
||||
missing UTF8_NFD_TO_NFC
|
||||
missing WINDOWS
|
||||
|
12
git.spec
12
git.spec
@ -79,8 +79,8 @@
|
||||
#global rcrev .rc0
|
||||
|
||||
Name: git
|
||||
Version: 2.33.1
|
||||
Release: 3%{?rcrev}%{?dist}
|
||||
Version: 2.34.0
|
||||
Release: 1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -112,10 +112,6 @@ Source99: print-failed-test-output
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# fix the broken link in git-bundle.html
|
||||
# https://lore.kernel.org/git/20211013032852.959985-1-tmz@pobox.com/
|
||||
Patch1: 0001-doc-add-bundle-format-to-TECH_DOCS.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: %{_bindir}/pod2man
|
||||
@ -215,6 +211,7 @@ BuildRequires: jgit
|
||||
%endif
|
||||
# endif fedora (except i386 and s390x)
|
||||
BuildRequires: mod_dav_svn
|
||||
BuildRequires: openssh
|
||||
BuildRequires: perl(App::Prove)
|
||||
BuildRequires: perl(CGI)
|
||||
BuildRequires: perl(CGI::Carp)
|
||||
@ -1004,6 +1001,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||
|
||||
%changelog
|
||||
* Mon Nov 15 2021 Todd Zullinger <tmz@pobox.com> - 2.34.0-1
|
||||
- update to 2.34.0
|
||||
|
||||
* Sun Nov 14 2021 Todd Zullinger <tmz@pobox.com> - 2.33.1-3
|
||||
- add more git-email perl dependencies
|
||||
- Resolves: rhbz#2020487
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.33.1.tar.xz) = 16d417183232e1057bea754d59cdf4bbacc5f1527d1de6ee04cdd293a2512bfa7208e20f6130816605528b59cb1bc3188c5bddf1a42c1413095ee74e44dd2f91
|
||||
SHA512 (git-2.33.1.tar.sign) = b1a8d3b4ebbf5db43eb1234446b903d62637999390e59f94b9793bf8c8c302ff6d7b74f48cdfe3b4a304f767641ccba96479ddf5a19c6e6d4861da1e568e9760
|
||||
SHA512 (git-2.34.0.tar.xz) = 3102c1ebe408eb549ebd0f9b1420663ed04a2720e4dc676c1854a9e7b8306bb49dc931b734aa7eb612eb7adc2ad92730c0d2dd704dbd859ba61e5ceba909fcc3
|
||||
SHA512 (git-2.34.0.tar.sign) = 28713fe9b0c8bfac4937b31cdf54ff427c784547932c2002032fa1ae40757d6fdfd291ce9ea24eeecf480816643359530cf93b4e9d4fac40b1deb987577a3de3
|
||||
|
Loading…
Reference in New Issue
Block a user