Remove the unused patch for DESTDIR in the python instlibdir
Changes in git-1.8.5 made the files it patched irrelevant. We also no longer need to remove %{python_sitelib} or %{gitcoredir}/git-remote-testgit.
This commit is contained in:
parent
a0d6c92a21
commit
d784390dc8
@ -1,29 +0,0 @@
|
|||||||
From d40d33173dc24d9b7ad6f5071994f90b5f9a71e8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Todd Zullinger <tmz@pobox.com>
|
|
||||||
Date: Wed, 27 Mar 2013 14:01:57 -0400
|
|
||||||
Subject: [PATCH] Drop DESTDIR from python instlibdir
|
|
||||||
|
|
||||||
When building packages, we install to DESTDIR but we don't want this to
|
|
||||||
end up hard-coded in the scripts.
|
|
||||||
|
|
||||||
This needs discussed upstream to find a proper solution.
|
|
||||||
---
|
|
||||||
git_remote_helpers/Makefile | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/git_remote_helpers/Makefile b/git_remote_helpers/Makefile
|
|
||||||
index 3d12232..36d40b5 100644
|
|
||||||
--- a/git_remote_helpers/Makefile
|
|
||||||
+++ b/git_remote_helpers/Makefile
|
|
||||||
@@ -38,7 +38,7 @@ install: $(pysetupfile)
|
|
||||||
$(PYTHON_PATH) $(pysetupfile) install --prefix $(DESTDIR_SQ)$(prefix)
|
|
||||||
|
|
||||||
instlibdir: $(pysetupfile)
|
|
||||||
- @echo "$(DESTDIR_SQ)$(prefix)/$(PYLIBDIR)"
|
|
||||||
+ @echo "$(prefix)/$(PYLIBDIR)"
|
|
||||||
|
|
||||||
clean:
|
|
||||||
$(QUIET)$(PYTHON_PATH) $(pysetupfile) $(QUIETSETUP) clean -a
|
|
||||||
--
|
|
||||||
1.8.1
|
|
||||||
|
|
13
git.spec
13
git.spec
@ -51,7 +51,7 @@
|
|||||||
|
|
||||||
Name: git
|
Name: git
|
||||||
Version: 1.8.5.3
|
Version: 1.8.5.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Fast Version Control System
|
Summary: Fast Version Control System
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -72,9 +72,6 @@ Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
|||||||
# https://bugzilla.redhat.com/600411
|
# https://bugzilla.redhat.com/600411
|
||||||
Patch3: git-1.7-el5-emacs-support.patch
|
Patch3: git-1.7-el5-emacs-support.patch
|
||||||
Patch5: 0001-git-subtree-Use-gitexecdir-instead-of-libexecdir.patch
|
Patch5: 0001-git-subtree-Use-gitexecdir-instead-of-libexecdir.patch
|
||||||
# This fixes the build when python is enabled. Needs discussion upstream to
|
|
||||||
# find a proper solution.
|
|
||||||
Patch6: 0001-Drop-DESTDIR-from-python-instlibdir.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -317,7 +314,6 @@ Requires: emacs-git = %{version}-%{release}
|
|||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
#%patch6 -p1
|
|
||||||
|
|
||||||
%if %{use_prebuilt_docs}
|
%if %{use_prebuilt_docs}
|
||||||
mkdir -p prebuilt_docs/{html,man}
|
mkdir -p prebuilt_docs/{html,man}
|
||||||
@ -433,10 +429,6 @@ find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
|
|||||||
find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
|
find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
|
||||||
find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
find %{buildroot} -type f -name perllocal.pod -exec rm -f {} ';'
|
||||||
|
|
||||||
# Remove remote-helper python libraries and scripts, these are not ready for
|
|
||||||
# use yet
|
|
||||||
rm -rf %{buildroot}%{python_sitelib} %{buildroot}%{gitcoredir}/git-remote-testgit
|
|
||||||
|
|
||||||
# git-archimport is not supported
|
# git-archimport is not supported
|
||||||
find %{buildroot} Documentation -type f -name 'git-archimport*' -exec rm -f {} ';'
|
find %{buildroot} Documentation -type f -name 'git-archimport*' -exec rm -f {} ';'
|
||||||
|
|
||||||
@ -641,6 +633,9 @@ rm -rf %{buildroot}
|
|||||||
# No files for you!
|
# No files for you!
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 16 2014 Todd Zullinger <tmz@pobox.com> - 1.8.5.3-2
|
||||||
|
- Drop unused python DESTIR patch
|
||||||
|
|
||||||
* Thu Jan 16 2014 Ondrej Oprala <ooprala@redhat.com> - 1.8.5.3-1
|
* Thu Jan 16 2014 Ondrej Oprala <ooprala@redhat.com> - 1.8.5.3-1
|
||||||
* Update to 1.8.5.3
|
* Update to 1.8.5.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user