Add git-daemon and gitweb packages
This commit is contained in:
parent
aed6e3618e
commit
c97cf8e11f
11
git-1.5-gitweb-home-link.patch
Normal file
11
git-1.5-gitweb-home-link.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- git-1.5.0.6/gitweb/gitweb.perl~ 2007-03-30 01:37:05.000000000 +0100
|
||||
+++ git-1.5.0.6/gitweb/gitweb.perl 2007-05-07 08:31:37.000000000 +0100
|
||||
@@ -39,7 +39,7 @@ our $projectroot = "++GITWEB_PROJECTROOT
|
||||
our $home_link = $my_uri || "/";
|
||||
|
||||
# string of the home link on top of all pages
|
||||
-our $home_link_str = "++GITWEB_HOME_LINK_STR++";
|
||||
+our $home_link_str = $ENV{'SERVER_NAME'} ? "git://" . $ENV{'SERVER_NAME'} : "projects";
|
||||
|
||||
# name of your site or organization to appear in page titles
|
||||
# replace this with something more descriptive for clearer bookmarks
|
6
git.conf.httpd
Normal file
6
git.conf.httpd
Normal file
@ -0,0 +1,6 @@
|
||||
Alias /git /var/www/git
|
||||
|
||||
<Directory /var/www/git>
|
||||
Options +ExecCGI
|
||||
AddHandler cgi-script .cgi
|
||||
</Directory>
|
47
git.spec
47
git.spec
@ -1,13 +1,16 @@
|
||||
# Pass --without docs to rpmbuild if you don't want the documentation
|
||||
Name: git
|
||||
Version: 1.5.2.2
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Git core and tools
|
||||
License: GPL
|
||||
Group: Development/Tools
|
||||
URL: http://kernel.org/pub/software/scm/git/
|
||||
Source: http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.gz
|
||||
Source1: git-init.el
|
||||
Source2: git.xinetd
|
||||
Source3: git.conf.httpd
|
||||
Patch0: git-1.5-gitweb-home-link.patch
|
||||
BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel, expat-devel, emacs %{!?_without_docs:, xmlto, asciidoc > 6.0.3}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: git-core, git-svn, git-cvs, git-arch, git-email, gitk, git-gui, perl-Git, emacs-git
|
||||
@ -30,6 +33,22 @@ and full access to internals.
|
||||
|
||||
These are the core tools with minimal dependencies.
|
||||
|
||||
%package daemon
|
||||
Summary: Git protocol dæmon
|
||||
Group: Development/Tools
|
||||
Requires: git-core = %{version}-%{release}
|
||||
%description daemon
|
||||
The git dæmon for supporting git:// access to git repositories
|
||||
|
||||
%package -n gitweb
|
||||
Summary: Simple web interface to git repositories
|
||||
Group: Development/Tools
|
||||
Requires: git-core = %{version}-%{release}
|
||||
|
||||
%description -n gitweb
|
||||
Simple web interface to track changes in git repositories
|
||||
|
||||
|
||||
%package svn
|
||||
Summary: Git tools for importing Subversion repositories
|
||||
Group: Development/Tools
|
||||
@ -92,6 +111,7 @@ Requires: git-core = %{version}-%{release}, emacs-common
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
|
||||
@ -113,17 +133,26 @@ for elc in $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/*.elc ; do
|
||||
done
|
||||
install -Dpm 644 %{SOURCE1} \
|
||||
$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/site-start.d/git-init.el
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
|
||||
install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
|
||||
mkdir -p $RPM_BUILD_ROOT/var/www/git
|
||||
install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
|
||||
install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
|
||||
install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
|
||||
|
||||
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
|
||||
find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
|
||||
find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
|
||||
|
||||
(find $RPM_BUILD_ROOT%{_bindir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
|
||||
(find $RPM_BUILD_ROOT%{_bindir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
|
||||
(find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
|
||||
%if %{!?_without_docs:1}0
|
||||
(find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
|
||||
%else
|
||||
rm -rf $RPM_BUILD_ROOT%{_mandir}
|
||||
%endif
|
||||
mkdir -p $RPM_BUILD_ROOT/srv/git
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -189,10 +218,24 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/git-core/
|
||||
%doc README COPYING Documentation/*.txt
|
||||
|
||||
%files daemon
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/git-daemon
|
||||
%config(noreplace)%{_sysconfdir}/xinetd.d/git
|
||||
/srv/git
|
||||
|
||||
%files -n gitweb
|
||||
%defattr(-,root,root)
|
||||
/var/www/git/
|
||||
%{_sysconfdir}/httpd/conf.d/git.conf
|
||||
%{!?_without_docs: %doc Documentation/*.html Documentation/howto}
|
||||
%{!?_without_docs: %doc Documentation/technical}
|
||||
|
||||
%changelog
|
||||
* Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
|
||||
- Add git-daemon and gitweb packages
|
||||
|
||||
* Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
|
||||
- Add emacs-git package (#235431)
|
||||
|
||||
|
16
git.xinetd
Normal file
16
git.xinetd
Normal file
@ -0,0 +1,16 @@
|
||||
# default: off
|
||||
# description: The git dæmon allows git repositories to be exported using
|
||||
# the git:// protocol.
|
||||
|
||||
service git
|
||||
{
|
||||
disable = yes
|
||||
socket_type = stream
|
||||
wait = no
|
||||
user = nobody
|
||||
server = /usr/bin/git-daemon
|
||||
server_args = --base-path=/srv/git --export-all --user-path=public_git --syslog --inetd --verbose
|
||||
log_on_failure += USERID
|
||||
# xinetd doesn't do this by default. bug #195265
|
||||
flags = IPv6
|
||||
}
|
Loading…
Reference in New Issue
Block a user