import git-2.26.2-1.el8
This commit is contained in:
commit
c8e5bc9b67
2
.git.metadata
Normal file
2
.git.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
bdb5eb6c014d7c372be70782a5155d964abe2c08 SOURCES/git-2.26.2.tar.xz
|
||||||
|
097b8da13939ac9f51f97a5659184c1d96fb0973 SOURCES/gpgkey-junio.asc
|
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/git-2.26.2.tar.xz
|
||||||
|
SOURCES/gpgkey-junio.asc
|
@ -0,0 +1,12 @@
|
|||||||
|
diff -ur a/git-instaweb.sh b/git-instaweb.sh
|
||||||
|
--- a/git-instaweb.sh 2020-04-20 17:52:30.000000000 +0200
|
||||||
|
+++ b/git-instaweb.sh 2020-05-27 12:36:20.725300334 +0200
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
# Defaults:
|
||||||
|
|
||||||
|
# if installed, it doesn't need further configuration (module_path)
|
||||||
|
-test -z "$httpd" && httpd='lighttpd -f'
|
||||||
|
+test -z "$httpd" && httpd='httpd -f'
|
||||||
|
|
||||||
|
# Default is @@GITWEBDIR@@
|
||||||
|
test -z "$root" && root='@@GITWEBDIR@@'
|
@ -0,0 +1,57 @@
|
|||||||
|
From 68e7090f31b4d4f2c7b9a25240af61149fbebb5c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alban Gruin <alban.gruin@gmail.com>
|
||||||
|
Date: Mon, 30 Mar 2020 14:42:35 +0200
|
||||||
|
Subject: [PATCH 1/2] sequencer: don't abbreviate a command if it doesn't have
|
||||||
|
a short form
|
||||||
|
|
||||||
|
When the sequencer is requested to abbreviate commands, it will replace
|
||||||
|
those that do not have a short form (eg. `noop') by a comment mark.
|
||||||
|
`noop' serves no purpose, except when fast-forwarding (ie. by running
|
||||||
|
`git rebase'). Removing it will break this command when
|
||||||
|
`rebase.abbreviateCommands' is set to true.
|
||||||
|
|
||||||
|
Teach todo_list_to_strbuf() to check if a command has an actual
|
||||||
|
short form, and to ignore it if not.
|
||||||
|
|
||||||
|
Signed-off-by: Alban Gruin <alban.gruin@gmail.com>
|
||||||
|
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||||
|
---
|
||||||
|
sequencer.c | 9 ++++++---
|
||||||
|
1 file changed, 6 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/sequencer.c b/sequencer.c
|
||||||
|
index e528225e78..c2f97f94ba 100644
|
||||||
|
--- a/sequencer.c
|
||||||
|
+++ b/sequencer.c
|
||||||
|
@@ -1564,7 +1564,7 @@ static const char *command_to_string(const enum todo_command command)
|
||||||
|
|
||||||
|
static char command_to_char(const enum todo_command command)
|
||||||
|
{
|
||||||
|
- if (command < TODO_COMMENT && todo_command_info[command].c)
|
||||||
|
+ if (command < TODO_COMMENT)
|
||||||
|
return todo_command_info[command].c;
|
||||||
|
return comment_line_char;
|
||||||
|
}
|
||||||
|
@@ -4947,6 +4947,8 @@ static void todo_list_to_strbuf(struct repository *r, struct todo_list *todo_lis
|
||||||
|
max = num;
|
||||||
|
|
||||||
|
for (item = todo_list->items, i = 0; i < max; i++, item++) {
|
||||||
|
+ char cmd;
|
||||||
|
+
|
||||||
|
/* if the item is not a command write it and continue */
|
||||||
|
if (item->command >= TODO_COMMENT) {
|
||||||
|
strbuf_addf(buf, "%.*s\n", item->arg_len,
|
||||||
|
@@ -4955,8 +4957,9 @@ static void todo_list_to_strbuf(struct repository *r, struct todo_list *todo_lis
|
||||||
|
}
|
||||||
|
|
||||||
|
/* add command to the buffer */
|
||||||
|
- if (flags & TODO_LIST_ABBREVIATE_CMDS)
|
||||||
|
- strbuf_addch(buf, command_to_char(item->command));
|
||||||
|
+ cmd = command_to_char(item->command);
|
||||||
|
+ if ((flags & TODO_LIST_ABBREVIATE_CMDS) && cmd)
|
||||||
|
+ strbuf_addch(buf, cmd);
|
||||||
|
else
|
||||||
|
strbuf_addstr(buf, command_to_string(item->command));
|
||||||
|
|
||||||
|
--
|
||||||
|
2.26.0
|
@ -0,0 +1,63 @@
|
|||||||
|
From de9f1d3ef45ec885339d04f9e34293eb2de8605d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alban Gruin <alban.gruin@gmail.com>
|
||||||
|
Date: Mon, 30 Mar 2020 14:42:36 +0200
|
||||||
|
Subject: [PATCH 2/2] t3432: test `--merge' with `rebase.abbreviateCommands =
|
||||||
|
true', too
|
||||||
|
|
||||||
|
When fast forwarding, `git --merge' should act the same whether
|
||||||
|
`rebase.abbreviateCommands' is set or not, but so far it was not the
|
||||||
|
case. This duplicates the tests ensuring that `--merge' works when fast
|
||||||
|
forwarding to check if it also works with abbreviated commands.
|
||||||
|
|
||||||
|
Signed-off-by: Alban Gruin <alban.gruin@gmail.com>
|
||||||
|
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
||||||
|
---
|
||||||
|
t/t3432-rebase-fast-forward.sh | 24 +++++++++++++++++++-----
|
||||||
|
1 file changed, 19 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/t/t3432-rebase-fast-forward.sh b/t/t3432-rebase-fast-forward.sh
|
||||||
|
index 6c9d4a1375..6f0452c0ea 100755
|
||||||
|
--- a/t/t3432-rebase-fast-forward.sh
|
||||||
|
+++ b/t/t3432-rebase-fast-forward.sh
|
||||||
|
@@ -28,10 +28,12 @@ test_rebase_same_head () {
|
||||||
|
shift &&
|
||||||
|
cmp_f="$1" &&
|
||||||
|
shift &&
|
||||||
|
- test_rebase_same_head_ $status_n $what_n $cmp_n " --apply" "$*" &&
|
||||||
|
- test_rebase_same_head_ $status_f $what_f $cmp_f " --apply --no-ff" "$*"
|
||||||
|
- test_rebase_same_head_ $status_n $what_n $cmp_n " --merge" "$*" &&
|
||||||
|
- test_rebase_same_head_ $status_f $what_f $cmp_f " --merge --no-ff" "$*"
|
||||||
|
+ test_rebase_same_head_ $status_n $what_n $cmp_n 0 " --apply" "$*" &&
|
||||||
|
+ test_rebase_same_head_ $status_f $what_f $cmp_f 0 " --apply --no-ff" "$*"
|
||||||
|
+ test_rebase_same_head_ $status_n $what_n $cmp_n 0 " --merge" "$*" &&
|
||||||
|
+ test_rebase_same_head_ $status_f $what_f $cmp_f 0 " --merge --no-ff" "$*"
|
||||||
|
+ test_rebase_same_head_ $status_n $what_n $cmp_n 1 " --merge" "$*" &&
|
||||||
|
+ test_rebase_same_head_ $status_f $what_f $cmp_f 1 " --merge --no-ff" "$*"
|
||||||
|
}
|
||||||
|
|
||||||
|
test_rebase_same_head_ () {
|
||||||
|
@@ -41,9 +43,21 @@ test_rebase_same_head_ () {
|
||||||
|
shift &&
|
||||||
|
cmp="$1" &&
|
||||||
|
shift &&
|
||||||
|
+ abbreviate="$1" &&
|
||||||
|
+ shift &&
|
||||||
|
flag="$1"
|
||||||
|
shift &&
|
||||||
|
- test_expect_$status "git rebase$flag $* with $changes is $what with $cmp HEAD" "
|
||||||
|
+ if test $abbreviate -eq 1
|
||||||
|
+ then
|
||||||
|
+ msg="git rebase$flag $* (rebase.abbreviateCommands = true) with $changes is $what with $cmp HEAD"
|
||||||
|
+ else
|
||||||
|
+ msg="git rebase$flag $* with $changes is $what with $cmp HEAD"
|
||||||
|
+ fi &&
|
||||||
|
+ test_expect_$status "$msg" "
|
||||||
|
+ if test $abbreviate -eq 1
|
||||||
|
+ then
|
||||||
|
+ test_config rebase.abbreviateCommands true
|
||||||
|
+ fi &&
|
||||||
|
oldhead=\$(git rev-parse HEAD) &&
|
||||||
|
test_when_finished 'git reset --hard \$oldhead' &&
|
||||||
|
cp .git/logs/HEAD expect &&
|
||||||
|
--
|
||||||
|
2.26.0
|
70
SOURCES/git-2.26.2-core-crypto-hmac.patch
Normal file
70
SOURCES/git-2.26.2-core-crypto-hmac.patch
Normal file
@ -0,0 +1,70 @@
|
|||||||
|
diff -ur a/builtin/receive-pack.c b/builtin/receive-pack.c
|
||||||
|
--- a/builtin/receive-pack.c 2020-04-20 17:52:30.000000000 +0200
|
||||||
|
+++ b/builtin/receive-pack.c 2020-05-26 16:03:25.809849961 +0200
|
||||||
|
@@ -28,6 +28,8 @@
|
||||||
|
#include "protocol.h"
|
||||||
|
#include "commit-reach.h"
|
||||||
|
#include "worktree.h"
|
||||||
|
+#include <openssl/hmac.h>
|
||||||
|
+#include <openssl/evp.h>
|
||||||
|
|
||||||
|
static const char * const receive_pack_usage[] = {
|
||||||
|
N_("git receive-pack <git-dir>"),
|
||||||
|
@@ -418,43 +420,11 @@
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static void hmac(unsigned char *out,
|
||||||
|
+static inline void hmac(unsigned char *out,
|
||||||
|
const char *key_in, size_t key_len,
|
||||||
|
const char *text, size_t text_len)
|
||||||
|
{
|
||||||
|
- unsigned char key[GIT_MAX_BLKSZ];
|
||||||
|
- unsigned char k_ipad[GIT_MAX_BLKSZ];
|
||||||
|
- unsigned char k_opad[GIT_MAX_BLKSZ];
|
||||||
|
- int i;
|
||||||
|
- git_hash_ctx ctx;
|
||||||
|
-
|
||||||
|
- /* RFC 2104 2. (1) */
|
||||||
|
- memset(key, '\0', GIT_MAX_BLKSZ);
|
||||||
|
- if (the_hash_algo->blksz < key_len) {
|
||||||
|
- the_hash_algo->init_fn(&ctx);
|
||||||
|
- the_hash_algo->update_fn(&ctx, key_in, key_len);
|
||||||
|
- the_hash_algo->final_fn(key, &ctx);
|
||||||
|
- } else {
|
||||||
|
- memcpy(key, key_in, key_len);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
- /* RFC 2104 2. (2) & (5) */
|
||||||
|
- for (i = 0; i < sizeof(key); i++) {
|
||||||
|
- k_ipad[i] = key[i] ^ 0x36;
|
||||||
|
- k_opad[i] = key[i] ^ 0x5c;
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
- /* RFC 2104 2. (3) & (4) */
|
||||||
|
- the_hash_algo->init_fn(&ctx);
|
||||||
|
- the_hash_algo->update_fn(&ctx, k_ipad, sizeof(k_ipad));
|
||||||
|
- the_hash_algo->update_fn(&ctx, text, text_len);
|
||||||
|
- the_hash_algo->final_fn(out, &ctx);
|
||||||
|
-
|
||||||
|
- /* RFC 2104 2. (6) & (7) */
|
||||||
|
- the_hash_algo->init_fn(&ctx);
|
||||||
|
- the_hash_algo->update_fn(&ctx, k_opad, sizeof(k_opad));
|
||||||
|
- the_hash_algo->update_fn(&ctx, out, the_hash_algo->rawsz);
|
||||||
|
- the_hash_algo->final_fn(out, &ctx);
|
||||||
|
+ HMAC(EVP_sha1(), key_in, key_len, text, text_len, out, NULL);
|
||||||
|
}
|
||||||
|
|
||||||
|
static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
|
||||||
|
diff -ur a/Makefile b/Makefile
|
||||||
|
--- a/Makefile 2020-04-20 17:52:30.000000000 +0200
|
||||||
|
+++ b/Makefile 2020-05-26 16:04:48.672551647 +0200
|
||||||
|
@@ -1832,6 +1832,8 @@
|
||||||
|
BASIC_CFLAGS += -DHAVE_GETDELIM
|
||||||
|
endif
|
||||||
|
|
||||||
|
+EXTLIBS += -lcrypto
|
||||||
|
+
|
||||||
|
ifneq ($(PROCFS_EXECUTABLE_PATH),)
|
||||||
|
procfs_executable_path_SQ = $(subst ','\'',$(PROCFS_EXECUTABLE_PATH))
|
||||||
|
BASIC_CFLAGS += '-DPROCFS_EXECUTABLE_PATH="$(procfs_executable_path_SQ)"'
|
BIN
SOURCES/git-2.26.2.tar.sign
Normal file
BIN
SOURCES/git-2.26.2.tar.sign
Normal file
Binary file not shown.
@ -0,0 +1,26 @@
|
|||||||
|
From 09891c65a5f7409ce0bd37daced0ff31fbb1b1c9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Todd Zullinger <tmz@pobox.com>
|
||||||
|
Date: Mon, 23 Mar 2009 00:03:36 -0400
|
||||||
|
Subject: [PATCH] git-cvsimport: Ignore cvsps-2.2b1 Branches: output
|
||||||
|
|
||||||
|
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||||
|
---
|
||||||
|
git-cvsimport.perl | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/git-cvsimport.perl b/git-cvsimport.perl
|
||||||
|
index e439202..d020f1a 100755
|
||||||
|
--- a/git-cvsimport.perl
|
||||||
|
+++ b/git-cvsimport.perl
|
||||||
|
@@ -952,7 +952,7 @@ while (<CVS>) {
|
||||||
|
} elsif (/^-+$/) { # end of unknown-line processing
|
||||||
|
$state = 1;
|
||||||
|
} elsif ($state != 11) { # ignore stuff when skipping
|
||||||
|
- print STDERR "* UNKNOWN LINE * $_\n";
|
||||||
|
+ print STDERR "* UNKNOWN LINE * $_\n" unless /^Branches: /;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
commit() if $branch and $state != 11;
|
||||||
|
--
|
||||||
|
1.6.2.2
|
||||||
|
|
9
SOURCES/git-gui.desktop
Normal file
9
SOURCES/git-gui.desktop
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
[Desktop Entry]
|
||||||
|
Name=Git GUI
|
||||||
|
GenericName=Git GUI
|
||||||
|
Comment=A graphical interface to Git
|
||||||
|
Exec=git gui
|
||||||
|
Icon=/usr/share/git-gui/lib/git-gui.ico
|
||||||
|
Terminal=false
|
||||||
|
Type=Application
|
||||||
|
Categories=Development;
|
9
SOURCES/git.socket
Normal file
9
SOURCES/git.socket
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
[Unit]
|
||||||
|
Description=Git Activation Socket
|
||||||
|
|
||||||
|
[Socket]
|
||||||
|
ListenStream=9418
|
||||||
|
Accept=true
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=sockets.target
|
14
SOURCES/git.xinetd.in
Normal file
14
SOURCES/git.xinetd.in
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
# default: off
|
||||||
|
# description: The git dæmon allows git repositories to be exported using \
|
||||||
|
# the git:// protocol.
|
||||||
|
|
||||||
|
service git
|
||||||
|
{
|
||||||
|
disable = yes
|
||||||
|
socket_type = stream
|
||||||
|
wait = no
|
||||||
|
user = nobody
|
||||||
|
server = @GITEXECDIR@/git-daemon
|
||||||
|
server_args = --base-path=@BASE_PATH@ --export-all --user-path=public_git --syslog --inetd --verbose
|
||||||
|
log_on_failure += USERID
|
||||||
|
}
|
10
SOURCES/git@.service.in
Normal file
10
SOURCES/git@.service.in
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
[Unit]
|
||||||
|
Description=Git Repositories Server Daemon
|
||||||
|
Documentation=man:git-daemon(1)
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
User=nobody
|
||||||
|
ExecStart=-@GITEXECDIR@/git-daemon --base-path=@BASE_PATH@ --export-all \
|
||||||
|
--user-path=public_git --inetd --log-destination=stderr --verbose
|
||||||
|
StandardInput=socket
|
||||||
|
StandardError=journal
|
7
SOURCES/gitweb-httpd.conf
Normal file
7
SOURCES/gitweb-httpd.conf
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
Alias /git /var/www/git
|
||||||
|
|
||||||
|
<Directory /var/www/git>
|
||||||
|
Options +ExecCGI
|
||||||
|
AddHandler cgi-script .cgi
|
||||||
|
DirectoryIndex gitweb.cgi
|
||||||
|
</Directory>
|
53
SOURCES/gitweb.conf.in
Normal file
53
SOURCES/gitweb.conf.in
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
# The gitweb config file is a fragment of perl code. You can set variables
|
||||||
|
# using "our $variable = value"; text from "#" character until the end of a
|
||||||
|
# line is ignored. See perlsyn(1) man page for details.
|
||||||
|
#
|
||||||
|
# See /usr/share/doc/gitweb-*/README and /usr/share/doc/gitweb-*/INSTALL for
|
||||||
|
# more details and available configuration variables.
|
||||||
|
|
||||||
|
# Set the path to git projects. This is an absolute filesystem path which will
|
||||||
|
# be prepended to the project path.
|
||||||
|
#our $projectroot = "@PROJECTROOT@";
|
||||||
|
|
||||||
|
# Set the list of git base URLs used for URL to where fetch project from, i.e.
|
||||||
|
# the full URL is "$git_base_url/$project". By default this is empty
|
||||||
|
#our @git_base_url_list = qw(git://git.example.com
|
||||||
|
# ssh://git.example.com@PROJECTROOT@);
|
||||||
|
|
||||||
|
# Enable the 'blame' blob view, showing the last commit that modified
|
||||||
|
# each line in the file. This can be very CPU-intensive. Disabled by default
|
||||||
|
#$feature{'blame'}{'default'} = [1];
|
||||||
|
#
|
||||||
|
# Allow projects to override the default setting via git config file.
|
||||||
|
# Example: gitweb.blame = 0|1;
|
||||||
|
#$feature{'blame'}{'override'} = 1;
|
||||||
|
|
||||||
|
# Disable the 'snapshot' link, providing a compressed archive of any tree. This
|
||||||
|
# can potentially generate high traffic if you have large project. Enabled for
|
||||||
|
# .tar.gz snapshots by default.
|
||||||
|
#
|
||||||
|
# Value is a list of formats defined in %known_snapshot_formats that you wish
|
||||||
|
# to offer.
|
||||||
|
#$feature{'snapshot'}{'default'} = [];
|
||||||
|
#
|
||||||
|
# Allow projects to override the default setting via git config file.
|
||||||
|
# Example: gitweb.snapshot = tbz2,zip; (use "none" to disable)
|
||||||
|
#$feature{'snapshot'}{'override'} = 1;
|
||||||
|
|
||||||
|
# Disable grep search, which will list the files in currently selected tree
|
||||||
|
# containing the given string. This can be potentially CPU-intensive, of
|
||||||
|
# course. Enabled by default.
|
||||||
|
#$feature{'grep'}{'default'} = [0];
|
||||||
|
#
|
||||||
|
# Allow projects to override the default setting via git config file.
|
||||||
|
# Example: gitweb.grep = 0|1;
|
||||||
|
#$feature{'grep'}{'override'} = 1;
|
||||||
|
|
||||||
|
# Disable the pickaxe search, which will list the commits that modified a given
|
||||||
|
# string in a file. This can be practical and quite faster alternative to
|
||||||
|
# 'blame', but still potentially CPU-intensive. Enabled by default.
|
||||||
|
#$feature{'pickaxe'}{'default'} = [0];
|
||||||
|
#
|
||||||
|
# Allow projects to override the default setting via git config file.
|
||||||
|
# Example: gitweb.pickaxe = 0|1;
|
||||||
|
#$feature{'pickaxe'}{'override'} = 1;
|
13
SOURCES/print-failed-test-output
Normal file
13
SOURCES/print-failed-test-output
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
shopt -s failglob
|
||||||
|
|
||||||
|
# Print output from failing tests
|
||||||
|
dashes=$(printf "%80s" '' | tr ' ' '-')
|
||||||
|
for exit_file in t/test-results/*.exit; do
|
||||||
|
[ "$(cat "$exit_file")" -eq 0 ] && continue
|
||||||
|
out_file="${exit_file%exit}out"
|
||||||
|
printf '\n%s\n%s\n%s\n' "$dashes" "$out_file" "$dashes"
|
||||||
|
cat "$out_file"
|
||||||
|
done
|
||||||
|
exit 1
|
2447
SPECS/git.spec
Normal file
2447
SPECS/git.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user