Update to 2.22.0-rc1
Release notes: https://www.kernel.org/pub/software/scm/git/docs/RelNotes/2.22.0.txt
This commit is contained in:
parent
40e1625e1a
commit
ba20d6b2a2
@ -1,40 +0,0 @@
|
||||
From aeb950b03f0ef22bdfee09b505349521e68b7e54 Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Tue, 14 May 2019 01:47:25 +0000
|
||||
Subject: [PATCH] test-lib: try harder to ensure a working jgit
|
||||
|
||||
The JGIT prereq uses 'type jgit' to determine whether jgit is present.
|
||||
While this should be sufficient, if the jgit found is broken we'll waste
|
||||
time running tests which fail due to no fault of our own.
|
||||
|
||||
Use 'jgit --version' instead, to catch some badly broken jgit
|
||||
installations.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
I ran into such a broken jgit on Fedora >= 30¹. This is clearly a
|
||||
problem in the Fedora jgit package which will hopefully be resolved
|
||||
soon. But it may be good to avoid wasting time debugging tests which
|
||||
fail due to such a broken tool which is outside of our control.
|
||||
|
||||
¹ https://bugzilla.redhat.com/1709624
|
||||
|
||||
t/test-lib.sh | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/t/test-lib.sh b/t/test-lib.sh
|
||||
index 908ddb9c46..599fd70e14 100644
|
||||
--- a/t/test-lib.sh
|
||||
+++ b/t/test-lib.sh
|
||||
@@ -1522,7 +1522,7 @@ test_lazy_prereq NOT_ROOT '
|
||||
'
|
||||
|
||||
test_lazy_prereq JGIT '
|
||||
- type jgit
|
||||
+ jgit --version
|
||||
'
|
||||
|
||||
# SANITY is about "can you correctly predict what the filesystem would
|
||||
--
|
||||
2.20.1
|
||||
|
8
git.spec
8
git.spec
@ -84,11 +84,11 @@
|
||||
%endif
|
||||
|
||||
# Define for release candidates
|
||||
%global rcrev .rc0
|
||||
%global rcrev .rc1
|
||||
|
||||
Name: git
|
||||
Version: 2.22.0
|
||||
Release: 0.0%{?rcrev}%{?dist}
|
||||
Release: 0.1%{?rcrev}%{?dist}
|
||||
Summary: Fast Version Control System
|
||||
License: GPLv2
|
||||
URL: https://git-scm.com/
|
||||
@ -120,10 +120,6 @@ Source99: print-failed-test-output
|
||||
# https://bugzilla.redhat.com/490602
|
||||
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
|
||||
|
||||
# https://bugzilla.redhat.com/1709624
|
||||
# https://public-inbox.org/git/20190514020520.GI3654@pobox.com/
|
||||
Patch1: 0001-test-lib-try-harder-to-ensure-a-working-jgit.patch
|
||||
|
||||
%if %{with docs}
|
||||
# pod2man is needed to build Git.3pm
|
||||
BuildRequires: %{_bindir}/pod2man
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (git-2.22.0.rc0.tar.xz) = f3a928fbb36693917ed268d6ed6f47dcf0c56e2976a2d0bf0b9d209cb48ca309d0568f230752a765cd8d4f264db57b93542a481a5bf30bd1cec5eea7246c6342
|
||||
SHA512 (git-2.22.0.rc0.tar.sign) = 188b89b5813f1820a18a29c4df6cc72f5208ade8d628a0948cb6fc11651b6ff7199900932a8af962b0729c260ce9081e1b491b0099f1940e15218b245b00da00
|
||||
SHA512 (git-2.22.0.rc1.tar.xz) = c3d878f7b5b4c4d67d4c8f20ab07a54c2bb4c2646feedc4a670e28849bb544177ab7aab6458bc982774c954b6c05b8e83acf3b9c5eeecccb34776cac16cfe1e1
|
||||
SHA512 (git-2.22.0.rc1.tar.sign) = a900071d502ec2eaa6c5befd33c4fd62f5fa7be56aafb6e432193ad3d3810846fd191a831b97fc5e64bfbd839968a101ee5ae7f1c318d23a6c062cd220a3bce6
|
||||
|
Loading…
Reference in New Issue
Block a user