update to 2.40.0-rc2
Release notes: https://github.com/git/git/raw/v2.40.0-rc2/Documentation/RelNotes/2.40.0.txt
This commit is contained in:
parent
01d712d89b
commit
b8be89a815
@ -1,40 +0,0 @@
|
|||||||
From d9165bef5810df216e0eb4fac62d59cbf19446e4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Ren=C3=A9=20Scharfe?= <l.s.r@web.de>
|
|
||||||
Date: Tue, 28 Feb 2023 17:13:27 +0100
|
|
||||||
Subject: [PATCH] range-diff: avoid compiler warning when char is unsigned
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Since 2b15969f61 (range-diff: let '--abbrev' option takes effect,
|
|
||||||
2023-02-20), GCC 11.3 on Ubuntu 22.04 on aarch64 warns (and errors
|
|
||||||
out if the make variable DEVELOPER is set):
|
|
||||||
|
|
||||||
range-diff.c: In function ‘output_pair_header’:
|
|
||||||
range-diff.c:388:20: error: comparison is always false due to limited range of data type [-Werror=type-limits]
|
|
||||||
388 | if (abbrev < 0)
|
|
||||||
| ^
|
|
||||||
cc1: all warnings being treated as errors
|
|
||||||
|
|
||||||
That's because char is unsigned on that platform. Use int instead, just
|
|
||||||
like in struct diff_options, to copy the value faithfully.
|
|
||||||
|
|
||||||
Signed-off-by: René Scharfe <l.s.r@web.de>
|
|
||||||
Signed-off-by: Junio C Hamano <gitster@pobox.com>
|
|
||||||
---
|
|
||||||
range-diff.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/range-diff.c b/range-diff.c
|
|
||||||
index 086365dffb..4bd65ab749 100644
|
|
||||||
--- a/range-diff.c
|
|
||||||
+++ b/range-diff.c
|
|
||||||
@@ -383,7 +383,7 @@ static void output_pair_header(struct diff_options *diffopt,
|
|
||||||
const char *color_new = diff_get_color_opt(diffopt, DIFF_FILE_NEW);
|
|
||||||
const char *color_commit = diff_get_color_opt(diffopt, DIFF_COMMIT);
|
|
||||||
const char *color;
|
|
||||||
- char abbrev = diffopt->abbrev;
|
|
||||||
+ int abbrev = diffopt->abbrev;
|
|
||||||
|
|
||||||
if (abbrev < 0)
|
|
||||||
abbrev = DEFAULT_ABBREV;
|
|
12
git.spec
12
git.spec
@ -74,14 +74,14 @@
|
|||||||
%{?!bash_completions_dir:%global bash_completions_dir %{_datadir}/bash-completion/completions}
|
%{?!bash_completions_dir:%global bash_completions_dir %{_datadir}/bash-completion/completions}
|
||||||
|
|
||||||
# Define for release candidates
|
# Define for release candidates
|
||||||
%global rcrev .rc1
|
%global rcrev .rc2
|
||||||
|
|
||||||
# Set path to the package-notes linker script
|
# Set path to the package-notes linker script
|
||||||
%global _package_note_file %{_builddir}/%{name}-%{version}%{?rcrev}/.package_note-%{name}-%{version}-%{release}.%{_arch}.ld
|
%global _package_note_file %{_builddir}/%{name}-%{version}%{?rcrev}/.package_note-%{name}-%{version}-%{release}.%{_arch}.ld
|
||||||
|
|
||||||
Name: git
|
Name: git
|
||||||
Version: 2.40.0
|
Version: 2.40.0
|
||||||
Release: 0.1%{?rcrev}%{?dist}
|
Release: 0.2%{?rcrev}%{?dist}
|
||||||
Summary: Fast Version Control System
|
Summary: Fast Version Control System
|
||||||
License: BSD-3-Clause AND GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
|
License: BSD-3-Clause AND GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later AND MIT
|
||||||
URL: https://git-scm.com/
|
URL: https://git-scm.com/
|
||||||
@ -123,11 +123,6 @@ Patch2: 0002-t-lib-git-daemon-try-harder-to-find-a-port.patch
|
|||||||
# https://github.com/tmzullinger/git/commit/aa5105dc11
|
# https://github.com/tmzullinger/git/commit/aa5105dc11
|
||||||
Patch3: 0003-t-lib-git-svn-try-harder-to-find-a-port.patch
|
Patch3: 0003-t-lib-git-svn-try-harder-to-find-a-port.patch
|
||||||
|
|
||||||
# Avoid range-diff issues on non-x86 arches
|
|
||||||
# https://github.com/git/git/commit/d9165bef58
|
|
||||||
# https://lore.kernel.org/git/Y%2F+paI8WGSmEbv%2Fw@pobox.com/
|
|
||||||
Patch4: 0001-range-diff-avoid-compiler-warning-when-char-is-unsig.patch
|
|
||||||
|
|
||||||
%if %{with docs}
|
%if %{with docs}
|
||||||
# pod2man is needed to build Git.3pm
|
# pod2man is needed to build Git.3pm
|
||||||
BuildRequires: %{_bindir}/pod2man
|
BuildRequires: %{_bindir}/pod2man
|
||||||
@ -1040,6 +1035,9 @@ rmdir --ignore-fail-on-non-empty "$testdir"
|
|||||||
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
%{?with_docs:%{_pkgdocdir}/git-svn.html}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 07 2023 Todd Zullinger <tmz@pobox.com> - 2.40.0-0.2.rc2
|
||||||
|
- update to 2.40.0-rc2
|
||||||
|
|
||||||
* Wed Mar 01 2023 Todd Zullinger <tmz@pobox.com> - 2.40.0-0.1.rc1
|
* Wed Mar 01 2023 Todd Zullinger <tmz@pobox.com> - 2.40.0-0.1.rc1
|
||||||
- update to 2.40.0-rc1
|
- update to 2.40.0-rc1
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (git-2.40.0.rc1.tar.xz) = edff125736d498d964ec876a30a2bd4b0a115df58747e8f2c94c7c45fb5b112925336fecc7cbb2f2037e9f890d10753e988499be222fc41a176fec68f2a157fc
|
SHA512 (git-2.40.0.rc2.tar.xz) = e038ddc97b95a0e2e50fcc35308041586e4c40891ce9e491b922a9fe0c40fd816387d84266acfd55565f90c4b6d794880952d6ce8ea19e68ef5451ace9a76548
|
||||||
SHA512 (git-2.40.0.rc1.tar.sign) = aabee9d1810fd93858ad884ae0aaefb5a6965543715e02f8abf787cfc47794f53d6527399787e8aca20ceb9e8b6df4c9d1be2cbbd517ecb11eae3c05e77ffcb5
|
SHA512 (git-2.40.0.rc2.tar.sign) = 5a0c16b11293ccea1c90612b2076e202c23ce8bd16584ab5416397906b2bddf21b23397ef0bf5517093e85986bfd258233e45f0509b2336dc7e566e99cf1d32b
|
||||||
|
Loading…
Reference in New Issue
Block a user