Drop DESTDIR from python instlibdir

When building packages, we install to DESTDIR but we don't want this to
end up hard-coded in the scripts.

This needs discussed upstream to find a proper solution.
This commit is contained in:
Todd Zullinger 2013-03-28 15:31:24 -04:00
parent c0b6baf54b
commit b1cee32757
2 changed files with 34 additions and 0 deletions

View File

@ -0,0 +1,29 @@
From d40d33173dc24d9b7ad6f5071994f90b5f9a71e8 Mon Sep 17 00:00:00 2001
From: Todd Zullinger <tmz@pobox.com>
Date: Wed, 27 Mar 2013 14:01:57 -0400
Subject: [PATCH] Drop DESTDIR from python instlibdir
When building packages, we install to DESTDIR but we don't want this to
end up hard-coded in the scripts.
This needs discussed upstream to find a proper solution.
---
git_remote_helpers/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/git_remote_helpers/Makefile b/git_remote_helpers/Makefile
index 3d12232..36d40b5 100644
--- a/git_remote_helpers/Makefile
+++ b/git_remote_helpers/Makefile
@@ -38,7 +38,7 @@ install: $(pysetupfile)
$(PYTHON_PATH) $(pysetupfile) install --prefix $(DESTDIR_SQ)$(prefix)
instlibdir: $(pysetupfile)
- @echo "$(DESTDIR_SQ)$(prefix)/$(PYLIBDIR)"
+ @echo "$(prefix)/$(PYLIBDIR)"
clean:
$(QUIET)$(PYTHON_PATH) $(pysetupfile) $(QUIETSETUP) clean -a
--
1.8.1

View File

@ -55,6 +55,9 @@ Patch1: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
# https://bugzilla.redhat.com/600411 # https://bugzilla.redhat.com/600411
Patch3: git-1.7-el5-emacs-support.patch Patch3: git-1.7-el5-emacs-support.patch
Patch5: 0001-git-subtree-Use-gitexecdir-instead-of-libexecdir.patch Patch5: 0001-git-subtree-Use-gitexecdir-instead-of-libexecdir.patch
# This fixes the build when python is enabled. Needs discussion upstream to
# find a proper solution.
Patch6: 0001-Drop-DESTDIR-from-python-instlibdir.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -261,6 +264,7 @@ Requires: emacs-git = %{version}-%{release}
%patch3 -p1 %patch3 -p1
%endif %endif
%patch5 -p1 %patch5 -p1
%patch6 -p1
%if %{use_prebuilt_docs} %if %{use_prebuilt_docs}
mkdir -p prebuilt_docs/{html,man} mkdir -p prebuilt_docs/{html,man}
@ -546,6 +550,7 @@ rm -rf %{buildroot}
%changelog %changelog
* Wed Mar 27 2013 Todd Zullinger <tmz@pobox.com> - 1.8.2-2 * Wed Mar 27 2013 Todd Zullinger <tmz@pobox.com> - 1.8.2-2
- Require perl(Term::ReadKey) for git add --interactive (#928328) - Require perl(Term::ReadKey) for git add --interactive (#928328)
- Drop DESTDIR from python instlibdir
* Tue Mar 19 2013 Adam Tkac <atkac redhat com> - 1.8.2-1 * Tue Mar 19 2013 Adam Tkac <atkac redhat com> - 1.8.2-1
- update to 1.8.2 - update to 1.8.2