couple minor git fixes
This commit is contained in:
parent
d8f9dac0cc
commit
ae67d257ac
32
cvsserver-Avoid-miscounting-bytes-in-Perl-v5.8.x.patch
Normal file
32
cvsserver-Avoid-miscounting-bytes-in-Perl-v5.8.x.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 4f88d3e0cbf443cd309c2c881209f3366f14023d Mon Sep 17 00:00:00 2001
|
||||
From: Martin Langhoff <martin@catalyst.net.nz>
|
||||
Date: Thu, 7 Dec 2006 16:38:50 +1300
|
||||
Subject: [PATCH] cvsserver: Avoid miscounting bytes in Perl v5.8.x
|
||||
|
||||
At some point between v5.6 and 5.8 Perl started to assume its input,
|
||||
output and filehandles are UTF-8. This breaks the counting of bytes
|
||||
for the CVS protocol, resulting in the client expecting less data
|
||||
than we actually send, and storing truncated files.
|
||||
|
||||
Signed-off-by: Martin Langhoff <martin@catalyst.net.nz>
|
||||
Signed-off-by: Junio C Hamano <junkio@cox.net>
|
||||
Signed-off-by: Chris Wright <chrisw@sous-sol.org>
|
||||
---
|
||||
git-cvsserver.perl | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/git-cvsserver.perl b/git-cvsserver.perl
|
||||
index ca519b7..197014d 100755
|
||||
--- a/git-cvsserver.perl
|
||||
+++ b/git-cvsserver.perl
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
use strict;
|
||||
use warnings;
|
||||
+use bytes;
|
||||
|
||||
use Fcntl;
|
||||
use File::Temp qw/tempdir tempfile/;
|
||||
--
|
||||
1.4.4.2
|
||||
|
22
git-install-non-executable-doc-files.patch
Normal file
22
git-install-non-executable-doc-files.patch
Normal file
@ -0,0 +1,22 @@
|
||||
No need to install documentation files as executable.
|
||||
|
||||
Signed-off-by: Chris Wright <chrisw@sous-sol.org>
|
||||
---
|
||||
Documentation/Makefile | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Documentation/Makefile b/Documentation/Makefile
|
||||
index c00f5f6..d68bc4a 100644
|
||||
--- a/Documentation/Makefile
|
||||
+++ b/Documentation/Makefile
|
||||
@@ -56,8 +56,8 @@ man7: $(DOC_MAN7)
|
||||
|
||||
install: man
|
||||
$(INSTALL) -d -m755 $(DESTDIR)$(man1dir) $(DESTDIR)$(man7dir)
|
||||
- $(INSTALL) $(DOC_MAN1) $(DESTDIR)$(man1dir)
|
||||
- $(INSTALL) $(DOC_MAN7) $(DESTDIR)$(man7dir)
|
||||
+ $(INSTALL) -m644 $(DOC_MAN1) $(DESTDIR)$(man1dir)
|
||||
+ $(INSTALL) -m644 $(DOC_MAN7) $(DESTDIR)$(man7dir)
|
||||
|
||||
|
||||
#
|
10
git.spec
10
git.spec
@ -1,12 +1,14 @@
|
||||
# Pass --without docs to rpmbuild if you don't want the documentation
|
||||
Name: git
|
||||
Version: 1.4.4.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Git core and tools
|
||||
License: GPL
|
||||
Group: Development/Tools
|
||||
URL: http://kernel.org/pub/software/scm/git/
|
||||
Source: http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.gz
|
||||
Patch0: git-install-non-executable-doc-files.patch
|
||||
Patch1: cvsserver-Avoid-miscounting-bytes-in-Perl-v5.8.x.patch
|
||||
BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel, expat-devel %{!?_without_docs:, xmlto, asciidoc > 6.0.3}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: git-core, git-svn, git-cvs, git-arch, git-email, gitk, perl-Git
|
||||
@ -82,6 +84,8 @@ Perl interface to Git
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" WITH_OWN_SUBPROCESS_PY=YesPlease \
|
||||
@ -155,6 +159,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{!?_without_docs: %doc Documentation/*.html }
|
||||
|
||||
%changelog
|
||||
* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
|
||||
- no need to install manpages executable (bz 216790)
|
||||
- use bytes for git-cvsserver
|
||||
|
||||
* Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
|
||||
- git-1.4.4.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user